Contribute
Register

macOS10.12.4 Wake up black screen(Only backlight)

RehabMan

Moderator
Joined
May 3, 2012
Messages
192,090
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Thanks for your reply.
I am not sure if you mean the kext in my clover should be installed to the system volume? And how can I get right usbconnector value,any suggestions? Thank you
Installing kexts is fully explained in post #2 of my guide.
https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/

The USBInjectAll (custom SSDT) guide is linked from the FAQ.
http://www.tonymacx86.com/el-capitan-laptop-support/164990-faq-read-first-laptop-frequent-questions.html
 
Joined
Nov 24, 2015
Messages
54
CPU
i7 5500u
Graphics
intel 5500
Mac
Classic Mac
Mobile Phone
Your kexts are not installed correctly.
All kexts you need must be installed to the system volume.

HECI should be renamed to IMEI.
Your USB configuration is wrong (UsbConnector values are wrong).
USB WiFi is not recommended. Install compatible PCIe WiFi instead.
Remove unnecessary software such as: net.telestream.driver.TelestreamAudio

Also try different ig-platform-id values.
Forgive my foolishness, I think the kexts I need is in system volume. If you mean they must be installed in system/library/extension ? Could you give me an example?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
192,090
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Forgive my foolishness, I think the kexts I need is in system volume. If you mean they must be installed in system/library/extension ? Could you give me an example?
Example:
FakeSMC.kext is definitely a member of the set "kexts you need" (it is a kext everyone needs).

Your kextcache output shows it is not installed to the system volume.
Installed to the system volume means in /L/E or /S/L/E (your choice).
 
Joined
Nov 24, 2015
Messages
54
CPU
i7 5500u
Graphics
intel 5500
Mac
Classic Mac
Mobile Phone
Example:
FakeSMC.kext is definitely a member of the set "kexts you need" (it is a kext everyone needs).

Your kextcache output shows it is not installed to the system volume.
Installed to the system volume means in /L/E or /S/L/E (your choice).
thanks you for correct my mistake. I always think the FakeSMC.kext can be installed to the clover/kexts/others.i will try all your suggestions . thank you very much!
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
192,090
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Joined
Nov 24, 2015
Messages
54
CPU
i7 5500u
Graphics
intel 5500
Mac
Classic Mac
Mobile Phone
Your kexts are not installed correctly.
All kexts you need must be installed to the system volume.

HECI should be renamed to IMEI.
Your USB configuration is wrong (UsbConnector values are wrong).
USB WiFi is not recommended. Install compatible PCIe WiFi instead.
Remove unnecessary software such as: net.telestream.driver.TelestreamAudio

Also try different ig-platform-id values.
Hi Rehabman. I have followed your suggestion . but the issue is still exist .

more details about this issue:

when I try to turn off the display by anyway (not only by click sleep button ),the display is off. then turn on the display by click keyboard in anytime(about 1 sencond or more) and the backlight will appear.

It means this issue is not appear with sleep mode. just turn off the display and turn on . it will appear.

I have try different ig-platform-id values but nothing better than 0x16160002 in my machine.

this is the the latest Reporting files. you may need.

Thanks you for your suggestions.
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
192,090
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hi Rehabman. I have followed your suggestion . but the issue is still exist .

more details about this issue:

when I try to turn off the display by anyway (not only by click sleep button ),the display is off. then turn on the display by click keyboard in anytime(about 1 sencond or more) and the backlight will appear.

It means this issue is not appear with sleep mode. just turn off the display and turn on . it will appear.

I have try different ig-platform-id values but nothing better than 0x16160002 in my machine.

this is the the latest Reporting files. you may need.

Thanks you for your suggestions.
Your backlight configuration is wrong.
0x16160002 uses PWMMax of 0x56c. SSDT-PNLF.aml assumes 0xad9 for all Broadwell device-ids.
You need to set LMAX to 0x56c via SSDT-Config.aml (as per brightness guide).
 
Joined
Nov 24, 2015
Messages
54
CPU
i7 5500u
Graphics
intel 5500
Mac
Classic Mac
Mobile Phone
Hi RehabMan, sorry for reply late, I have set LMAX to 0x56c , but the issue('wake up' with black screen only backlight) is still exist.



And I found whether I use AppleBacklightInjector.kext or not (just use config patches and SSDT-PNLF.aml,SSDT-config). the backlight control is fine on my machine . and I found when I use AppleBacklightInjector.kext to l/e ,in terminal ,I use sudo touch /System/Library/Extensions && sudo kextcache -u /. it seems AppleBacklightInjector.kext was loaded.
but in apple extension interface. It appears unload(you can see it below).

And I found a new kext AGDCBacklightControl.kext load when I not install the AppleBacklightInjector to l/e.
when a install AppleBacklightInjector to l/e. rebuild cache,restart computer . although the AppleBacklightInjector is not load in apple extension interface .the AGDCBacklightControl.kext can not load . In other words .the AGDCBacklightControl.kext can only
load when l delete the AppleBacklightInjector.kext in l/e.

My system is 10.13beta (17A360a) ,In last versions 10.13 beta (17A352a)I can see the AppleBacklightInjector appears load in Apple extension interface.

if AppleBacklightInjector.kext are broken in 10.13 beta(17A360a). but I feel my backlight control can work fine without it.


sorry for my poor English.

Thanks for your suggestion ! thank you very much.

here is the latest the latest Reporting files.
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
192,090
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Joined
Aug 14, 2012
Messages
12
Motherboard
Elitebook 850G2
CPU
i5-5300U
Graphics
HD 5500, 1920x1080
Is this problem resolved or still under investigation?
I have very similar symptoms in Sierra 10.12.6.
Attached my problem reporting files.
 

Attachments

Top