Contribute
Register

macOS 10.15 Catalina is Now Available on the Mac App Store

Joined
Aug 28, 2019
Messages
2
Motherboard
GIGABYTE GA-Z270N-Gaming 5
CPU
Intel Core i5 6500 3.20 GHz
Graphics
Internal
No issues upgrading from Mojave to Catalina. However, my Logitech receiver isn't working.
Got my Logitech keyboard and mouse to work by installing LCC version 3.9.9
 
Joined
Apr 1, 2011
Messages
141
Motherboard
Asus X-299 Prime deluxe,Asus X-99 Deluxe II
CPU
i9-7980XE, Xeon E5-2696 v4
Graphics
XFX Radeon VII, Sapphire Nitro+ Radeon RX Vega 64 8GB
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
Like betas, so does the upgrade to the macOS Catalina 10.15 final, is running suave suavecito, on my X-99 :thumbup:
Possible to share the kernel patches required for the X99? I'm basing on KPG's guide, stuck at the apple logo....

UPDATE: never mind, found the issue. Updated successfully. Will post work flow on X99/E5-2696v4 later.
 
Last edited:
Joined
Jul 9, 2018
Messages
56
Motherboard
Gigabyte x58 USB3
CPU
i7-960
Graphics
GT 430
Mobile Phone
  1. Other
I am going to update my HP8300 Desktop core i7 3770 with Nvidia GT710. Running the last version of Mojave to Catalina, I upgraded kexts as stated in the first post before starting the update. Wish me luck. I will post feedback soon. :)
 
Joined
Apr 10, 2016
Messages
611
Motherboard
<< need model # >> See Forum Rules !!
CPU
I3 5020U
Graphics
Hd5500
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
USB touchscreen no longer but-in support. Also multi-fingers touchscreen gesture is changed, like 5 finger magnify
 
Joined
Sep 28, 2017
Messages
55
Motherboard
GIGABYTE GA-Z170X-Gaming 6
CPU
i7 7700
Graphics
Radeon ROG 560 4gb
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Hello guys,

I was on Mojave 10.14.4 and updated the following before installing Catalina :

Clover to 5070
Lilu from 1.3.5 to 1.3.8
AppleALC 1.3.6 to 1.4.1

However after multiple reboot, I get this screen :

View attachment 429798

How could I display logs/troubleshoot and find out what's wrong ?
Here my EFI folder.

If anyone can help me, it would be really cool :)
Hey there mate! I had the same issue. Let me figure out my EFI partition, and I will
Hello guys,

I was on Mojave 10.14.4 and updated the following before installing Catalina :

Clover to 5070
Lilu from 1.3.5 to 1.3.8
AppleALC 1.3.6 to 1.4.1

However after multiple reboot, I get this screen :

View attachment 429798

How could I display logs/troubleshoot and find out what's wrong ?
Here my EFI folder.

If anyone can help me, it would be really cool :)
Hey there mate! This might work. I got almost the same setup as you, and this did the trick. I'm more used to the setup where I don't see the full logs just cuz I don't like it. But use this EFI. It worked for me, and, once I installed it, I used my own old EFI partition to the install. Like I said, is all up to taste, but this did do the work for me try it.
 

Attachments

  • EFI.zip
    3.6 MB · Views: 80
Joined
May 31, 2017
Messages
137
Motherboard
Gigabyte Z590 Aorus Elite AX
CPU
i7-10700KF
Graphics
RX 5700 XT
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. iOS
Had to disable the Intel Graphic in the bios due to a reboot loop (was active because of the preview bug on Mojave). Lost the Realtek sound device, appleALC seems not to work here... have to investigate. Everything else seems ok.

*UPDATE* : After having upgraded the kext in /Library/Extensions it seems to work fine. So, as an upgrade from Mojave, everything seems to work perfectly.
Hi @Theophilius, I have similar hardware than you. And I am running Mojave 10.14.6 well. My upgrade to Catalina did not go well. I updated to latest Clover and copied in FaceSMC....while the upgrade seemed to run fine (some 5-10-minut freezes along the way)...upon final reboot my monitor turned black. I could actually login using HDMI instead of Displayport, but network is not working and generally seems laggy.

Anyway, can you tell me which KEXTs you have. And potentially share you config.plist as well? The config.plist because i think I might have some old unnecessary items in mine.

THANKS!
 
Joined
May 31, 2017
Messages
137
Motherboard
Gigabyte Z590 Aorus Elite AX
CPU
i7-10700KF
Graphics
RX 5700 XT
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. iOS
I can confirm this update worked fine for :
- Quad-Core Intel Core i7 (6700K)
- Radeon RX 580 8 GB
Can you share the KEXT you use? I have similar hardware but I am struggling...
Thanks!
 
Joined
Aug 9, 2019
Messages
18
Motherboard
Gigabyte z390m gaming
CPU
Intel core i5 9400
Graphics
Sapphire Radeon rx580
Mac
  1. iMac
Everything seems to be running perfect in Catalina so far.
TB3 display working, reset/shutdown.
I had alot of issues with a few other things due to Windows being on a separate M.2. I removed it, and my restart times were cut in half, things ran smoother, and TB3 display started working. If anyone has any issues and you are dual booting windows. try removing the Windows SSD first. I was about to reinstall everything and decided to try this first, just in case.
 
Joined
Jan 30, 2017
Messages
80
Motherboard
Dell Inspiron 580
CPU
i5-750
Graphics
HD 5450
Mac
  1. iMac
  2. MacBook Air
Mobile Phone
  1. iOS
i am going to update my HP8300 Desktop core i7 3770 with nvidia GT710 running the last version of Mojave to Catalina i upgraded kexts as staited in the first post before starting the update wish me luck i will post feedback soon :)
keeping an eye on this. I have similar specs but too afraid to take that leap.
 
Joined
Jan 7, 2012
Messages
33
Motherboard
Asus-Z170K
CPU
i7-6700
Graphics
RX 580
Mac
  1. iMac
Classic Mac
  1. iMac
Mobile Phone
  1. iOS
Can you share the KEXT you use? I have similar hardware but I am struggling...
Thanks!
I also have the same hardware. i7-6700, 580 Pulse 8GB, Z170k Motherboard. Just upgraded to Catalina.
 
Top