Contribute
Register

macOS 10.15 Catalina is Now Available on the Mac App Store

Joined
Nov 3, 2017
Messages
289
Motherboard
Gigabyte Z390 Designare
CPU
i7-9700K
Graphics
Radeon VII
Mac
MacBook Pro
Classic Mac
iMac
Mobile Phone
iOS
So basically how many of you got it to work? My mac went to sh.it when I did the 1st update of Mojave. It takes 5 minutes to start, 3 alone to get to the bootloader. :think:
Yes and with all the other problems with Catalina and just went back to Mohave for now.
 
Joined
Mar 9, 2012
Messages
2,156
Motherboard
Gigabyte Z390 AORUS Pro WFI
CPU
i5 << need model # >> See Rules !!
Graphics
RX 580
Mac
iMac, Mac Pro
Mobile Phone
iOS
If it's taking that long to boot up that tells me your settings BIOS and/or EFI are completely out of whack - my board same chipset and same manufacture takes 30 seconds max to reach the desktop from BIOS post beep with clover. With OC test disk 10 to 15 seconds with verbose mode. Use a spare USB drive and test the attached EFI Folder to see the result.
 

Attachments

Last edited:
Joined
Apr 5, 2018
Messages
3
Motherboard
Gigabyte B360M GAMING HD
CPU
I5 9600K
Graphics
RX 560
Installed MacOS-Catalina 10.15.1 with Clover

BOARD - Gigabyte B360M GAMING HD - BOARD
CPU - CORE I5 9600K
GRAPHICS CARD - GIGABYTE AMD RX 560 OC 4GB
RAM - CORSAIR VENGANCE 16GB
CPU COOLER - COOLER MASTER LIQUIDLITE 120
SSD - GIGABYTE 480


screen2.png
 
Joined
Nov 26, 2012
Messages
1,605
Motherboard
Gigabyte Z490 D
CPU
i7-10700K
Graphics
RX 580
Mac
MacBook Pro
Mobile Phone
iOS
@pastrychef Is it absolutely necessary for the update to 10.15, that one needs to install Clover v2.5? The two drives that I have that has (had) 10.14.5(6) has crapped out on me when doing the update to v2.5 5099. The last of the cloned drives that I am presently using is set to clover 4920. If I can clone the other two NVMe drives I may try to install 10.15(x). I think that I bricked the WD Black 500gb after installing 5099 making the drive is inoperable, then attempts to clone the drive back to its original state failed. Flustered in Colorado. Add to the above BIOS at times does not even show any drives available and it will cycle over and over again. Would a BIOS reset be appropriate? Thank you for your assistance. I have also tried doing fresh installs three times.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
15,092
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
@pastrychef Is it absolutely necessary for the update to 10.15, that one needs to install Clover v2.5? The two drives that I have that has (had) 10.14.5(6) has crapped out on me when doing the update to v2.5 5099. The last of the cloned drives that I am presently using is set to clover 4920. If I can clone the other two NVMe drives I may try to install 10.15(x). I think that I bricked the WD Black 500gb after installing 5099 making the drive is inoperable, then attempts to clone the drive back to its original state failed. Flustered in Colorado. Add to the above BIOS at times does not even show any drives available and it will cycle over and over again. Would a BIOS reset be appropriate? Thank you for your assistance. I have also tried doing fresh installs three times.
No, it's not absolutely necessary to be on the latest version of Clover. However, I never tried going so many versions back... My guess is that 4920 should work. Updating your kexts should help.
 
Joined
Nov 26, 2012
Messages
1,605
Motherboard
Gigabyte Z490 D
CPU
i7-10700K
Graphics
RX 580
Mac
MacBook Pro
Mobile Phone
iOS
After (finally) updating to Clover v2.5 5099 successfully, I did the update to 10.15.1 Running very smooth and much faster than Mojave. I wonder when Apple will name an OS after a place in New York? Something like "Flatbush" or "Canarsie" or "The Bronx". ;)
 
Joined
Jul 13, 2016
Messages
2,109
Motherboard
Gigabyte Z370 Gaming 5
CPU
I9 9900k
Graphics
Vega 64
Mac
Mac mini, Mac Pro
Mobile Phone
iOS
After (finally) updating to Clover v2.5 5099 successfully, I did the update to 10.15.1 Running very smooth and much faster than Mojave. I wonder when Apple will name an OS after a place in New York? Something like "Flatbush" or "Canarsie" or "The Bronx". ;)
Not saying never but Apple is pretty set on naming after places in CA after they get done with CA they will likely move onto another Theme. Before, it was big cats, other then Mavericks, then they moved onto places in CA. Keep in mind that none of the names are Cities they are state treasures so to speak... like Statue of Liberty!
 
Joined
Nov 26, 2012
Messages
1,605
Motherboard
Gigabyte Z490 D
CPU
i7-10700K
Graphics
RX 580
Mac
MacBook Pro
Mobile Phone
iOS
Not saying never but apple is pretty set on naming after places in CA after they get done with CA they will likely move onto another Theme. Before It was big cats, other then Mavericks, then they moved onto places in CA. Keep in mind that none of the names are Cities they are state treasures so to speak... like Statue of Liberty!
I was of course joking. Hence, the winky eye.
 
Joined
Nov 20, 2011
Messages
21
Motherboard
Gigabyte Z490 Vision-D
CPU
i7-10700
Graphics
RX 580
Mac
iMac, MacBook Pro
Mobile Phone
iOS
I was finally able to migrate to Catalina (10.15.1)

Thanks to CodeDJ for pushing me in the right direction with his EFI folder (https://www.tonymacx86.com/threads/...able-on-the-mac-app-store.284169/post-2024014)

I was using FakeSMC, switched to VirtualSMC for this one and it worked.

It was a very smooth install on a new ssd.

This is what I ended using

BOOT
Clover 5099

KEXTS
VirtualSMC.kext 1.0.9
SMCProcessor.kext 1.0.9
SMCSuperIO.kext 1.0.9
AppleALC.kext 1.4.3
Lilu.kext 1.3.9
WhateverGreen.kext 1.3.4
IntelMausiEthernet.kext 2.5.0
AtherosE2200Ethernet.kext 2.2.2

DRIVERS
ApfsDriverLoader.efi 5099
AppleGenericInput.efi 2.0.9
AppleUISupport.efi 2.0.9
AptioMemoryFix.efi R26
HFSPlus.efi 5099
VirtualSMC.efi 1.0.9

Plus ssdt-ec.dsl and a board-specific DSDT.aml and config.plist

Catalina is working great (apfs encrypted system disk)
 
Last edited:
Joined
Jul 23, 2015
Messages
93
Motherboard
x99-UD4
CPU
5820K
Graphics
RX580 8GB
Mac
MacBook Pro
I just updated through System Preferences > Software Update. I don't even remember when was the last time i used MultiBeast.
Hey Kittciokas,

It seems we have the same setup, x99-UD4, i7-5820K, RX580... I was wondering if you could share your EFI folder since I seem to have problems to run Catalina 100%

Thanks man
 
Top