Contribute
Register

macOS 10.14.6 Supplemental Update 2

Joined
Jun 5, 2010
Messages
77
Motherboard
Gigabyte GA-P55M-UD4-F9
CPU
i7-860
Graphics
RX 580
Mobile Phone
iOS
FOUND THE SOLUTION in another thread :

I hit F3 on Clover Menu, And I have 2 "Install Mac OS from MacOS" and one with "Install from Preboot".
I choose the first : SSD drive activity, screen showing "Install..." with graphics and time of 36 minutes (in fact one) one reboot, I choose again "Install Mac OS from MacOS"... and reboot.

After this :

Ronalds-iMac:~ rva$ sw_vers
ProductName: Mac OS X
ProductVersion: 10.14.6
BuildVersion: 18G2022
Ronalds-iMac:~ rva$
If you have Clover configured to select your macOS disk on boot, when installing updates it will switch and boot from an "Install Mac OS" volume if one is present. This makes installing updates a hands-off process. Caveat is if you are using encrypted disks, you need to use the Preboot volumes.

The setup is straight forward:
  1. Download and install Clover Configurator
  2. Run it, in Mount EFI section, mount the EFI partition from you primary boot disk.
  3. Open config.plist in /EFI/EFI/CLOVER directory.
  4. In Boot section in the 'Default Boot Volume' field, type the name of your primary macOS volume.
  5. If you have multiple boot volumes you select, you will want to increase the Timeout value.
  6. Save.
The next time you boot, your machine should boot hands off and the next update should also install hands off.
 
Joined
Jan 11, 2019
Messages
3
Motherboard
ASUS TUF Z390-PLUS
CPU
i5-9600K
Graphics
RX 570
Might be a stupid question, but is the latest version of Clover recommended for updating to 10.14.6? I am currently running 10.14.2 and using clover 5.3.2.0.
 

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
13,387
Motherboard
ASUS ROG MAXIMUS X HERO Z370
CPU
i7-8700K
Graphics
RX 580
Mac
MacBook Pro, Mac mini, Mac Pro
Classic Mac
Power Mac, PowerBook
Mobile Phone
iOS
Might be a stupid question, but is the latest version of Clover recommended for updating to 10.14.6? I am currently running 10.14.2 and using clover 5.3.2.0.
For 10.14.6, r4961 will do the job. However, you can also use the newer builds. The tonymacx86 Downloads > Clover latest build is r5102 which works great for Catalina.
 
Joined
Mar 16, 2015
Messages
246
Motherboard
HP 6300 SFF-V3.08
CPU
i5-3570
Graphics
GT 640
Mac
Mac mini, Mac Pro
Classic Mac
Power Mac, Quadra, SE/30
Mojave has also been updated to 18G3020.
18G3020.png
 
Joined
Sep 25, 2011
Messages
69
Motherboard
HP Elite 8300 MT v2.99
CPU
i5-3470
Graphics
GT 710
Mac
MacBook Pro, Mac mini
Classic Mac
Power Mac
Mobile Phone
iOS
Installed latest 10.14.6 Security Update 2020-001 via Software Update, no issues.
 
Joined
Apr 2, 2013
Messages
25
Motherboard
ASUS Z370 Prime-A
CPU
i7-8700K
Graphics
Vega 64
Mac
MacBook Pro
Last security update went fine.
2 reboots, took some time.
 
Joined
Mar 16, 2015
Messages
246
Motherboard
HP 6300 SFF-V3.08
CPU
i5-3570
Graphics
GT 640
Mac
Mac mini, Mac Pro
Classic Mac
Power Mac, Quadra, SE/30
Updated Clover to r5107 and then Mojave to 18G4032.

18G4032.png
 
Joined
Apr 11, 2018
Messages
68
Motherboard
Gigabyte H370M D3H
CPU
i5-8500
Graphics
RX 570
Mac
iMac, MacBook Pro
Just finished a new build, my iHack 2. I made a new Bootable USB Install Thumb Drive with UniBeast for this build. When I downloaded the current Mojave OS from the App store 3 weeks ago for that Install Thumb Drive, I got 10.14.6 (18G103). A bit surprised as the (18G4032) was already released. Anyways, finished the build, updated the software. About 15-18 minutes and a few restarts later and it was done without any hassles.
 
Last edited:
Joined
Aug 9, 2011
Messages
7
Motherboard
Gigabyte Z390 M
CPU
i9 9900K
Graphics
Radeon Rx580
Mac
Mac Pro
Classic Mac
Power Mac
Mobile Phone
iOS
My system is running on 10.14.6 (18G4023), though I'm not exactly sure how it's running. I had put off doing updates to my stock Mojave installation because I couldn't afford to deal with issues. Recently I tried to update, thinking that I'd get to 103. Instead, my system upgraded directly to 4023. The normal install and reboot process happened a couple/few times as expected, then the boot process failed. I hadn't updated clover, and when the final disk selection for Mojave occurred, the machine would simply reboot a few seconds into the startup sequence. Turning on -verbose mode showed a lot of text, but the screen would then immediately boot into the hardware startup image. I could boot into recovery, and thought about reinstalling from a backup image, but decided to try other options first.

I was able to get past the startup crash by trying a 'Reboot from Reboot' image option; the first choice on the left in Clover. Then the startup sequence proceeded normally. Now the system is running, but there's no certainty that It'll work again if the machine gets shut down. I'll cross my fingers and give it a try. Oh, but first I'm going to backup some needed work files, in case the machine doesn't want to restart and I don't have the time to diagnose further.
 
Top