Contribute
Register

MacMan's Build: ASUS TUF Z390-PRO GAMING - i9-9900K - Vega 64 - Updated for 10.14.6 and NVRAM Support

Joined
Mar 17, 2010
Messages
119
Motherboard
ASUS sabertooth z97 mark 2
CPU
i7 4790k
Graphics
HD 4600
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Thanks, man. Now I have another problem. I reach the installer but i'm stuck at "2 minutes remaining". How can I solve this?
View attachment 427535
You have to download Clover_v2.4k_r4920-UEFI-EmuNVR-UB.pkg from MacMan´s guide, run it and select you USB UniBeast drive as installation location.
 
Joined
Oct 4, 2013
Messages
20
Motherboard
Asus TUF Z390 Plus Gaming
CPU
i5 9600K @4.8GHz
Graphics
Radeon RX 580
Mobile Phone
  1. Android
Dear @MacMan, All,
before selling my MacBook I created the UniBeast stick. Now I noticed that I had to apply ACPI patch BEFORE booting from the stick, so I should have it done in a Mac environment, using PlistBuddy command. I noticed that the patch is a simple text file and PlistBuddy does nothing else than add its contents into config.plist in EFI partition of USB stick.

Now that I don't have a Mac any more, I installed Ubuntu where I can mount RW the EFI partition and edit files.

Question is: Where exactly to put the lines from ACPI_PATCH to config.plist?
Or, is anyone willing to share their patched config.plist so I can replace mine? Thank you very much.
 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
25,862
Motherboard
Lenovo ThinkStation p700
CPU
2x E5-2620 V3
Graphics
RX 560
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
Where exactly to put the lines from ACPI_PATCH to config.plist?

 
Joined
Jun 22, 2016
Messages
19
Motherboard
ASUS TUF Z390M-PRO GAMING
CPU
i7-9700K
Graphics
UHD 630
Hey,

I am using the latest BIOS on my motherboard, and followed the instructions on the first post. When trying to boot the installer, I got the following panic.

I also attached my EFI folder on the installer.
 

Attachments

  • EFI.zip
    3.5 MB · Views: 61
  • IMG_1928.JPG
    IMG_1928.JPG
    2.7 MB · Views: 71

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
25,862
Motherboard
Lenovo ThinkStation p700
CPU
2x E5-2620 V3
Graphics
RX 560
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
followed the instructions on the first post

If you use UEFI version 2203 or later the system will hang during the boot of macOS at apfs_module_start:1393. @mattystonnie has created a patch that fixes this

1393.png


 
Joined
Jun 22, 2016
Messages
19
Motherboard
ASUS TUF Z390M-PRO GAMING
CPU
i7-9700K
Graphics
UHD 630
View attachment 430461

I applied the patch. In Clover Configurator, this is what's on my Acpi screen

1571045942672.png
 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
25,862
Motherboard
Lenovo ThinkStation p700
CPU
2x E5-2620 V3
Graphics
RX 560
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
I applied the patch. In Clover Configurator, this is what's on my Acpi screen
Must be some other cause then, no more ideas.
 
Joined
Oct 4, 2013
Messages
20
Motherboard
Asus TUF Z390 Plus Gaming
CPU
i5 9600K @4.8GHz
Graphics
Radeon RX 580
Mobile Phone
  1. Android

Thank you, message #60 of that thread helped me move further.

Now, in Disk Utility I don't see my NVMe Crucial P1 disk.
edit2: I just partitioned it using diskutil.
edit3: stuck at 2 minutes remaining. I guess i should have run clover_v2-4k_r4920-uefi-emunvr-ub-pkg-zip BEFORE installation. How can I do it now that I don't have a Mac? I can unpack the pkg in Windows or Linux, there are another pkgs inside, but where to put them? How to proceed through Linux or Windows? @MacMan
Edit4: I installed windows, virtualbox and macos inside it. There I finished the Unibeast key and successfully installed. Then I did the final reboot and according to verbose messages everything went well but in the end the monitor went black. I think I don't see the picture for some reason.
CPU is i5 9600K.
Monitor is old VGA-only, connected over hdmi to VGA adapter. Can this be the cause? How come it worked ok before reboot, just after install and not working after (the multibeast configuration)?
e5: I may have forgotten "Core Graphics Fixup" in Multibeast. I'll try to fix it tomorrow, either through safe mode or reinstall completely.
e6: done, fully up and running. Restoring from Time machine.
 
Last edited:
Joined
Sep 21, 2018
Messages
7
Motherboard
ASUS TUF Z390 PRO GAMING
CPU
i9-9900K
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac Pro
Classic Mac
  1. iMac
  2. Power Mac
Mobile Phone
  1. iOS
Hi @MacMan

I make installation by your guide, but I can't not boot to installation screen.

It error at: Could not set enviroment: 141: Reentrancy avoided

My build:

Asus TUF Z390 PRO
Core i9 9900k
HyperX fury DDR4 8gb x2
No VGA
Samsung 960 Evo 256gb

Please help me, thank you
 

Attachments

  • install-error.jpg
    install-error.jpg
    444.6 KB · Views: 68
Joined
Jul 31, 2016
Messages
77
Motherboard
Gigabyte Designare Z390
CPU
I7-8700
Graphics
Vega 64
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi,

I changed my ASUS ROG STRIX Z370-G to ROG STRIX Z370-G with WiFi and airport card. It's working so far (handover, airdrop and so on) but I cannot activate iGPU multi-monitor support...
I followed the golden build of @pastrychef, and it's rock stable

My question:
Do you think it's safe to just replace the Z370 ROG STRIX edition to Asus TUF Z390M-Pro WiFi?
I think the mainboards are nearly similar, right?
 
Top