Contribute
Register

Solved > Kernel Panic right after installation!! Please help!

Joined
Sep 26, 2016
Messages
87
Motherboard
ASUS ROG STRIX Z370-E Gaming
CPU
i7-8700k @ 5 GHz OC
Graphics
Sapphire RX580 8GB
Mobile Phone
  1. iOS
Hey!
I am installing catalina on;
i7 8700k (installation through igpu)
RX 560 2 GB (planning on using this after installation for mac)
GTX 1080 Ti (Using for windows)
16 GB DDR4 Kingston HyperX
Asus ROG Z370-E

I was able to boot into the installation and start it, then booted into macOS drive to continue installation (successful), then when I restart to get started with mac or maybe continue installation I get a kernel panic. I will attach screenshots of a video for reference. Please help me @pastrychef thanks
 

Attachments

  • FC9DF53F-EF17-4ECC-B75A-B7746D0F6DCE.jpeg
    FC9DF53F-EF17-4ECC-B75A-B7746D0F6DCE.jpeg
    4.5 MB · Views: 25
  • A9B26CEC-EB0A-4DAA-BCD2-2CBDE074DB41.png
    A9B26CEC-EB0A-4DAA-BCD2-2CBDE074DB41.png
    8.7 MB · Views: 23
  • 5A288A39-FF60-4B99-BD52-86015E839FD1.png
    5A288A39-FF60-4B99-BD52-86015E839FD1.png
    3.8 MB · Views: 31
  • 22F8D13A-CC21-4AF5-BFEB-D6478AD3C734.png
    22F8D13A-CC21-4AF5-BFEB-D6478AD3C734.png
    8.8 MB · Views: 35
  • A3748B4F-2D25-4FB4-824B-8F0BABB64C99.png
    A3748B4F-2D25-4FB4-824B-8F0BABB64C99.png
    8 MB · Views: 27
  • ABF342DD-53BD-4A0E-B8F9-6493DBF9BC24.png
    ABF342DD-53BD-4A0E-B8F9-6493DBF9BC24.png
    8.5 MB · Views: 30
  • CDF37D20-F6DD-44EF-9EFC-610C15F638C2.png
    CDF37D20-F6DD-44EF-9EFC-610C15F638C2.png
    8.4 MB · Views: 22
  • 651C7C08-8A10-4BD9-97F7-27C0F7ED0E05.png
    651C7C08-8A10-4BD9-97F7-27C0F7ED0E05.png
    7.9 MB · Views: 36
  • 6F44CC07-D935-49CA-81B6-FADE5915E880.png
    6F44CC07-D935-49CA-81B6-FADE5915E880.png
    8.5 MB · Views: 23

pastrychef

Moderator
Joined
May 29, 2013
Messages
17,063
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Vega 56 (Bios flashed to 64)
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Hey!
I am installing catalina on;
i7 8700k (installation through igpu)
RX 560 2 GB (planning on using this after installation for mac)
GTX 1080 Ti (Using for windows)
16 GB DDR4 Kingston HyperX
Asus ROG Z370-E

I was able to boot into the installation and start it, then booted into macOS drive to continue installation (successful), then when I restart to get started with mac or maybe continue installation I get a kernel panic. I will attach screenshots of a video for reference. Please help me @pastrychef thanks

It looks like it's graphics related. What kind of RX 560 are you using? Is it a rebadged RX 550?
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
17,063
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Vega 56 (Bios flashed to 64)
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Joined
Sep 26, 2016
Messages
87
Motherboard
ASUS ROG STRIX Z370-E Gaming
CPU
i7-8700k @ 5 GHz OC
Graphics
Sapphire RX580 8GB
Mobile Phone
  1. iOS
It looks like it's graphics related. What kind of RX 560 are you using? Is it a rebadged RX 550?
Okay do I need to uplug the nvidia as well? And then how do I setup the rx560 after installation with 1080ti disable in macos? I added a device property to disable all nvidia graphics card in the config.plist
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
17,063
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Vega 56 (Bios flashed to 64)
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Okay do I need to uplug the nvidia as well? And then how do I setup the rx560 after installation with 1080ti disable in macos? I added a device property to disable all nvidia graphics card in the config.plist

Wait... You have an Nvidia card installed too??? That might be your problem...

Try with just the GTX 1080 Ti pulled.

Please report back after you've booted in to macOS. I've never personally tried disabling a secondary Nvidia card but I can give it a shot...
 
Joined
Sep 26, 2016
Messages
87
Motherboard
ASUS ROG STRIX Z370-E Gaming
CPU
i7-8700k @ 5 GHz OC
Graphics
Sapphire RX580 8GB
Mobile Phone
  1. iOS
Wait... You have an Nvidia card installed too??? That might be your problem...

Try with just the GTX 1080 Ti pulled.

Please report back after you've booted in to macOS. I've never personally tried disabling a secondary Nvidia card but I can give it a shot...

I tried pulling out Nvidia before I posted here, didn't work for me, but pulling out the rx 560 worked! I installed macOS and now trying to figure out how to get the rx560 working.

Information that might be important:
BIOS:
default: CPU graphics
iGPU multi monitor support: Enabled

Clover:
No inject ATI

Now how do I manage to get my radeon card working post installation without KP?
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
17,063
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Vega 56 (Bios flashed to 64)
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
I tried pulling out Nvidia before I posted here, didn't work for me, but pulling out the rx 560 worked! I installed macOS and now trying to figure out how to get the rx560 working.

Information that might be important:
BIOS:
default: CPU graphics
iGPU multi monitor support: Enabled

Clover:
No inject ATI

Now how do I manage to get my radeon card working post installation without KP?

Try to find out what kind of RX 560 you have...

 
Joined
Sep 26, 2016
Messages
87
Motherboard
ASUS ROG STRIX Z370-E Gaming
CPU
i7-8700k @ 5 GHz OC
Graphics
Sapphire RX580 8GB
Mobile Phone
  1. iOS
Try to find out what kind of RX 560 you have...



This is the one!
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
17,063
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Vega 56 (Bios flashed to 64)
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS

This is the one!

I can't find any info on that card... Can't tell if it's Polaris or Baffin... 14 compute units or 16...
 
Top