Contribute
Register

Kaby Lake HD620 working...

Status
Not open for further replies.

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,727
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Just an update, I just got AppleLPC.kext to load by injecting device id 0xa2c5 using the kext I attached.

As per 100-series chipset datasheet, LCTL_Offset is 80 for 100-series.

I was not able to find a 200-series chipset datasheet, but I think it is much more likely that LPC on 200-series uses LTCL_Offset of 80 (same as for 100-series), than the 424 you coded here.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,727
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
USB3 devices still not working on the blue ports.

You probably forgot to use the port limit patch.

Keep in mind general procedure:
- install USBInjectAll.kext
- enable port limit patch
- verify in ioreg that all ports are injected
- test all ports to determine which ones you actually need (while IORegistryExplorer is running)
- use the data in the resulting ioreg to create custom SSDT for USBInjectAll (staying under the 15-port limit)
- install custom SSDT
- test all ports to be sure they work
- disable the port limit patch

Read USB guide, post #1, "Problem Reporting".
 
Joined
Oct 30, 2010
Messages
47
Motherboard
Asus TUF-Z270-Mark 1
CPU
i7-7700K OC @ 5GHz
Graphics
GTX 980 Ti
Mac
  1. MacBook Pro
  2. Mac Pro
Classic Mac
  1. Performa
Mobile Phone
  1. iOS
can you please help m with your bios(changes) I am trying to install Sierra on MSI carbon pro and 7700k.e

I didn't change much in the bios to get it to install. Just make sure 'XHCI Hand Off' is enabled, 'Fast boot' to disable, 'Secure Boot' is set to 'Other OS', and 'CFG Lock' is set to disable if you motherboard has that setting. Then once I got it to install, I played with other setting and overclocking.

With 7700K CPU, you need to make sure you set 'Kernel and Kext Patches'->'FakeCPUID' to '0x0506e3'. If you system still won't boot and your bios doesn't has 'CFG Lock' option, then try to enable 'Kernel and Kext Patches'->'KernelPm'.

Are you using iGPU or dGPU?
 
Joined
Oct 15, 2015
Messages
40
Motherboard
Gigabyte Z270X Aorus Gaming 7
CPU
i7 7700k
Graphics
gtx 1070FE
Mobile Phone
  1. Android
  2. iOS
I didn't change much in the bios to get it to install. Just make sure 'XHCI Hand Off' is enabled, 'Fast boot' to disable, 'Secure Boot' is set to 'Other OS', and 'CFG Lock' is set to disable if you motherboard has that setting. Then once I got it to install, I played with other setting and overclocking.

With 7700K CPU, you need to make sure you set 'Kernel and Kext Patches'->'FakeCPUID' to '0x0506e3'. If you system still won't boot and your bios doesn't has 'CFG Lock' option, then try to enable 'Kernel and Kext Patches'->'KernelPm'.

Are you using iGPU or dGPU?
dGPU for the time being its intel 1070 as I do not have HDMI cable on me. one i have is dvi to hdmi but i am not sure will it work or not.
 
Joined
Oct 30, 2010
Messages
47
Motherboard
Asus TUF-Z270-Mark 1
CPU
i7-7700K OC @ 5GHz
Graphics
GTX 980 Ti
Mac
  1. MacBook Pro
  2. Mac Pro
Classic Mac
  1. Performa
Mobile Phone
  1. iOS
dGPU for the time being its intel 1070 as I do not have HDMI cable on me. one i have is dvi to hdmi but i am not sure will it work or not.

I don't think Nvidia Web Driver supports any GPU based on Pascal, yet. Anyway, I'm attaching a Clover folder I use to boot i7-7700K with Asus TUF Z270 Mark 1 motherboard.
 

Attachments

  • CLOVER.zip
    4.9 MB · Views: 262
Joined
Oct 15, 2015
Messages
40
Motherboard
Gigabyte Z270X Aorus Gaming 7
CPU
i7 7700k
Graphics
gtx 1070FE
Mobile Phone
  1. Android
  2. iOS
I don't think Nvidia Web Driver supports any GPU based on Pascal, yet. Anyway, I'm attaching a Clover folder I use to boot i7-7700K with Asus TUF Z270 Mark 1 motherboard.

Thank you very very much for your sharing I simply copied you config.plist, kexts(only other folder) and drivers64UEFI from your folder to my USB and somehow it is installing.

I know new nvidia cards are not supported so far I will buy one of the supported AMD card/cheap one and will use that if really needed.
 

Attachments

  • IMG_0130.JPG
    IMG_0130.JPG
    1.7 MB · Views: 227
Last edited:
Joined
Oct 15, 2015
Messages
40
Motherboard
Gigabyte Z270X Aorus Gaming 7
CPU
i7 7700k
Graphics
gtx 1070FE
Mobile Phone
  1. Android
  2. iOS
I don't think Nvidia Web Driver supports any GPU based on Pascal, yet. Anyway, I'm attaching a Clover folder I use to boot i7-7700K with Asus TUF Z270 Mark 1 motherboard.

finally on desktop now lets strat to make it perfect/right. I took my graphic card out and copied your files to my USB and I started loading and after running all the commands screen of my computer was getting black(on IGPU) so I connected my GTX1070 and used nv_disable=1 to install OSX which worked now I have to take my 1070 out and have to use intel's graphics. what changes I have to make in config.plist and other folders would you be able to help me. In the main while, I will open mac and hackintosh side by side to see what was wrong earlier.
 
Joined
Oct 30, 2010
Messages
47
Motherboard
Asus TUF-Z270-Mark 1
CPU
i7-7700K OC @ 5GHz
Graphics
GTX 980 Ti
Mac
  1. MacBook Pro
  2. Mac Pro
Classic Mac
  1. Performa
Mobile Phone
  1. iOS
finally on desktop now lets strat to make it perfect/right. I took my graphic card out and copied your files to my USB and I started loading and after running all the commands screen of my computer was getting black(on IGPU) so I connected my GTX1070 and used nv_disable=1 to install OSX which worked now I have to take my 1070 out and have to use intel's graphics. what changes I have to make in config.plist and other folders would you be able to help me. In the main while, I will open mac and hackintosh side by side to see what was wrong earlier.

Did you also copy what inside the ACPI->patched folder? You need 'SSDT - 7700K.aml' for CPU PM and 'SSDT-HD530.aml' for iGPU.
 
Status
Not open for further replies.
Top