Contribute
Register

Solved > Internal Graphics not properly working UHD 630

Joined
Dec 6, 2018
Messages
50
Motherboard
Gigabyte H370 DS3H
CPU
i5-8500
Graphics
UHD 630
#1
Hey Guys,

I am having some trouble getting my hackintosch properly to work, my graphics show only 7MB, and I don't know how to fix it. I tried a couple of thing but couldn't get to work. I also searched on the forum but could not get any wiser. Maybe one of you wants to take a look at my folder. I would be very thankful if one of you could help me! I don't know what to do any more, and it would be very sad to give up the project..
Anyway, thanks in advance! See my complete configuration in my profile.

-Intel I5 8500
-Gigabyte H370 DS3h

__________________________________________________________________________________________________

Problem solved! Big shout out to CaseySJ
 

Attachments

Last edited:
Joined
Nov 11, 2018
Messages
954
Motherboard
Gigabyte Designare Z390
CPU
i7-9700K
Graphics
RX 580
Mac
MacBook Air, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
#5
Thanks for a try to help, but I only have the ability to connect with vga and hdmi...
I misunderstood your original problem statement. Your graphics is showing 7MB because Mojave has not activated the accelerated graphics driver (called "AppleIntelFramebuffer"). It's using a default VESA driver.

It's fairly easy to activate the accelerated graphics driver, but then you will lose HDMI output. This is where the guide in my previous post comes in.

But first we need to activate the proper driver. Your config.plist seems to be extremely abbreviated. Lots of sections are missing. Are you sure this is the EFI folder from the EFI partition of your Mojave internal disk (and not from the USB disk)?

The typical solution is as follows, using Clover Configurator:
  • Devices --> Fake ID --> IntelGFX --> set to 3E9B8086 or 3E928086
  • Graphics --> Inject Intel --> enable the check box
  • Graphics --> ig-platform-id --> use the pop-up menu to select 3E9B0007
Save the file and reboot.
 
Joined
Dec 6, 2018
Messages
50
Motherboard
Gigabyte H370 DS3H
CPU
i5-8500
Graphics
UHD 630
#6
I misunderstood your original problem statement. Your graphics is showing 7MB because Mojave has not activated the accelerated graphics driver (called "AppleIntelFramebuffer"). It's using a default VESA driver.

It's fairly easy to activate the accelerated graphics driver, but then you will lose HDMI output. This is where the guide in my previous post comes in.

But first we need to activate the proper driver. Your config.plist seems to be extremely abbreviated. Lots of sections are missing. Are you sure this is the EFI folder from the EFI partition of your Mojave internal disk (and not from the USB disk)?

The typical solution is as follows, using Clover Configurator:
  • Devices --> Fake ID --> IntelGFX --> set to 3E9B8086 or 3E928086
  • Graphics --> Inject Intel --> enable the check box
  • Graphics --> ig-platform-id --> use the pop-up menu to select 3E9B0007
Save the file and reboot.
Yes that it is correct, that is because my system otherwise wouldn't boot. What kind of customisations do I need to make? And I will lose HDMI but what will stay to work?
 
Joined
Nov 11, 2018
Messages
954
Motherboard
Gigabyte Designare Z390
CPU
i7-9700K
Graphics
RX 580
Mac
MacBook Air, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
#7
Yes that it is correct, that is because my system otherwise wouldn't boot. What kind of customisations do I need to make? And I will lose HDMI but what will stay to work?
  • Because you have VGA and HDMI, stick to VGA for the time being.
  • Because your system appears to be very sensitive to config.plist modifications, try making small changes at a time. The first change is to set IntelGFX to 3E928086, enable the Inject Intel check box in Graphics and set ig-platform-id to 3E9B0007.
I've made these changes in the attached config-v2.plist.

Standard warnings apply:
  • Backup the current config.plist
  • If this goes south, you'll need to reboot with the USB install disk or use Options from Clover Boot Menu to uncheck Inject Intel.
 

Attachments

Joined
Dec 6, 2018
Messages
50
Motherboard
Gigabyte H370 DS3H
CPU
i5-8500
Graphics
UHD 630
#8
I misunderstood your original problem statement. Your graphics is showing 7MB because Mojave has not activated the accelerated graphics driver (called "AppleIntelFramebuffer"). It's using a default VESA driver.

It's fairly easy to activate the accelerated graphics driver, but then you will lose HDMI output. This is where the guide in my previous post comes in.

But first we need to activate the proper driver. Your config.plist seems to be extremely abbreviated. Lots of sections are missing. Are you sure this is the EFI folder from the EFI partition of your Mojave internal disk (and not from the USB disk)?

The typical solution is as follows, using Clover Configurator:
  • Devices --> Fake ID --> IntelGFX --> set to 3E9B8086 or 3E928086
  • Graphics --> Inject Intel --> enable the check box
  • Graphics --> ig-platform-id --> use the pop-up menu to select 3E9B0007
Save the file and reboot.
When I try those configuration the sytem will boot to 60% and then my monitor will turn black but pc still on. Thats the loss of hdmi i think?
 
Joined
Nov 11, 2018
Messages
954
Motherboard
Gigabyte Designare Z390
CPU
i7-9700K
Graphics
RX 580
Mac
MacBook Air, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
#9
When I try those configuration the sytem will boot to 60% and then my monitor will turn black but pc still on. Thats the loss of hdmi i think?
Correct -- that's the HDMI "black screen" problem that plagues this forum. Hence, stick to VGA until framebuffer patching can be applied to fix HDMI output.
 
Last edited:
Joined
Dec 6, 2018
Messages
50
Motherboard
Gigabyte H370 DS3H
CPU
i5-8500
Graphics
UHD 630
#10
Correct -- that's the HDMI "black screen" problem that plagues this forum. Hence, stick to VGA until framebuffer patching can be applied to fix HDMI output.
Allright but the same thing happens when I try to boot from vga. (Didn't use your config.plist yet, edited myself)
 
Top