Contribute
Register

Solved > Intel UHD 630 not working

Joined
Oct 16, 2018
Messages
11
Motherboard
Dell Optiplex 3060
CPU
i3-8100
Graphics
UHD630
Thanks for your work!
I have the Optiplex 3060 with the i3-8100 and with your EFI High Sierra is booting fine but i am missing iGPU-acceleration and the screen is having a black bar on the bottom covering half the heigth of the dock on my 4k-Display.
I cant seem to find the correct way to enable acceleration in clover. Do i have to alter the AAPL Platform setting in config.plist by hand? This seems to be related to the i5 and i cant find the setting in clover configurator.
 
Joined
Oct 5, 2018
Messages
19
Motherboard
Dell OptiPlex 3060
CPU
i5-8500
Graphics
UHD 630
Mobile Phone
Android
Hi
First update to MacOS Mojave
Our PC came with hardware smaller to MacMini 2018
So to get native support for Intel UHD 630. you should be in MacOS Mojave 10.14.2 or 10.14.3

Note: for setup inject AAPL Platform with ID 0x12345678 if you using HDMI port
OR put all kext in Colver other folder
  • AppleALC.kext (For sound)
  • RealtekRTL8111.kext (For Ethernet)
  • FakeSMC.kext
  • WhateverGreen.kext
  • Lilu.kext
and use config.plist from my post #10

Otherways use DP port with my config.plist from my post #10 .

Don't forget to use mac mini SMBIOS. its allreday in my config.plist
 
Joined
Oct 16, 2018
Messages
11
Motherboard
Dell Optiplex 3060
CPU
i3-8100
Graphics
UHD630
I have to stay on High Sierra due to a Nvidia Card i will add in a couple days.

After updating High Sierra to the latest Version and adding "device-id 923E0000" to the AAPL section i now have graphics acceleration and igp memory is shown as 2048MB with iMac18.1 SMBIOS. The graphics output has glitches and artifacts though and is not useable. All iMac18 and iMac17 give the same results and the MacMini8 is unavailable for High Sierra. DP and HDMI give the same results.

Maybe someone else reading this has any other ideas. Thanks anyway for your config.plist.
 
Joined
Oct 16, 2018
Messages
11
Motherboard
Dell Optiplex 3060
CPU
i3-8100
Graphics
UHD630
Hi
First update to MacOS Mojave
As High Sierra was always flickering/glitching as soon as GPU-acceleration was active i decided to test Mojave. It is flickering too with your EFI and config.plist. On HDMI and DP, with a 4k Monitor and a 1280p Monitor. So there seems to be a bug (in Lilu?) that makes the i3 iGP flicker in comparison to the i5. All the other Hardware should be the exact same.
What BIOS Version are you running? Im on 1.2.7.

And are you able to boot without the Framebuffer-memory-patches? As Windows is showing the Optiplex 3060 has 128MB DVMT pre-allocation which should be enough to not need any 19/9MB FB-patches. But without the patches i am always getting a kernel panic in appleintelcflgraphicsframebuffer.
 
Joined
Oct 16, 2018
Messages
11
Motherboard
Dell Optiplex 3060
CPU
i3-8100
Graphics
UHD630
Btw: As soon as acceleration is active the Monitors don't get recognised. Maybe the flickering is "just" EDID related?
 

BreBo

Moderator
Joined
Oct 17, 2011
Messages
9,643
Motherboard
Gigabyte GA-Z87X-OC
CPU
i7-4770K
Graphics
GTX 970
@StSc, please update your profile (account details) with your Motherboard, CPU and iGPU or Graphics Card(s).
If you have a prebuilt computer enter make and model instead of motherboard.
The Rules said:
Profiles are mandatory so that others can assist you.
 
Joined
Oct 5, 2018
Messages
19
Motherboard
Dell OptiPlex 3060
CPU
i5-8500
Graphics
UHD 630
Mobile Phone
Android
As High Sierra was always flickering/glitching as soon as GPU-acceleration was active i decided to test Mojave. It is flickering too with your EFI and config.plist. On HDMI and DP, with a 4k Monitor and a 1280p Monitor. So there seems to be a bug (in Lilu?) that makes the i3 iGP flicker in comparison to the i5. All the other Hardware should be the exact same.
What BIOS Version are you running? Im on 1.2.7.

And are you able to boot without the Framebuffer-memory-patches? As Windows is showing the Optiplex 3060 has 128MB DVMT pre-allocation which should be enough to not need any 19/9MB FB-patches. But without the patches i am always getting a kernel panic in appleintelcflgraphicsframebuffer.

Hello my friend
sorry for the delay
actually I using a 1080p screen
and everything is fine with it

For the bios I in the latest version from Dell

I am not a professional in the Hackintosh. But I will try my best to help you

First
where did you install the kexts?
and one more question?
can you explain more or provide a video on how the screen is flickering
 
Joined
Oct 16, 2018
Messages
11
Motherboard
Dell Optiplex 3060
CPU
i3-8100
Graphics
UHD630
The glitching was fixed by a clean install on a fresh drive. Something was messed up and got worse with the other bug in relation to the 4k-Display for which i made a new thread. Thanks for your help.
 
Joined
Oct 5, 2018
Messages
19
Motherboard
Dell OptiPlex 3060
CPU
i5-8500
Graphics
UHD 630
Mobile Phone
Android
I hope your problem gets solved as soon as possible

is the sound card working for you without any issue

I am working with InsanelyDeepak in another forum to solve mic issue and back port issue

if you have the same issue you can try original AppleALC

Layout ID 18 makes the back port work with the internal speaker (the sound came out from both together )

and Layout 27,30,31 fix the front port sound for the headphone

you can choose what is best for you
until we fix the issues
 
Last edited:
Joined
Oct 16, 2018
Messages
11
Motherboard
Dell Optiplex 3060
CPU
i3-8100
Graphics
UHD630
Ahh, very nice.
I was having a static buzz on the front port with your latest config.plist so had to use the monitor output from the Displayport.
Any chance to get the back port without the internal speaker? Did you try them all?
 
Top