Contribute
Register

Install OS X El Capitan with Chameleon

Joined
Jun 18, 2013
Messages
84
Motherboard
Gigabyte GA-X79-UD3 LGA2011
CPU
Intel Core i7-4930K Ivy Bridge-E 6-Core 3.4GHz LGA 2011 130W
Graphics
ASUS GTX760-DC2OC-2GD5 G-SYNC Support GeForce GTX 760 2GB 256-Bit GDDR5 PCI Express 3.0 x16 HDCP Rea
Mac
Classic Mac
Mobile Phone
org.chameleon.Boot.plist and SMBios.plist in Extra, but I never used kernel.plist, in extra also that?
and the kernel.zip? where extract it?


my exact question as well
 
Joined
Dec 2, 2011
Messages
223
Motherboard
Gigabyte GA-Z170X-UD3
CPU
i7-6700K
Graphics
GTX 1050
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
I wonder how one could upgrade to El Capitan via Enoch? Has anyone tried with an older board?
 
Joined
Sep 22, 2014
Messages
144
Motherboard
HP Intel X58
CPU
3.2 Xeon quad core
Graphics
EVGA GT 740
You have to go to System/Library, and then create a folder and name it Kernels. You then extract Kernels.zip to this folder. The file will have the name Kernel. The other files can go in the Extra folder.
 
Joined
Sep 22, 2014
Messages
144
Motherboard
HP Intel X58
CPU
3.2 Xeon quad core
Graphics
EVGA GT 740
Tony's guide worked for me. I installed El Capitan on an HP Z400 using Unibeast, and Enoch Chameleon.
 
Joined
Jul 31, 2013
Messages
3
CPU
Core I5
Graphics
HD 4000
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Dude, i want to install El Capitan on a SC440 Dell server, they have a INTEL XEON 1.86 DUAL CORE (3040)

Clover don´t works on legacy, and i try a lots of methods but nothings works x.x
i will try this.
 
Joined
Sep 6, 2015
Messages
2
Motherboard
Gigabyte GA-Z97X-UD7 TH
CPU
Intel Core i7-4790K
Graphics
nVIDIA GeForce GT 740
I followed the steps in this post and got all the way to the final STEP 7 --> Post-Installation - Install Chameleon to system drive + Kexts to /Library/Extensions.

I installed Chameleon to the system drive, and copied the same 2 kexts into the system's /Library/Extensions on my new El Capitan instance. When I boot, I get the Enoch boot loader. I can boot in verbose mode, but it never finishes booting. Last thing I see before the freeze is the infamously misleading "Missing Bluetooth Transport Controller." Checking the "Big List of El Capitan Solutions" I think this is a problem with graphics, but not certain. The install worked fine, and I was able to load the OS and browse using Safari. Just can't boot fully on its own.

NOTE: I am using the onboard GFX and DVI port. I pulled out out the GT 740 to troubleshoot. Decided to try a vanilla Chameleon/El Capitan build after seeing this thread. Other hardware details are in my build sig.

Any thoughts on how to fix this? I can predictably get to the Chameleon text bootloader and start booting in verbose mode, but it never fully boots. I'm about to retry from scratch, but oddly I can't seem to even boot from the USB anymore :(
 
Last edited:
Joined
Sep 6, 2015
Messages
2
Motherboard
Gigabyte GA-Z97X-UD7 TH
CPU
Intel Core i7-4790K
Graphics
nVIDIA GeForce GT 740
As a followup -- has anybody tried installing Chameleon Enoch over an existing Yosemite/MultiBeast/Chimera build?

Should this just work out-of-the-box? to switch versions of Chameleon with a re-install?? I think the installer creates a Chameleon.backups folder when you re-install...
 
Joined
Jul 21, 2011
Messages
3
Mac
Classic Mac
Mobile Phone
i was pretty annoyed by the people saying clover is "way better" than anything else while i was trying to find alternatives for my 12-core hackintosh on a non-uefi asus board. it's been running lion for years but now that pro tools works with el capitan, i figured i'd try to install it on a test ssd.

with clover, i could sometimes get to the install screen, sort of, but the screen was all jumbled and no matter what i did, i couldn't get the graphics drivers sorted out right. now i'm looking at an el capitan install screen on my multiple monitors thanks to enoch...

that said, twice now the install has hung up, at different points. not sure what's causing that but i'll keep working on it.

and can anyone tell me what the -no-zp boot flag does? never heard of that one.
 
Joined
Oct 26, 2015
Messages
3
Motherboard
ASUS P5P43TD
CPU
Intel Core 2 Quad Q6600
Graphics
Gigabyte GeForce GT740
Mobile Phone
  1. Android
Why would you want to use chameleon (old legacy style) when you can use clover (UEFI)?

When using enoch on motherboards that use the old bios system, the overall performance of systems is better
I did many tests and although the system seems to work at the same way whit Clover or Enoch, when I used programs that demanding more performance, I'd experimented some issues, like higher latencies and problems in the audio system when using Clover.
 
Joined
Dec 31, 2013
Messages
156
Motherboard
Z97
CPU
i7-4770K
Graphics
GTX 1070
Mobile Phone
  1. Android
I have 3 Hackintoshes: X58, Z97, and Z170... Because the X58 is legacy and I been using Chameleon/Enoch on it since I first got OS X functioning on it (before Clover existed), I decided to leave the bootloader on it as is. However, my Z170 system on the other hand would only work with Clover so I was forced use ithat option on that system which happened to turn out alright. I was so impressed at the outcome, I had transitioned my Z97 system from using Enoch to Clover and don't regret my decision yet. All in all, both bootloaders, Enoch and Clover have their place so I'll retain a version of each on a different system to keep myself fairly familiar with the step-by-step process required to get OS X functioning.
 
Top