Contribute
Register

HP Envy 17-3200 - No USB 2.0 Ports, alternative?

Status
Not open for further replies.
Joined
Aug 12, 2012
Messages
3
Motherboard
HP Envy 17-3200
CPU
i7-3610QM
Graphics
ATI 7850
Mac
Classic Mac
Mobile Phone
I created the ML USB stick using Unibeast on an HP dv6t-3000 running Snow Leopard (it has USB 2.0 ports). I then inserted the Unibeast USB into a USB 3.0 port on my Envy 17-3200 (i7-3610QM, ATI 7850) and ran the installer using the following parameters:

-v -x cpus=1 busratio=23 GraphicsEnabler=No PCIRootUID=1 (also tried 0)

But I keep getting stuck at "waiting for root device". I believe the issue is the USB 3.0 port, but my Envy 17 doesn't have any USB 2.0 ports. Is this most likely the issue, and if so, is there an alternative way to use Unibeast (maybe via DVD)?
 
Joined
Jul 14, 2012
Messages
24
Motherboard
Lenovo Y580
CPU
i7 3610QM
Graphics
Nvidia GTX660M
Mobile Phone
  1. Android
If I were you, I would try to make a bootable USB (with the startup kexts and everything you need) and then try to clone it to a DVD. Maybe a Double Layer DVD if it is too big. No promises, but you might as well try!
 
Joined
Aug 12, 2012
Messages
3
Motherboard
HP Envy 17-3200
CPU
i7-3610QM
Graphics
ATI 7850
Mac
Classic Mac
Mobile Phone
If I were you, I would try to make a bootable USB (with the startup kexts and everything you need) and then try to clone it to a DVD. Maybe a Double Layer DVD if it is too big. No promises, but you might as well try!

Thanks, I'll give it a shot in a few days and post my results. If anyone else has any suggestions, please post them!
 
Joined
Apr 9, 2011
Messages
10
Motherboard
HP Envy 17 3270nr (clover)
CPU
i7 3610QM 8GB
Graphics
Radeon 7850M | Intel HD 4000, 1920x1080
Mac
Classic Mac
Mobile Phone
  1. iOS
I'm thinking of buying this machine, and knowing whether OSx86 works or not is the only thing holding me up. Please post back if you've been able to get a sucessful install, even if there are some driver support issues.

I'm happy to do some research to help out anyone trying to make this laptop work. Just let me know what you need.

Dave
 
Joined
Jul 28, 2011
Messages
351
Motherboard
GA-H67MA-UD2H-B3
CPU
i5-2400
Graphics
HD 5750
Mac
  1. MacBook
Mobile Phone
  1. Android
How about taking out the hard drive, put it in a USB enclosure and install OSX on it from a different computer (laptop or desktop) ?
 
Joined
Jul 18, 2012
Messages
2
Motherboard
Dell Vostro 3560
CPU
Core I5 3210M 2.5GHz
Graphics
AMD 7670M - HD 4000
Mac
Classic Mac
Mobile Phone
  1. iOS
Vostro 3560 has the same problem :(
 
Joined
Jul 18, 2012
Messages
2
Motherboard
Dell Vostro 3560
CPU
Core I5 3210M 2.5GHz
Graphics
AMD 7670M - HD 4000
Mac
Classic Mac
Mobile Phone
  1. iOS
I think that it must have a solution. Anybody have new ideas?
 
Joined
Apr 9, 2011
Messages
10
Motherboard
HP Envy 17 3270nr (clover)
CPU
i7 3610QM 8GB
Graphics
Radeon 7850M | Intel HD 4000, 1920x1080
Mac
Classic Mac
Mobile Phone
  1. iOS
Solved it, at least for the first snow leopard part anyway. I now have a working snow leopard installation on my envy 17 3270nr (which arrived a week ago).

Trying a boot disc as suggested did not work because for some reason, as soon as I ejected the iBoot disc, I got an EBIOS read error. Booting with the installer on an external HDD did not work (waiting for root device error), maybe this is lack of USB 3.0 support.

Ultimately what worked was doing a partition copy of my external HDD snow leopard installer, copying it to an unallocated area on my envy 17's internal hdd using gparted in Ubunut 12.04. So basically, not using a DVD nor an external drive for the install! In iBoot I was able to see the installer, which ran fine, and actually worked pretty well after first boot. Lots of my hardware stopped working after the 10.6.8 update. I'm currently limping along, running with only a bluetooth mouse and no working USB.

My aim is simply to download mountain lion, then do the same again. I will post more detailed instructions later. Documenting everything as I go, but lots of dead ends so far.

If anyone can help me get past this error, I'd greatly appreciate it:
--
We could not complete your purchase. OS X 10.8 Mountain Lion requires a Core 2 Duo, Core i3, Core i5, Core i7 or Xeon processor
--
Related post here: http://www.tonymacx86.com/buying-ad...ore-i7-3770k-ga-z77x-up5-th-2.html#post413888

Dave
 
Joined
Apr 9, 2011
Messages
10
Motherboard
HP Envy 17 3270nr (clover)
CPU
i7 3610QM 8GB
Graphics
Radeon 7850M | Intel HD 4000, 1920x1080
Mac
Classic Mac
Mobile Phone
  1. iOS
Hi All,

Here's the full rundown if anyone wants to duplicate what I've done so far, installing snow leopard on my HP envy 17 3270nr

1. Started with only 4GB installed. Not sure if this was necessary, but that what I had in case it’s relevant. Again, I happened to have the battery unplugged to, but probably not relevant either.

2. Using installed ubuntu 12.04, used gparted to copy my working patched version of the SL10.6.3 installer (patched to allow install to MBR partition drive), to a spare unformatted section of the on-board hard drive (in my case in the extended partition). This is a partition i’d created on a 20GB external drive hdd using the ‘restore image’ feature in disc utility on another machine which would boot to the osx installer. I did this using the copy and paste partition feature of gparted.

3. Used gparted to format a spare 100GB partition as ‘unformatted’ on the built in sata drive of my envy 17. This is where osx will go.

4. Rebooted using iboot legacy 2.7.2, this straight away listed ‘Mac OSX Install DVD’ but actually it’s a patched imaged of a DVD on a SATA drive.

5. Selected and ran the installer from the installer partition with -f -v (these boot flags might not be necessary, didn’t need PCIRootUID=x, GraphicsEnabler=no etc, which was a surprise)

6. Graphical installer starts up fine, (low res), usb mouse not working, but touchpad ok, tapping the pad to click rather than the button. Used disc utility to format 100GB partition as Mac OS Extended (Journaled). Install completed sucessfully, but automatic shutdown/reboot did not work, ending with the looping message “SerialATAPI device reconfiuration did not complete successfully. (failedCommandInfo = 0x1)”

7. Rebooted again using iBoot legacy 2.7.2

8. Post install completed ok (keybard detection, etc), but there was a really annoying changing sound coming from the speakers! After this, the external mouse started working again, and the trackpad stopped being able to click. At this point i had:
- USB external drive: YES, USB is reported as up to 480Mb/sec in system profiler.
- ethernet: NO,
- volume control and mute switch: YES,
- audio: NO
- camera: unknown
- wifi: NO
- DVD drive: YES (burner untested).

9. Upgrading snow leopard to 10.6.8... processor is i7 3610QM (ivy bridge), so I assumed the info here http://tonymacx86.blogspot.co.uk/2011/07/get-ready-for-os-x-lion-update-to-1068.html did not apply.

10. [red herring - don't bother] Copied AtherosL1cEthernet.kext from http://www.osx86.net/view/1085-atheros_ar8151.html to /System/Library/Extensions/

11. Ran the updater, then MultiBeast 3.10.1, selecting
- EasyBeast
- System Utlities
- VoodooHDA 0.2.72
- After the install I rebooted with -f -v. Hangs at [PCI configuration begin]

12. Fixed booting by adding -f -v npci=0x3000 (long wait at PCI configuratin begin, but does work after 30sec ish. Now you can see the desktop, no external mouse, trackpad can’t click either. This means you need to be pretty good on the keyboard, and enable tab selection in the keyboard preferences. Installed IOUSBFamily rollback, to hopefully get my mouse back! Didn’t work. But I found that bluetooth was working, so i grabbed a dusty bluetooth mouse and paired that. At least I can now click things!

13. Downloaded and installed http://www.osx86.net/view/2053-atheros_8151_lan_kext.html using kext utility. Rebooted with -f and network working! All of my network devices appeared.
Tried to install mountain lion from the app store. I got the message ‘We could not complete your purchase. OS X 10.8 Mountain Lion requires a Core 2 Duo, Core i3, Core i5, Core i7 or Xeon processor’.

At this point I had:
- USB: no (no mouse, removable media, etc)
- DVD: untested
- Wifi: no
- Ethernet: yes
- Bluetooth: yes
- Audio: unknown

Hope this helps someone. Currently I’m trying to run OSX in a VM to see if the ML download will work from there. My ultimate aim is to get ML working, so I’ve not spent a lot of time on the hardware kexts etc in SL for USB, wifi, graphics etc. Plenty of scope for someone to dig deeper if they only want snow leopard.

Generally my experience was that most things worked quite well until after the combo update and running multibeast.

I'll try to answer any questions, but there's not much more to add than what's above.
 
Joined
Apr 9, 2011
Messages
10
Motherboard
HP Envy 17 3270nr (clover)
CPU
i7 3610QM 8GB
Graphics
Radeon 7850M | Intel HD 4000, 1920x1080
Mac
Classic Mac
Mobile Phone
  1. iOS
I've got past the next stage and now I'm currently downloading mountain lion. Got SL running in a VM, then if anyone's wondering, I got past the above error by adding the kernel flag arch=x86_64 during boot up. After that the ML download worked fine.

The decision of whether your machine is compatible is made by a 800kB installer that the App store downloads prior to the purchase. I was able to redownload, then split down this installer, eventually finding the script that does the checks. This is plain javascript and not compiled or encrypted. After i'd patched the script to tell me what was failing and what was ok, locating the source of the error was easy. One particularly interesting find was that the board id check is bypassed if a virtual machine is detected.

Next step: mountain lion install. Installing from another partition should be an option if the USB ports won't work. Hopefully not much further to go. Anyone else made any progress with their Envy 17?
 
Status
Not open for further replies.
Top