Contribute
Register

How to Create a macOS Catalina Public Beta Installation USB

Status
Not open for further replies.
Joined
Apr 7, 2019
Messages
13
Motherboard
Gigabyte GA-Z97-HD3
CPU
i7-4790K
Graphics
GTX 780 Ti
Really. Clover do not see the Catalina installer. See all disk, but not Catalina installer. Install UEFI only and esp selected....
 
Joined
Apr 7, 2019
Messages
13
Motherboard
Gigabyte GA-Z97-HD3
CPU
i7-4790K
Graphics
GTX 780 Ti
Can you be more specific? As in my post, usb installer does not make an efi partition.
Hello, I mean, depend of USB keys, i don't know why, but after the command

sudo /Applications/Install\ macOS\ Catalina.app/Contents/Resources/createinstallmedia --volume /Volumes/USB /Applications/Install\ macOS\ Catalina.app --nointeraction


sometimes the USB have EFI and sometimes no. However, after the Clover installation, in all cases the Clover do not see the installer, but can see all disks...
 
Joined
Jul 17, 2016
Messages
18
Motherboard
Gigabyte Aorus MASTER Z390
CPU
i9-9900K
Graphics
RX 580
Mac
iMac
Hello, no way to get a working USB key or working installation.
I created several times the USB key as said in post #1 using Clover_v2.4k_r4961-UEFI.pkg, it boots and works with Mojave partition, but I cannot start Catalina external (USB) once.
I created SSDT-EC.aml and paced in ACPI/patched folder (IoRegistry shows EC item), I placed in kext/other latest version of FakeSMC.kext (but tried a lot of combinations using also lilu, USBInjectAll and WhateverGreen), tried with config.plist from working Mojave partition and from post #1, tested many boot options (disablegfxfirmware=1 / nv_disable=1 / slide=0, shikigva=1) but without results. :(

Any idea? I disconnected every SATA device, and I am using English language. I only have some USB device connected, like webcam and Logitech Unifying Receiver.

Strangest thing is that the first time I created the USB key, it worked, and I installed Catalina, but with audio and Bluetooth issues. So I am sure BIOS setting are right. But now I cannot install it any more (and I deleted the whole HD).

I also tried upgrading from Mojave, but I get an error loading kernel cache after reboot.
 

Attachments

Last edited:
Joined
Oct 12, 2019
Messages
2
Motherboard
Acer Aspire M1930
CPU
G620
Graphics
HD 2000
Mobile Phone
iOS
I ran into a problem with terminal where it says "/Applications/Install macOS Catalina.app does not appear to be a valid OS installer application."
 
Joined
Apr 7, 2019
Messages
13
Motherboard
Gigabyte GA-Z97-HD3
CPU
i7-4790K
Graphics
GTX 780 Ti
Finally Catalina work.

1 Install Clover 5070 on USB drive (only for UEFI, install in ESP, OsxAptioFixDrvV3) and replace the config.plist with file in this guide.

2 Start Catalina update from Mojave (clover 4920) the pc will reboot sometimes, at first boot, after installation Catalina will freeze at startup on black screen after apple logo.

3 Shut down manually during the freeze.

4 Boot from USB and select in clover boot options "boot Catalina from YOUR HD"

5 (make backup to your EFI partition) Mount EFI partition and replace BOOT and CLOVER folders with folders from USB but use old config.plist and put your kext in EFI/CLOVER/KEXT/OTHER

6 I needed to fix audio with latest version of AppleALC and Lilu and found my layout number (11 for me) for ALC1150 (my motherboard chip)

I hope this solution will work for someone with the same hardware.

Ciao
 

Attachments

Joined
Apr 7, 2019
Messages
13
Motherboard
Gigabyte GA-Z97-HD3
CPU
i7-4790K
Graphics
GTX 780 Ti
Finally Catalina work.

1 Install Clover 5070 on USB drive (only for UEFI, install in ESP, OsxAptioFixDrvV3) and replace the config.plist with file in this guide.

2 Start Catalina update from Mojave (clover 4920) the pc will reboot sometimes, at first boot, after installation Catalina will freeze at startup on black screen after apple logo.

3 Shut down manually during the freeze.

4 Boot from USB and select in clover boot options "boot Catalina from YOUR HD"

5 (make backup to your EFI partition) Mount EFI partition and replace BOOT and CLOVER folders with folders from USB but use old config.plist and put your kext in EFI/CLOVER/KEXT/OTHER

6 I needed to fix audio with latest version of AppleALC and Lilu and found my layout number (11 for me) for ALC1150 (my motherboard chip)

I hope this solution will work for someone with the same hardware.

Ciao
Update the 6 point:

For fix the audio (with AppleALC and Lilu in EFI/CLOVER/KEXT/OTHER the startup is not slow, but also not fast and the system can't remember the default output device, every time at startup the flag is on headphones also if in last session u've selected the internal speakers)

Open Terminal and go in the folder where you have the kexts, (in the example I will use the Desktop) and type:


cd Desktop

sudo cp -R Lilu.kext /Library/Extensions

sudo cp -R AppleALC.kext /Library/Extensions

sudo touch /Library/Extensions


and reboot. Now the audio work fine the boot is faster and the system remember ur default output device.

Ciao
 
Last edited:
Joined
Sep 16, 2018
Messages
79
Motherboard
GA-Z390-UD
CPU
i5-9400F
Graphics
RX 480
Mac
iMac
Classic Mac
Apple, Performa
Mobile Phone
Android
Update the 6 point:

For fix the audio (with AppleALC and Lilu in EFI/CLOVER/KEXT/OTHER the startup is not slow, but also not fast and the system can't remember the default output device, every time at startup the flag is on headphones also if in last session u've selected the internal speakers)

Open Terminal and go in the folder where you have the kexts, (in the example I will use the Desktop) and type:


cd Desktop

sudo cp -R Lilu.kext /Library/Extensions

sudo cp -R AppleALC.kext /Library/Extensions

sudo touch /Library/Extensions


and reboot. Now the audio work fine the boot is faster and the system remember ur default output device.

Ciao
I tried to, but doesn't works for me. still no internal audio , just HDMI GPU.
 
Joined
Sep 30, 2012
Messages
3
CPU
i7
Hello,

I created the Catalina installer according to the instructions and the latest version of the clover. But, when starting, it does not recognize me the entry of the installer in the USB. Does anyone know anything?
 
Joined
Sep 16, 2018
Messages
79
Motherboard
GA-Z390-UD
CPU
i5-9400F
Graphics
RX 480
Mac
iMac
Classic Mac
Apple, Performa
Mobile Phone
Android
Hello,

I created the Catalina installer according to the instructions and the latest version of the clover. But, when starting, it does not recognize me the entry of the installer in the USB. Does anyone know anything?
Reinstall Clover again to a USB installer. Then put FakeSMC.kext to .../kext/other/
 
Status
Not open for further replies.
Top