Contribute
Register

[HALF-SUCCESS] iTunes 12.7 constantly crashing (random messages)

Joined
Apr 8, 2017
Messages
18
Motherboard
HP Elitebook 840 G1 (Clover)
CPU
Intel Core i5-4300u (HM86)
Graphics
Intel HD Graphics 4400 (1920x1080)
Try it out with the argument 'shikigva=1'.
Also, review your clover config, or try also changing the sysdef.
shikigva=1 didn't work either. I double-checked my clover config boot flags and reinstalled the latest kexts from Github (Lilu, Shiki) and IntelGraphicsFixup to Library/Extensions. Just tried shikigva=16 again and rebooted - still crashing. I'm not changing sysdef since I doubt there's one more appropriate for my system than MacBookAir6,2. By the way this is on 10.13.1.

Edit: I just tried repairing permissions and rebuilding cache. Seems stable so far. I'll report back if this changes.

Edit2: Nope, still crashes.

Edit3: I'm using shikigva=16 and shikigva=1 in conjunction now and iTunes appears to be stable for the moment.

Edit4: Just experienced a few crashes. They seem less frequent, but it's still annoying for them to happen while listening to music.
 
Last edited:
Joined
May 27, 2013
Messages
139
Motherboard
GA-Z97X-GAMING 3
CPU
i7-4790K
Graphics
RX 580
Mac
MacBook
Mobile Phone
iOS
shikigva=1 didn't work either. I double-checked my clover config boot flags and reinstalled the latest kexts from Github (Lilu, Shiki) and IntelGraphicsFixup to Library/Extensions. Just tried shikigva=16 again and rebooted - still crashing. I'm not changing sysdef since I doubt there's one more appropriate for my system than MacBookAir6,2. By the way this is on 10.13.1.

Edit: I just tried repairing permissions and rebuilding cache. Seems stable so far. I'll report back if this changes.

Edit2: Nope, still crashes.

Edit3: I'm using shikigva=16 and shikigva=1 in conjunction now and iTunes appears to be stable for the moment.

Edit4: Just experienced a few crashes. They seem less frequent, but it's still annoying for them to happen while listening to music.
Can you share your clover's configuration file? (hash the serials and another information after).
Also, as a best practice, I put the kext files into the /EFI/CLOVER/kexts/Other instead /L/E or /S/L/E.

NOTE: The latest code from Shiki doesn't need the argument 'shikigva=16' anymore.
 
Joined
Feb 9, 2014
Messages
67
Motherboard
Intel DQ57TM
CPU
i5-760
Graphics
GT 710
Mac
iMac
Mobile Phone
iOS
lilu.kex and shiki.kext has been updated. no more iTunes crashes for me. HD4400 graphics. try updating to latest kext. solved my crashes.
 
Joined
Apr 8, 2017
Messages
18
Motherboard
HP Elitebook 840 G1 (Clover)
CPU
Intel Core i5-4300u (HM86)
Graphics
Intel HD Graphics 4400 (1920x1080)
Can you share your clover's configuration file? (hash the serials and another information after).
Also, as a best practice, I put the kext files into the /EFI/CLOVER/kexts/Other instead /L/E or /S/L/E.

NOTE: The latest code from Shiki doesn't need the argument 'shikigva=16' anymore.
I moved kext files from L/E to Clover's Other folder and removed the boot flags. Repaired permissions and rebuilt caches. No more crashing. Thanks for the assistance!
 
Joined
Jul 15, 2012
Messages
46
Motherboard
Gigabyte GA-Z170N-Gaming 5
CPU
Intel i7-6700k
Graphics
HD530
Mac
MacBook Pro, Mac mini
Mobile Phone
iOS
I thought it would be good to reinstall HS with all the changes I made to trying to fix this before the new Shiki came out. I was surprised to see iTunes 10.6.2.20 is bundled with the latest macOS 10.13.1 download. I don’t require DRM since it’s only function is iTunes library for my Apple TV’s and I’m happy to report it runs perfectly without Shiki, I just hid the iTunes update. I do have intelgraphics and lilu for the hd530 glitch and hardware acceleration works. Don’t know what they did in the new iTunes but I’m happy with this config for the time being.
 
Joined
May 28, 2016
Messages
395
Motherboard
Gigabyte Z170N-WIFI (ITX)
CPU
6700K
Graphics
Asus Strix R9 380X
Mobile Phone
iOS
Latest shiki and lilu (2.1.1) with -shikigva=16 bootarg fixed iTunes 12.6.3.6 (I need that version). Installed to. L/E

On 13.1 on 7200U, no dedicated graphics.

Devs fcuking rock.
 
Joined
Jun 9, 2013
Messages
10,960
Motherboard
GA-H77N-WIFI
CPU
Core i7-3770
Graphics
Intel HD 4000
Mac
MacBook, Mac mini
Mobile Phone
Android
I am confused.

I have got an genuine iMac 14,2. This type had a i7-4771 CPU. I looked up this model in ark.intel.com. The grahics of the cpu is HD4600.
I compared the ioreg output of my hackintosh and the genuine iMac 14,2. The device-id of IGPU is the same. I changed the ig-platform-id to the same as that on the iMac. But it seems nothing related between ig-platform-id and the IntelAccelerator. The IMEI device of my hackintosh isthe same as the iMac.

Why is it stable on the genuine iMac? Did Apple use an special version if i7-4771? Or we just missed some other ID to inject?
Attach ioreg. I think you will find that onboard iGPU on the iMac 2013 is disabled by Apple. Ioreg on my friends iMac 14,2 shows no onboard iGPU 21.5 model.
 
Joined
Jul 9, 2014
Messages
11
Motherboard
Gigabyte Z97N-Gaming 5
CPU
i7 4790
Graphics
HD 4600
Mac
MacBook Pro
New kexts from vit (shiki,intelgraphicfixup and lilu) really fixed everything now. Itunes is rock stable. Before, even with boot arg -shikigva=16 it crashed a lot.

So it was probably kext bug or some similar issue.
 
Joined
Apr 14, 2013
Messages
80
Motherboard
Aorus Z370 Gaming 7
CPU
i7 8700K
Graphics
GTX 970
Mobile Phone
iOS
iTunes doesn't seem to crash anymore, using Shiki 2.1.2, -shikigva=12 (not sure if still necessary) on i7 7700K w/ HD630 + GTX 970. Looking good, thanks vit9696!

EDIT: full hardware acceleration working too, forgot to mention :)
 
Joined
May 27, 2013
Messages
139
Motherboard
GA-Z97X-GAMING 3
CPU
i7-4790K
Graphics
RX 580
Mac
MacBook
Mobile Phone
iOS
iTunes doesn't seem to crash anymore, using Shiki 2.1.2, -shikigva=12 (not sure if still necessary) on i7 7700K w/ HD630 + GTX 970. Looking good, thanks vit9696!
The argumen is no longer necessary, I'm working right now without the argument and goes well (using the latest versions).
 
Top