Contribute
Register

[GUIDE] Lenovo Yoga 920

Joined
Dec 18, 2013
Messages
484
Motherboard
Lenovo Yoga C740
CPU
i7-10510U
Graphics
Intel UHD Graphics
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
Hi @ito01, I never experienced that but I saw discussion in the Forum having that problem in their headline. Really sorry, I have absolutely no experience with that problem. Actually I wonder why it occurs here.

Best regards
 
Joined
Jun 26, 2020
Messages
4
Motherboard
LAPTOP
CPU
Lenovo Yoga 910 Intel 7 -7500U
Graphics
intel 620
Mac
  1. MacBook Pro
Classic Mac
  1. 512K
Mobile Phone
  1. iOS
Hi @ito01, I never experienced that but I saw discussion in the Forum having that problem in their headline. Really sorry, I have absolutely no experience with that problem. Actually I wonder why it occurs here.

Best regards

Ok. Thanks
 
Joined
Aug 15, 2020
Messages
6
Motherboard
Yoga 920 MB
CPU
i7 8550u
Graphics
UHD 620
Hi all!

Before diving into this I wanted to ask if anyone managed to test out thunderbolt 3 compatibility with this. Additionally I'd like to know what the overall expereince is for people that have been on this for a longe rperiod of time - I am running as fast as I can to escape Windows but Linux is not really meeting all of my needs so now I'm turning to take a look at hackintosh.

Also, what is this
Follow RehabMan's guide for installation, you will need a usb mouse.
reffering to? Rehabman seems to have qutie a few different guides on here
 
Last edited:
Joined
Mar 22, 2020
Messages
20
Motherboard
Yoga 920-13IKB
CPU
i7-8550u
Graphics
UHD620

Like others on the thread, I have TB3 controller recognizing the slots; but my TB devices are at my workstation, and covid is not allowing me to get to them, so I don't have test speeds.

I've been using this machine as my daily driver; some hiccups here and there but nothing major. Overall, very much compatible and working great.

Not sure how much your are familiar with hackintoshing, but it wasn't as easy as it seems from my experience. This is my second machine, and it took me two weeks to setup (but of course I am no expert and this thread was solving problems as they come up, so should be a lot smoother for you). And the guide was referring to rehabman's main OSX installer boot guide (THIS ONE)
 
Joined
Aug 15, 2020
Messages
6
Motherboard
Yoga 920 MB
CPU
i7 8550u
Graphics
UHD 620
Thanks, I'll give this a shot then! I have a TB3 eGPU, if I manage to get the whole thing going then I'll def. report if it works.
 
Joined
Aug 15, 2020
Messages
6
Motherboard
Yoga 920 MB
CPU
i7 8550u
Graphics
UHD 620
Ok so I've started trying this out and this is the procedure I followed.

1. I created a recovery USB for catalina
2. I installed clover on it
3. I grabbed @qxuchn efi folder and copied over his config, ktext and drivers
4. I was able to boot into the installer and install macOS
5. after launching mac os I had some very rudmientary things wokring (usb mouse, no touchpad, sound, touchscreen...)
6. I installed the Clover app and clover on the drive - I was not able to use Rehab man's release from 2018 since it told me it is not supporteds so I used the latest one from github
7. after installing it I added the config, ktexts and driver from @qxuchn efi folder again
8. I tried rebooting the system, however now I was unable to get past 80% of the loading bar when choosing to boot to mac os

Any clue what I can do to fix this?

As a side note, I do not have my linux os as an option on clover,, instead I need to chose either clover or pop os in my UEFI boot menu. Any clue how I could get Linux into clover so I can set it as the default?

Cheers
 
Joined
Mar 22, 2020
Messages
20
Motherboard
Yoga 920-13IKB
CPU
i7-8550u
Graphics
UHD620

So you were able to boot macos? On a working macOS, you edited the EFI? and it's not rebooting into macos?

In the clover menu, choose verbose mode and check the messages that you are stuck on.
 
Joined
Aug 15, 2020
Messages
6
Motherboard
Yoga 920 MB
CPU
i7 8550u
Graphics
UHD 620
So I booted with verbose mode and I'm getting a bunch of errors telling me that no local arguments and variables are initialized.

1597606265268.png


I'm assuming that this has something to do with me copying qxuchn's EFI,
however it was copying of his EFI that got me to a working USB in the first place.

So, if I were to go and reinstall macOS, what is the right procedure for getting clover on?

Is this the right procedure:
Clover app -> install clover via the macOS clover app -> go to the drive (places) inside of the finder and change the contents of the folder there
 
Joined
Mar 22, 2020
Messages
20
Motherboard
Yoga 920-13IKB
CPU
i7-8550u
Graphics
UHD620

Did you correctly patch your DSDT?

What I would do is, boot clover via USB (like you did when installing), and you should be able to boot macos from there.

If it is not booting and you get the same error messages, you should modify the USB EFI folder and keep it minimum (Rehabman's instillation guide). Then, boot into the usb clover again, and try booting macos.

You should be able to boot into macos, then modify the boot EFI. the config from Edd1024 should work; then add a few SSDT and kexts (but you should generate your own DSDT and patch it). DSDTs have unique hardware addresses to every machine, so you have to have your own. Once you have yours, you can patch it (there is a rehabmans guide somewhere), or you can take a DSDT from this thread, and modify the addresses manually (highly frowned upon in tonymacx).
 
Joined
Aug 15, 2020
Messages
6
Motherboard
Yoga 920 MB
CPU
i7 8550u
Graphics
UHD 620
Aha! I didn't generate my DSDT. My understanding was that this is something that should be done but that it's not going to be vital for me to be able to boot into hackintosh. I'll give it a shot tomorrow, thank you for the help :)
 
Top