Contribute
Register

[Guide] Intel Kaby Lake NUC7 using Clover UEFI (NUC7i7BNH, NUC7i5BNK, NUC7i3BNH, etc)

Status
Not open for further replies.

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,623
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hmm… Now when I came back after being away from home some days I have video just fine on my TV via HDMI from the NUC. Don't know what fixed it – maybe it was just the TV that needed to be power cycled.

It still says that ”Type” is ”DisplayPort” in System Preferences > Sound > Output for my Panasonic-TV (despite being connected to the NUC via HDMI) but since sound is working just fine I guess I can ignore that? The other oddity I've mentioned is that the AirPlay menu in the upper right corner of the screen looks like in the attached screen shot, i.e. MacOS thinks the TV is connected as a projector. But I gues that's nothing to worry about in this case? Like I said, things seems to work fine, so for now I think I will skip posting the troubleshooting files I prepared, saving you some time. :)

Thanks again for all the help! Looking forward to trying the Kaby Lake native graphics whenever you have the updated repository ready. Cheers!

No "Problem Reporting" files attached.
 
Joined
Jul 23, 2011
Messages
81
Motherboard
MacPro5,1
CPU
Intel "Westmere"
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
  2. Mac Pro
Classic Mac
  1. SE
Mobile Phone
  1. Android
  2. iOS

Attachments

  • sudo_touch_output.rtf.zip
    858 bytes · Views: 59
  • kextstat_output.rtf.zip
    1.2 KB · Views: 73
  • Archive_of_Downloads>RehabMan.zip
    50.9 KB · Views: 52
  • CLOVER.zip
    1.4 MB · Views: 70
  • HT-Mhack_IOReg.zip
    422.4 KB · Views: 58

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,623
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Yes, that was my intention. :)



But if you want to take a look I'll attach them. Thanks!

connector-type under AppleIntelFramebuffer@0 is HDMI <00 08 00 00>... as expected.
 
Joined
Jul 23, 2011
Messages
81
Motherboard
MacPro5,1
CPU
Intel "Westmere"
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
  2. Mac Pro
Classic Mac
  1. SE
Mobile Phone
  1. Android
  2. iOS
connector-type under AppleIntelFramebuffer@0 is HDMI <00 08 00 00>... as expected.

OK, I guess things are alright then. Seems to work fine, so I'll just ignore it for now.
 
Joined
Jul 19, 2017
Messages
5
Motherboard
NUC 7
CPU
i5
Hey RehabMan. I'm up and running with everything working well with the exception of sound, which just doesn't work despite all my attempts.

Following the Problem Reporting guidelines with my attachments....
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,623
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hey RehabMan. I'm up and running with everything working well with the exception of sound, which just doesn't work despite all my attempts.

Following the Problem Reporting guidelines with my attachments....

Your ACPI/patched content is wrong.
Read post #1.
 
Joined
Jul 19, 2017
Messages
5
Motherboard
NUC 7
CPU
i5
Your ACPI/patched content is wrong.
Read post #1.

Before coming here I read the entirety of post #1 and performed _all_ of the steps in post 1 (including the patch scripts), and it made no difference.

Any advice on wiping the slate clean and starting that part of the process again, or does it require wiping entirely and starting over, hoping for a better result?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,623
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Before coming here I read the entirety of post #1 and performed _all_ of the steps in post 1 (including the patch scripts), and it made no difference.

You did not.
You forgot to run 'make install_nuc7'.
You also forgot to fill out your profile with hardware details.
 
Joined
Jul 19, 2017
Messages
5
Motherboard
NUC 7
CPU
i5
You forgot to run 'make install_nuc7'.

I didn't! Perhaps the config changed later as I went through several other attempts to get this to work? But I absolutely did run every single one of those steps.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,623
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I didn't! Perhaps the config changed later as I went through several other attempts to get this to work? But I absolutely did run every single one of those steps.

If you had used it successfully, you would have SSDT-NUC7.aml in ACPI/patched.
 
Status
Not open for further replies.
Top