Contribute
Register

[Guide] HP ProBook/EliteBook/Zbook using Clover UEFI hotpatch

Status
Not open for further replies.

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,805
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Sleeps but wakes to reboot. Serial Port was never enabled. I have disabled Firewire. Thank you

misc/preboot.log is missing (you forgot to press F2).
Please read "Problem Reporting" carefully.

The ioreg still shows a serial port.
Try without GenericUSBXHCI.kext.
Try with fresh install and install only according to the guide, nothing else.
Compare with results on 10.12.6 as well.

Double check BIOS settings.
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,805
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,805
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Sorry, missed it.
Worked fine with 10.12.6.
This is an upgrade.

Do a fresh install to compare results.
Also, check that everything is still ok with 10.12.6 with current github project.
 
Joined
Jan 6, 2012
Messages
440
Motherboard
Gigabyte Aorus Z490 Elite
CPU
i9-10850K
Graphics
RX 580
Mobile Phone
  1. iOS
I have installed 10.13 (17A405) on my ProBook 450 G4. Most everything is working working correctly but sleep. After the machine is put to sleep by closing the lid or using the 'Sleep' command from the Apple menu, upon trying to rewake, I get a black screen. Using the brightness keys, I can see that the backlight is increasing/decreasing however the screen remains blank. The only way to get the screen to work is to reboot. Another minor nuisance issue I'm experiencing is that brightness and audio volume are set at maximum upon startup of macOS. Problem reporting files are attached.

Thanks in advance
-bth
 

Attachments

  • ProBook450G4.zip
    2.1 MB · Views: 53

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,805
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I have installed 10.13 (17A405) on my ProBook 450 G4. Most everything is working working correctly but sleep. After the machine is put to sleep by closing the lid or using the 'Sleep' command from the Apple menu, upon trying to rewake, I get a black screen. Using the brightness keys, I can see that the backlight is increasing/decreasing however the screen remains blank. The only way to get the screen to work is to reboot. Another minor nuisance issue I'm experiencing is that brightness and audio volume are set at maximum upon startup of macOS. Problem reporting files are attached.

Thanks in advance
-bth

What are the results with the same EFI/Clover on 10.12.6?
Note: You have an issue with Google Chrome. Read laptop FAQ:
http://www.tonymacx86.com/el-capita...faq-read-first-laptop-frequent-questions.html

Do a fresh install for comparison as well. I can see this is not likely a fresh install due to unnecessary software such as VirtualBox.

Finally, your files are not up-to-date with respect to the github project. Please make sure all files are current (as per post #1, this is something that should have been done prior to updating to 10.13).
 
Joined
Jan 6, 2012
Messages
440
Motherboard
Gigabyte Aorus Z490 Elite
CPU
i9-10850K
Graphics
RX 580
Mobile Phone
  1. iOS
Under 10.12.6, I had the same issue with max brightness and max volume upon startup, but no sleep issues. I did pull the latest files from from your git prior to installation and when I configured 10.13 post install. I will give it a try with a fresh install, but I resorted to the update from 10.12.6 because I was having issues with the USB installer not getting to the second phase of the install when I tried a fresh install. As for VirtualBox, I do use it to run a Windows 7 VM and have never had problems there. FWIW, my 4530s is working perfectly under 10.13, so I do thank you very much for that!

-bth
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,805
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Under 10.12.6, I had the same issue with max brightness and max volume upon startup,

Probably an NVRAM issue.
Since you have EmuVariableUefi-64.efi, keep in mind you must install "RC scripts" (in Clover installer).

I did pull the latest files from from your git prior to installation and when I configured 10.13 post install.

github has been updated quite often lately.

I will give it a try with a fresh install, but I resorted to the update from 10.12.6

Do a fresh install of 10.12.6 and 10.13.0 to separate partitions.
Then test those clean installs.
Don't forget to use the Clover installer, or else RC scripts will not be installed...

Because I was having issues with the USB installer not getting to the second phase of the install when I tried a fresh install.

You would need to provide details.

As for VirtualBox, I do use it to run a Windows 7 VM and have never had problems there.

Extra software has no place when troubleshooting.
 
Joined
Aug 6, 2013
Messages
19
Motherboard
HP EliteBook 840-G4 i7
CPU
i7-7500U
Graphics
HD 620
Mac
  1. iMac
  2. MacBook
Mobile Phone
  1. iOS
Installed on a Probook 440 G4 with OS X Sierra 10.12.6 using your custom Clover.
All that I need its running smoothly: HD620 Acceleration - VGA Port - Ethernet 8111 - Audio - USB (2.0 I think) - Function keys - Sleep - iCloud, external mice, keyboard and wifi (TL-WN722N).

Thanks for your time and for those amazing tools, kexts, configs and tutorials.
GO RAHABMAN!

Emanuel from Buenos Aires.
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,805
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Status
Not open for further replies.
Top