Contribute
Register

[Guide] HP ProBook/EliteBook/Zbook using Clover UEFI hotpatch

Status
Not open for further replies.

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,935
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I've had to order a displayport adapter since the damn laptop doesn't have an hdmi out. It will be here monday.

Good.
Your laptop might also support video from USB-C (if it has one), so that is another adapter you should have.

Any idea why another user with an almost identical laptop with the same specs except screen size (840 G3 vs 820 G3) would have no issues with 10.13? Should I do another clean install?

Could be different BIOS version, different memory configuration, different BIOS settings, different screen, etc.
 
Joined
Jun 4, 2016
Messages
96
Motherboard
HP elitebook 820 G3
CPU
I5-6200U
Graphics
HD 520 1366x768
Good.
Your laptop might also support video from USB-C (if it has one), so that is another adapter you should have.



Could be different BIOS version, different memory configuration, different BIOS settings, different screen, etc.

FYI, just did another clean install of 10.13, but this time did it without converting to APFS. No difference in sleep. Will post updated problem reporting files when I get the DisplayPort adapter.
 
Joined
Apr 26, 2014
Messages
16
Motherboard
b350
CPU
i7 3632qm
Graphics
hd4000
Mac
  1. Mac mini
Classic Mac
  1. Portable
Mobile Phone
  1. Android
  2. iOS
- 7-series laptop (Ivy Bridge or Sandy Bridge): HP Probook 4x40s, 4x0 G0, 6x70b, Elitebook 8x70p, 2x70p, 9470m
thanks for rehabman , may 2570p almost perfecrt. haha
 
Joined
Sep 24, 2017
Messages
8
Motherboard
HP ProBook 640 G1 (RAM: 16G) Wifi: BCM43225HMB
CPU
i5 4300M (Haswell)
Graphics
Intel HD4600, 1600x900
Hello,


I'm new to this, so please bear with me! :)
I have a spare laptop (HP Probook 6460b with Broadcom 43224), so i thought i give it a go and install High Sierra.
I followed the guide of creating the USB. Or at least i thought... when i boot the laptop from it, without any additional changes i get KP.
Could someone explain what kexts should be on the USB?
Do i need to explicitly select any of them before booting the install in Clover?

Thank you!
.A.
 
Joined
Dec 18, 2013
Messages
486
Motherboard
Lenovo Yoga C740
CPU
i7-10510U
Graphics
Intel UHD Graphics
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
Hello,...
Basically it is as described by the guide.
1. Format and partition the USB thumb drive
2. Install Clover to it
3. Copy the kexts, drivers and the proper config.plist to it (this is described in perfect detail)
4. Create/copy Install media
5. Boot the target laptop.
6. Install MacOS
7. Do the post-install stuff
8. You're done, look at the watch, go to bed, get some sleep and continue tomorrow.
 
Joined
Sep 11, 2011
Messages
24
Motherboard
Gigabyte Z87-HD3
CPU
Intel Core i5 4670k
Graphics
Gigabyte Gaming 1 GTX970
Mobile Phone
  1. Android
I installed all on my elitebook 8470 and everything works fine
But I hear a noise when i use headphone 30 after the silence in OS and when a sound starting to play again another noise heared before the sound, something like turn off and on for headphone in silences
is it normal ?
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,935
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hello,


I'm new to this, so please bear with me! :)
I have a spare laptop (HP Probook 6460b with Broadcom 43224), so i thought i give it a go and install High Sierra.
I followed the guide of creating the USB. Or at least i thought... when i boot the laptop from it, without any additional changes i get KP.
Could someone explain what kexts should be on the USB?
Do i need to explicitly select any of them before booting the install in Clover?

Thank you!
.A.

No "Problem Reporting" files attached.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,935
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I installed all on my elitebook 8470 and everything works fine
But I hear a noise when i use headphone 30 after the silence in OS and when a sound starting to play again another noise heared before the sound, something like turn off and on for headphone in silences
is it normal ?

It is part of putting the codec into idle and taking it out of idle (referred to as "D3hot" in the HDA spec).
Unfortunately, that process is not as smooth as it is on real Apple hardware.
 
Joined
Sep 16, 2015
Messages
7
Motherboard
ASUS P5QL Pro
CPU
Quad-Core Intel Xeon X5460
Graphics
NVIDIA GTX 1050
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. Android
Hi RehabMan,

Using your old thread and now this one i have everything working super fine on my Elitebook Folio 9470m.
Thanks for this great guide !

I have triple boot (OSX, Windows and Linux Mint) on the same SSD. Initial OSX was El capitan and always been updating till Sierra 10.12.6 without any problem what so ever. Now, when i tried to update to High Sierra without converting to APFS (using "/Applications/"Install macOS High Sierra.app"/Contents/Resources/startosinstall --converttoapfs NO") the update start but a few minutes later it shows the message :

"macOS could not be installed on your computer"
"This partition map modification would make a windows partition unbootable"

Do you have any clue what could be the problem ?
Any workaround to bypass this ?
 
Last edited:
Status
Not open for further replies.
Top