Contribute
Register

[Guide] Dell XPS 13 9360 on MacOS Sierra 10.12.x - LTS (Long-Term Support) Guide

Joined
Feb 10, 2019
Messages
5
Motherboard
idk9000
CPU
i5 7200u
Graphics
intel HD 620
Anyone managed to get the bluetooth working correctly? And if yes, how?
 
Joined
Apr 2, 2013
Messages
404
Motherboard
Dell XPS 13 (9360)
CPU
i7-8550u (8th Generation) Kalby Lake - R
Graphics
Intel UHD 620
Mac
MacBook Pro
Anyone managed to get the bluetooth working correctly? And if yes, how?

I think the majority of us do have it working. Do you have BrcmPatchRAM2.kext and BrcmFirmwareRepo.kext installed? What is your wifi card?

More info always helps towards a solution...
 
Joined
Apr 4, 2013
Messages
127
Motherboard
ASUS MAXIMUS VI Impact
CPU
i5-4670K
Graphics
GTX 770
Mac
MacBook
Mobile Phone
Android, iOS
Anyone managed to get the bluetooth working correctly? And if yes, how?
I'm also wondering about this. What's ur bt behaviour, @Ocytoxin ? Because mine isn't working properly as well. I can use it for airdrop (it's detected by other airdrop enabled devices, and able to transfer data), but not for pairing with peripherals like a bt headset or mouse.


I think the majority of us do have it working. Do you have BrcmPatchRAM2.kext and BrcmFirmwareRepo.kext installed? What is your wifi card?

More info always helps towards a solution...
In my case, i do have these two kexts inside clover's kexts/other folder, and I'm using DW1560.
 
Joined
Nov 17, 2016
Messages
51
Motherboard
Dell XPS13 9360 - Clover
CPU
i5-7200U
Graphics
HD 620, 1920x1080
Mac
MacBook Pro
Mobile Phone
Android
I'm also wondering about this. What's ur bt behaviour, @Ocytoxin ? Because mine isn't working properly as well. I can use it for airdrop (it's detected by other airdrop enabled devices, and able to transfer data), but not for pairing with peripherals like a bt headset or mouse.




In my case, i do have these two kexts inside clover's kexts/other folder, and I'm using DW1560.
BrcmFirmwareRepo must be putted inside LE, not EFI. If you want to use EFI you must use BrcmFirmwareData. Never use both, only Repo OR Data. Info are available in the birtbucket repo (rehabman)
 
Joined
Apr 4, 2013
Messages
127
Motherboard
ASUS MAXIMUS VI Impact
CPU
i5-4670K
Graphics
GTX 770
Mac
MacBook
Mobile Phone
Android, iOS
BrcmFirmwareRepo must be putted inside LE, not EFI. If you want to use EFI you must use BrcmFirmwareData. Never use both, only Repo OR Data. Info are available in the birtbucket repo (rehabman)
My bad. I'm using the BrcmFrimwareData.kext and BrcmPatchRAM2.kext inside EFI
 
Joined
Nov 17, 2016
Messages
51
Motherboard
Dell XPS13 9360 - Clover
CPU
i5-7200U
Graphics
HD 620, 1920x1080
Mac
MacBook Pro
Mobile Phone
Android
My bad. I'm using the BrcmFrimwareData.kext and BrcmPatchRAM2.kext inside EFI
I suggest you to use Repo instead of Data and put eveything (even BrcmPatchRAM2.kext) inside /L/E. Based on rehabman bitbucket this is more memory efficent. Maybe it can help you fixing your problem (I have DW1560 too and I can pair bt headphones without any issue). I followed this video from a user in this thread, check if you've done something different maybe:
 
Joined
Aug 1, 2012
Messages
431
Motherboard
Asus Z370 Prime A II
CPU
i9-9900K
Graphics
VEGA VII
Mac
MacBook Pro
Mobile Phone
iOS
After a while spent digging in this thread I'm rather positive about purchasing this Dell XPS9360. The only thing I'm still evaluating is if there is the possibility to change the keyboard, has anyone tried to do it?
 
Joined
Jul 3, 2014
Messages
934
Motherboard
Dell XPS 9360 (KabyLake R)
CPU
Intel i7 8550U
Graphics
Intel UHD 620
Mac
MacBook, MacBook Pro
Mobile Phone
Android
@the-darkvoid The newest build now works absolutely perfect on my i7-7500 with a custom CPUFriend.
Could you add an option to customize the bootchime, maybe add a pointer to a simple .ogg or .wav file that we can swap?

Thanks for your work!
If you could share your custom CPUFriend, I'll make it available for others in the repository.
Regarding the bootchime, I'm waiting for the functionality to stabilize in Clover.

When using the Clover native audio method, the results are varying and it does not work properly always.
Additionally the sound will not play during the Apple logo, but rather block the loading before.
 
Joined
Feb 20, 2019
Messages
47
Motherboard
Dell XPS 9360
CPU
i5-7200U
Graphics
HD 620
Did anyone find a fix for the audio cutting out? Happens to me regular after going from AC to battery power. Restart fixes it, im using the ALCID=56 and ComboJack. ID 11 made the problems worse. Thanks!
 
Top