Contribute
Register

[Guide] Catalina Gigabyte Z170 HD3P + i7-6700K + Sapphire Pulse RX 580 8Gb

Joined
Aug 9, 2011
Messages
3
Motherboard
Gigabyte GA-Z170N-Gaming Mini-ITX
CPU
i7-6700K
Graphics
HD 530
Mac
  1. iMac
  2. Mac mini
Classic Mac
  1. Centris
  2. iMac
  3. PowerBook
  4. SE/30
Mobile Phone
  1. iOS
Thank you CeeeWeee for providing the guide. I have a Gigabyte H170N-Gaming5 motherboard with the i7-6700k that I recently updated to Catalina.
Fortunately, the system can boot (bluetooth and ethernet and WIFI all work, as does iMessage), but the audio and onboard graphics are not recognized from my clover / update. I am climbing the steep learning curve and trying to decide between Clover and OpenCore. If I were to start with your posted EFI for OC, would you (or any other willing expert) be able to point me in the direction of what changes are needed to enable the audio and graphics?
Thanks in advance!
 
Joined
Aug 9, 2011
Messages
3
Motherboard
Gigabyte GA-Z170N-Gaming Mini-ITX
CPU
i7-6700K
Graphics
HD 530
Mac
  1. iMac
  2. Mac mini
Classic Mac
  1. Centris
  2. iMac
  3. PowerBook
  4. SE/30
Mobile Phone
  1. iOS
Thank you! Follow your guide (upgrading froView attachment 445451m Mojave) and it went well, except for Clover Boot, I am using Clover 4934, GA-Z170N-GAMING 5 motherboard with RX580 Graphics Card.
egneus, I have the same setup but with built-in graphics. Any chance you would be able to upload your EFI directory or config.plist and kexts used? I am having issues understanding how to enable audio and built-in graphics. Does your Hackintosh wake from sleep?
 
Joined
Feb 10, 2011
Messages
38
Motherboard
Gigabyte GA-Z170-HD3P
CPU
Core i5-6600 ?
Graphics
Nvidia GTX 650 Ti
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Mobile Phone
  1. iOS
Thanks CeeeWeee for the OC EFI example.
I had started with Dortania OC guide and followed it to the letter, but could not reliably boot OC to Catalina. (For some reason it was dead slow.)
Started with yours and made some tweaks and it works great. I have updated OC, kexts, and made a few more tweaks (like customized USBMap.kext), and it seems to work great with my rig. (NVMe + Nvidia GTX 650 Ti).
Note that I did have some strangeness w/ my nvidia card, so I pulled it out for initial installation, and used onboard intel graphics. Note that I had some initial troubles as screen would always go blank after some time booting - I was using onboard DVI adapter. Seems like it (WhateverGreen?) _really_ wants to switch over to HDMI, so I just used that for initial setup, then after everything was working, I put back in my nvidia card, and it worked without issues or anything special.
I did try doing some of the graphics customization (trying to force intel DVI connector output, but didnt really make progress. Gave up as I'm using nvidia card anyhow.)

If it's helpful for anyone, let me know, and I'll try to share my latest (sanitized) EFI w/ OC (based from CeeeWeee's).
 
Joined
Mar 5, 2021
Messages
2
Motherboard
Gigabyte GA-Z170-HD3P
CPU
i5-6600
Graphics
RX 570 + GTX 960
Thanks CeeeWeee for the OC EFI example.
I had started with Dortania OC guide and followed it to the letter, but could not reliably boot OC to Catalina. (For some reason it was dead slow.)
Started with yours and made some tweaks and it works great. I have updated OC, kexts, and made a few more tweaks (like customized USBMap.kext), and it seems to work great with my rig. (NVMe + Nvidia GTX 650 Ti).
Note that I did have some strangeness w/ my nvidia card, so I pulled it out for initial installation, and used onboard intel graphics. Note that I had some initial troubles as screen would always go blank after some time booting - I was using onboard DVI adapter. Seems like it (WhateverGreen?) _really_ wants to switch over to HDMI, so I just used that for initial setup, then after everything was working, I put back in my nvidia card, and it worked without issues or anything special.
I did try doing some of the graphics customization (trying to force intel DVI connector output, but didnt really make progress. Gave up as I'm using nvidia card anyhow.)

If it's helpful for anyone, let me know, and I'll try to share my latest (sanitized) EFI w/ OC (based from CeeeWeee's).
Hi,
same motherboard and cpu here (Z170-hd3p + i5-6600), but gtx 960 as graphics board.
I'm trying with an old version of Clover and various kext, but no success, I can't install Catalina into internal ssd.
Could you please post your EFI / plist? Thanks
Next week I'll install an RX570...
 
Joined
Mar 5, 2021
Messages
2
Motherboard
Gigabyte GA-Z170-HD3P
CPU
i5-6600
Graphics
RX 570 + GTX 960
Hi,
same motherboard and cpu here (Z170-hd3p + i5-6600), but gtx 960 as graphics board.
I'm trying with an old version of Clover and various kext, but no success, I can't install Catalina into internal ssd.
Could you please post your EFI / plist? Thanks
Next week I'll install an RX570...
Ok, I install Catalina osx with recent opencore; all works but audio...
 
Top