Contribute
Register

[Guide] Catalina Gigabyte Z170 HD3P + i7-6700K + Sapphire Pulse RX 580 8Gb

Joined
May 12, 2017
Messages
3
Motherboard
Z170-HD3P
CPU
i7-6700
Graphics
RX 580
Mobile Phone
iOS
Isn't AppleALC.kext in Multibeast supposed to take that in charge ?
 
Joined
Nov 18, 2018
Messages
63
Motherboard
Lenovo Ideapad S340
CPU
i5-8265U
Graphics
HD 620
Mobile Phone
iOS
I think I solved my reboot issue. It looks like my DVD RW drive may be causing the panics, I added the patch from here and it hasn't panic in a couple hours now. I am waiting on a PCI-E adapter to add a BRCM4360CS2 wifi card then I should be all good with the build.
 
Joined
Nov 10, 2016
Messages
3
Motherboard
GA-Z170X-UD3
CPU
i7-6700K
Graphics
RX 580
Mac
iMac
Mobile Phone
iOS
I struggled for 3 days before stumbling upon this guide. Thank you so much. This helped immensely.
 
Joined
Oct 10, 2011
Messages
51
Motherboard
Gigabyte GA-Z170X-UD5
CPU
i7-6700
Graphics
MSI RX 580
Mac
MacBook Pro
Mobile Phone
iOS
@CeeeWeee
Is it necessary to do the Multibeast installation? even if there is no version for Catalina only the one for Mojave
Btw: i have a i7 4790K + Mob Asus Z97-P + RX 580
I'm about to install Catalina and i don't know if i need togo through these steps:
Or just pass directly to copying Kexts?

I'm wondering the same thing. No Multibeast for Catalina, are you all just skipping that step?
 
Joined
Feb 29, 2016
Messages
22
Motherboard
Asus Z170i pro gaming
CPU
i5-6600k
Graphics
Intel HD530
Mobile Phone
iOS
First - there a good general guides already. Will concentrate on what worked for this specific setup. It is an older system and therefore some might need that.

Fresh Install (upgrade is below)
  1. Create boot disk as stated here in the Update directly to MacOs Catalina thread
    • Remember to use the mentioned config.plist from This
    • Use Clover 5070
    • Use the following kexts (in /EFI/CLOVER/kexts/Other/)
      • AppleALC.kext
      • FakeSMC.kext
      • Lilu.kext
      • NullCPUPowerManagement.kext
      • RealtekRTL8111.kext
      • WhateverGreen.kext
    • Add the following files in a sub folder on the USB
      • Clover 5070 install
      • Latest MultiBeast
      • Clover Configurator
  2. Boot and install from your USB and choose the Catalina install disk
    • I would start formatting your target disk with the Disk Tool - remember to use APFS
    • Will boot 3 times during install
    • Just before I was to login for the first time I got Black Screen
      • Use HDMI to finalize the setup - you can revert to DisplayPort later
      • (if you boot with injecting AMD graphics you might not see this)
    • Complete your setup and you should now be in Catalina
      • Network, sound etc might not work yet
      • Do NOT state that you will be using a network (the setup guide crashes)
  3. First thing thereafter is to install EFI
    • In terminal run "sudo mount -uw /". Otherwise you cannot install Clover
    • Run MultiBeast with the following ticked
    • View attachment 431142
    • Thereafter install Clover 5070
    • Just to be sure I copied the 6 mentioned kexts to /EFI/CLOVER/kexts/Other/
  4. Now configure your Config.plist
  5. Save the Config.plist - Reboot
  6. All should be working now. You can use the DisplayPort again. Go ahead and create your SMBIOS settings BEFORE YOU LOGIN TO ICLOUD
Upgrade from Mojave
  1. Make a backup ;) (I can recommend CCC)
  2. Do step 3 from above (the sudo mount is not needed)
  3. Do step 4 from above - in principle it should not need much adjustment if your current setup in Mojave is working. But the ATI Inject is important to avoid the black screen
  4. Reboot
  5. Go to System Upgrade - Upgrade to Catalina
    • On first reboot choose the Preboot installer - next reboot choose the Install - and finally the MacOS
  6. You should now have a well running Catalina
Hope this helps some of you out there with an "older" Motherboard.

Update 12-FEB-2020
************************************************************************
**************************** INFO ON THE GUIDE *************************
************************************************************************

I swapped out my Sapphire RX580 with GIGABYTE Radeon RX 5700 XT GAMING OC

Process was:
- Remove old - insert new :clap:
- Add agdpmod=pikera to the bootflag
- Remove ATI Injection
=> Works

****** This means the guide might be limited on RX 580 advice going forward ********
************************************************************************
First - there a good general guides already. Will concentrate on what worked for this specific setup. It is an older system and therefore some might need that.

Fresh Install (upgrade is below)
  1. Create boot disk as stated here in the Update directly to MacOs Catalina thread
    • Remember to use the mentioned config.plist from This
    • Use Clover 5070
    • Use the following kexts (in /EFI/CLOVER/kexts/Other/)
      • AppleALC.kext
      • FakeSMC.kext
      • Lilu.kext
      • NullCPUPowerManagement.kext
      • RealtekRTL8111.kext
      • WhateverGreen.kext
    • Add the following files in a sub folder on the USB
      • Clover 5070 install
      • Latest MultiBeast
      • Clover Configurator
  2. Boot and install from your USB and choose the Catalina install disk
    • I would start formatting your target disk with the Disk Tool - remember to use APFS
    • Will boot 3 times during install
    • Just before I was to login for the first time I got Black Screen
      • Use HDMI to finalize the setup - you can revert to DisplayPort later
      • (if you boot with injecting AMD graphics you might not see this)
    • Complete your setup and you should now be in Catalina
      • Network, sound etc might not work yet
      • Do NOT state that you will be using a network (the setup guide crashes)
  3. First thing thereafter is to install EFI
    • In terminal run "sudo mount -uw /". Otherwise you cannot install Clover
    • Run MultiBeast with the following ticked
    • View attachment 431142
    • Thereafter install Clover 5070
    • Just to be sure I copied the 6 mentioned kexts to /EFI/CLOVER/kexts/Other/
  4. Now configure your Config.plist
  5. Save the Config.plist - Reboot
  6. All should be working now. You can use the DisplayPort again. Go ahead and create your SMBIOS settings BEFORE YOU LOGIN TO ICLOUD
Upgrade from Mojave
  1. Make a backup ;) (I can recommend CCC)
  2. Do step 3 from above (the sudo mount is not needed)
  3. Do step 4 from above - in principle it should not need much adjustment if your current setup in Mojave is working. But the ATI Inject is important to avoid the black screen
  4. Reboot
  5. Go to System Upgrade - Upgrade to Catalina
    • On first reboot choose the Preboot installer - next reboot choose the Install - and finally the MacOS
  6. You should now have a well running Catalina
Hope this helps some of you out there with an "older" Motherboard.

Update 12-FEB-2020
************************************************************************
**************************** INFO ON THE GUIDE *************************
************************************************************************

I swapped out my Sapphire RX580 with GIGABYTE Radeon RX 5700 XT GAMING OC

Process was:
- Remove old - insert new :clap:
- Add agdpmod=pikera to the bootflag
- Remove ATI Injection
=> Works

****** This means the guide might be limited on RX 580 advice going forward ********
************************************************************************
Hello just a curiosity: do you have sidecar and airplay icon working? I have the sidecar application but no airplay working. Thank you
 
Joined
Nov 9, 2016
Messages
10
Motherboard
Asus Z170 Pro
CPU
i5 > Need model # > See Rules!
Graphics
GTX 970
Mac
MacBook, MacBook Pro
Am struggling with a very similar setup, my motherboard is an Asus Z170 Pro Gaming. Any idea how I could get it to work with it?
 
Top