Contribute
Register

GTX 660 glitch issue with MacOS High Sierra 10.13

Joined
Nov 3, 2012
Messages
37
Motherboard
AsRock H310CM
CPU
i3-8100K
Graphics
RX 460
Mac
  1. iMac
Mobile Phone
  1. iOS
So the GTX650 Ti Boost also has problems in High Sierra. Probably the entire 6xx Kepler series graphics cards have graphics problems in High Sierra, then.
I have the GTX 650 Ti (not boost) working in high Sierra without any problem, no glitches, no Tetris.
 
Joined
May 16, 2010
Messages
254
Motherboard
Gigabyte Z370-HD3
CPU
i5-8600K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
I have the GTX 650 Ti (not boost) working in high Sierra without any problem, no glitches, no Tetris.
That is my experience as well-- I ended up swapping out the GTX 660 in my secondary Hack due to the graphics glitches and am using my GTX 650 Ti instead. So far no issues with that one.
 
Joined
Aug 2, 2011
Messages
27
Motherboard
I still didn't read
CPU
the RULES
Graphics
so ignore me
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I have the GTX 980 Ti and I can not boot with UniBeast, any ideas?
 
Joined
Jun 9, 2015
Messages
26
Motherboard
Gigabyte Z370 AORUS Gaming 5
CPU
i3-8100
Graphics
UHD 630
I have the GTX 980 Ti and I can not boot with UniBeast, any ideas?

Create a new thread, please. Please don't hijack this one with your unrelated issue. If your post isn't about graphics corruption or glitches in 10.13, it belongs elsewhere.
 

Jamesbond007

Moderator
Joined
May 21, 2011
Messages
5,785
Motherboard
Z390 Designare
CPU
i7 9700KF
Graphics
RX 580 Pulse Lite
Mac
  1. Mac mini
Mobile Phone
  1. iOS
I have the GTX 650 Ti (not boost) working in high Sierra without any problem, no glitches, no Tetris.

Oh really? Thank you for your information. Then apparently not all Kepler cards have this problem.
 
Joined
Jun 12, 2016
Messages
3
Motherboard
Intel DZ87KLT-75K
CPU
Intel Core i5-4670K
Graphics
Asus GeForce GTX 650 Ti BOOST
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Oh really? Thank you for your information. Then apparently not all Kepler cards have this problem.

I have GTX 650 Ti BOOST (2gb version) and I have glitches and artifacts on 10.13.1.
 
Joined
Apr 21, 2013
Messages
7
Motherboard
Asus Z97i Plus
CPU
core i7 4790
Graphics
GTX 660
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Mobile Phone
  1. Android
  2. iOS
I have the GTX 650 Ti (not boost) working in high Sierra without any problem, no glitches, no Tetris.
Please do a simple test:... start Youtube in browser and watch any video in normal view, them expand to full screen view, do several times expand normal to full screen and see if in full mode screen the glithes appear... in my system the glitches come on when I do this... then after a while it disapear and then came back again ... but if I don´t watch any video in ex: youtube, the system are normal and smooth... for me the glitches come when I watch videos... or if I use Final Cut Pro X, please tell us yours experiences. B. Regards
 
Joined
May 16, 2010
Messages
254
Motherboard
Gigabyte Z370-HD3
CPU
i5-8600K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Please do a simple test:... start Youtube in browser and watch any video in normal view, them expand to full screen view, do several times expand normal to full screen and see if in full mode screen the glithes appear... in my system the glitches come on when I do this... then after a while it disapear and then came back again ... but if I don´t watch any video in ex: youtube, the system are normal and smooth... for me the glitches come when I watch videos... or if I use Final Cut Pro X, please tell us yours experiences. B. Regards
Watched several Youtube videos in Safari using the GTX 650 Ti-- resizing videos etc. No sign of issues. When I had the GTX 660 installed the glitches started right away after booting- no need to work at making them happen. Note that this is on my Z97M mobo machine. Attached config.plist if it helps at all...
 

Attachments

  • config.plist
    6.6 KB · Views: 207
Last edited:
Joined
Nov 3, 2012
Messages
37
Motherboard
AsRock H310CM
CPU
i3-8100K
Graphics
RX 460
Mac
  1. iMac
Mobile Phone
  1. iOS
Watched several Youtube videos in Safari using the GTX 650 Ti-- resizing videos etc. No sign of issues. When I had the GTX 660 installed the glitches started right away after booting- no need to work at making them happen. Note that this is on my Z97M mobo machine. Attached config.plist if it helps at all...
I have also tested Youtube videos in Safari using the GTX 650 Ti resizing videos and no issues.
 
Top