Contribute
Register

Gigabyte GC-Alpine Ridge 2.0 Thunderbolt 3 Card in Gigabyte Z370 Aorus Gaming 7 + i7-8700K

Joined
Jan 10, 2019
Messages
15
Motherboard
AORUS Z370 Gaming 7
CPU
i7-8700K
Graphics
RX 580
Hi all

I'm pretty new to building Hackintoshes. So I managed to build my first one based on a successful build using:

Gigabyte Z370 Aorus Gaming 7
i7-8700K
Sapphire PULSE Radeon RX580
Samsung 970 EVO
Corsair Vengeance LPX (16GB)

Mojave Install was smooth and easy and everything just worked fine... Now I got myself a GC-Alpine Ridge 2.0 Thunderbolt 3 Card and just installed the card.

I am not sure what I have to do besides some settings in the BIOS (that I found in another thread)? System Profiler does not "show" the card... :(

Can anyone please help me out? Thanks!
 
Joined
Jan 13, 2019
Messages
15
Motherboard
Gigabyte AORUS Z390 PRO
CPU
i9 9900K
Graphics
Vega 64
Did you connect the DP port of the graphics card to the mini-DP port on alpine ridge? Also you need to connect the THB_C port on the motherboard with the card internally.

For the first time I installed the thunderbolt driver from the alpine ridge website on my dual boot windows disk. I immediately saw the Apple Thunderbolt Display and all other devices connected via daisy chain (including the audio, camera etc). Now you should be able to boot into Mac and see all your devices there.

The thunderbolt section in the system profiler will still not show any drivers. But for me all the devices are shown in the USB section.

Only the online swap of thunderbolt devices does not work for me but that is fine.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
4,694
Motherboard
Gigabyte Designare Z390
CPU
i7-9700K
Graphics
RX 580
Mac
MacBook Air, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
@madmarkdj

You may need to download two SSDTs from KGP's github repository:
  1. SSDT-DTPG.aml
  2. SSDT-X299-TB3HP.aml
SSDT #2 may need to be modified for the PCI device path for your GC-Alpine Ridge card.

You can try it as-is by copying both files to your CLOVER/ACPI/patched folder and rebooting. Then go to System Information --> PCI page and see if the Alpine Ridge controller is listed.

If it does not work as-is, I might be able to modify it for you if you run IORegistryExplorer and upload your IOReg dump.
 
Joined
Jan 10, 2019
Messages
15
Motherboard
AORUS Z370 Gaming 7
CPU
i7-8700K
Graphics
RX 580
@madmarkdj

You may need to download two SSDTs from KGP's github repository:
  1. SSDT-DTPG.aml
  2. SSDT-X299-TB3HP.aml
SSDT #2 may need to be modified for the PCI device path for your GC-Alpine Ridge card.

You can try it as-is by copying both files to your CLOVER/ACPI/patched folder and rebooting. Then go to System Information --> PCI page and see if the Alpine Ridge controller is listed.

If it does not work as-is, I might be able to modify it for you if you run IORegistryExplorer and upload your IOReg dump.
@CaseySJ Copying as-is didn't work... How can I do the IOReg dump thing?
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
4,694
Motherboard
Gigabyte Designare Z390
CPU
i7-9700K
Graphics
RX 580
Mac
MacBook Air, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
@CaseySJ Copying as-is didn't work... How can I do the IOReg dump thing?
Simply download and run IORegistryExplorer. Then from the File menu, choose Save As... (or any option that looks like it will save the IOReg dump).
 
Joined
Jan 13, 2019
Messages
15
Motherboard
Gigabyte AORUS Z390 PRO
CPU
i9 9900K
Graphics
Vega 64
@CaseySJ followed your posts on other the other thread to edit the aml and now my hot swap works :)
I can also see the pcie card in system info. The file without change did not work.
thanks
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
4,694
Motherboard
Gigabyte Designare Z390
CPU
i7-9700K
Graphics
RX 580
Mac
MacBook Air, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
@CaseySJ followed your posts on other the other thread to edit the aml and now my hot swap works :)
I can also see the pcie card in system info. The file without change did not work.
thanks
That's awesome! Glad to see the initiative!
  • Do you have the same GC-Alpine Ridge card?
  • If so, I wonder if it's plugged into the same PCI slot as @madmarkdj?
  • Because I'm still away from home, can you upload your SSDT for him to try?
 
Joined
Jan 13, 2019
Messages
15
Motherboard
Gigabyte AORUS Z390 PRO
CPU
i9 9900K
Graphics
Vega 64
@madmarkdj you can try these files

If you upload your IORegistryExplorer extract I will try to modify it for you.

My card is same as yours but it may be in another slot. I just had to change the name of the slot where the card is installed. The slot is identified as a 4 character string.
 

Attachments

Joined
Jan 13, 2019
Messages
15
Motherboard
Gigabyte AORUS Z390 PRO
CPU
i9 9900K
Graphics
Vega 64
@madmarkdj I could not find any details of your thunderbolt card in the IORegistry extract. It seems the system does not pick the card. Is the card connected to the thb port on the motherboard and you have followed the gc-alpine ridge guide for all the connections?
 
Top