Contribute
Register

Geforce 980 Graphics card not Recognized.

Joined
Dec 7, 2015
Messages
25
Motherboard
Sabertooth Z97 Mark 2-USB3.1
CPU
I7-4790K
Graphics
GTX 980
Mac
  1. iMac
Just followed the setup
http://www.tonymacx86.com/el-capita...-el-capitan-any-supported-intel-based-pc.html
and got everything working but it seems the driver doesn't recognize the card.
I have used the latest driver from here
http://www.tonymacx86.com/graphics/...raphics-drivers-os-x-10-11-2-346-03-04-a.html
and it installed fine but it still wont recognize the card.

I installed the os with El Capitan and wondering if its worth redoing the whole install with Yosmite. I see that Nvidia had a driver for Yosimite but it dosen't look like there is a driver for the 980 card.
Looking for some help or direction on how to get it working.
Thanks
 

slim.jim

Moderator
Joined
Dec 17, 2014
Messages
4,288
Motherboard
MSI Z97 Gaming 9 AC
CPU
i7-4790K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
The drivers fully support that card. When you say not recognizing what do you mean? Will it not boot or is the information in about this Mac wrong?
 
Joined
Dec 7, 2015
Messages
25
Motherboard
Sabertooth Z97 Mark 2-USB3.1
CPU
I7-4790K
Graphics
GTX 980
Mac
  1. iMac
I have got everything to load. The OS is loaded and I loaded the latest nvidia web driver. But when I go into Settings>nvida; I cant see the driver. My resolution is stuck at 960x650.

There are no other resolutions to select from and it seems to not be able to find the card.

I booted with nv-disable=1 which I realize works around the card but that was the only way I could get the install to work. When I use the boot flag nvda_drv=1 it crashes and restarts.
 

slim.jim

Moderator
Joined
Dec 17, 2014
Messages
4,288
Motherboard
MSI Z97 Gaming 9 AC
CPU
i7-4790K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
You are running 10.11.2?

What monitor and what connection are you using?

Even with nv_disable=1 you should still be getting full resolution. If I boot using my GTX 970 using nv_disable my resolution is 1920x1200 just without acceleration.
 
Joined
Dec 7, 2015
Messages
25
Motherboard
Sabertooth Z97 Mark 2-USB3.1
CPU
I7-4790K
Graphics
GTX 980
Mac
  1. iMac
Post your config.plist.

I see you posted this to another thread "This is very basic and depending on how you installed Clover will determine its location. It is either in the EFI/CLOVER folder in the root of your OS X partition or it is in the EFI partition of the HDD where OS X is installed. Edit it using text edit."

But I only see "firmware.scap" file in that folder. Can you instruct me on how to get you the config.plist? Ill keep searching on how to find it in the mean time.
Really appreciate your help.
 
Joined
Dec 7, 2015
Messages
25
Motherboard
Sabertooth Z97 Mark 2-USB3.1
CPU
I7-4790K
Graphics
GTX 980
Mac
  1. iMac
I attached the MultiBeast config. Still cant find the config.plist. I also saw on another thread where you advise to use iMac14,2 instead of MacPro6,1. If you advise I will redo the startup with this selection. Do you advise using Yosemite rather than El Capitan?

I need this machine up and running for work and have been researching as much as possible to get this machine running. Seems like its close as the OS loads with ease just need to figure out the graphics issue.
Again any support is greatly appreciated.
 

Attachments

  • currentconfig.pdf
    17.6 KB · Views: 351
Top