Contribute
Register

First Build! > MSI H81M-E33 | Intel Core i7 4770 | Sapphire R9-270X

Joined
Aug 22, 2015
Messages
5
Motherboard
MSI H81M-E33
CPU
Intel Core i7 4770
Graphics
Sapphire R9-270X
Mobile Phone
Android
My First Build:
MSI H81M-E33 - Intel Core i7 4770 - Sapphire R9-270X


Components

MicroATX Computer Case with 400W
https://www.amazon.com/dp/B004ASW73G/?tag=tonymacx86com-20


Motherboard MSI H81M-E33
https://www.amazon.com/dp/B00F42W70A/?tag=tonymacx86com-20


Intel Core i7 4770 Processor
https://www.amazon.com/dp/B00CO8TBNS/?tag=tonymacx86com-20


DDR3 Memory Kingston HyperX Fury 16 GB (2x8GB)
https://www.amazon.com/dp/B00J8E8YES/?tag=tonymacx86com-20


Sapphire Radeon R9 270X 4GB GDDR5 Graphics Card
https://www.amazon.com/dp/B00FLMKN6I/?tag=tonymacx86com-20


Toshiba 500 GB HDD
https://www.amazon.com/dp/B00B6A8VFY/?tag=tonymacx86com-20


Sceptre 40 inch 4k TV
https://www.amazon.com/dp/B01NAJ84Y5/?tag=tonymacx86com-20



Comments

I didn't actually build this computer for hackintosh purposes, I bought it a couple of years ago for gaming, upgraded the memory and the graphics card and started playing every game I liked, I know it's not top notch but still I managed to run GTA V and FIFA 17 on it so no complaints. Anyway, I everything is "already owned" because I didn't buy anything for Mac OS purposes, however I did choose Intel-friendly components because I've always considered it better than the rest and I'm glad I did.

Ever since I heard the word mackintosh and knew what it meant, I wanted to do it myself, I've always been geek so it caught my attention immediately, I had been trying and failing ever since the Snow Leopard days, back then the bootable device was a CD, not a USB as it is right now, I failed in previous laptops and desktops, I also failed in this same computer, however this time the process was surprisingly simple...

UEFI Settings:

1. I Pressed and held Delete at startup when the motherboard logo was on the screen.
2. I chose Optimize Defaults.
3. I saved and exit.


Installation



1. Obviously I used a Mac to download Sierra OS, I had to borrow it from an acquaintance because I don't have one.

2. I downloaded UniBeast and created a bootable USB drive, this part was painful because for some weird reason Unibeast always gave me an error message, saying "Unibeast quit unexpectedly" so I re-formatted the USB device and tried again, found myself in what seemed to be an eternal loop, I finally decided to try to boot from the USB drive despite the error message, fortunately it worked so if you have the same error I had, don't panic, the process was probably successful. I didn't include graphics drivers in UniBeast because it gave me another error, I went for the basics.

3. I booted from the USB thing and it gave me the menu, I tried to launch the installer and surprise, it went right away, like I said it was surprisingly simple!


Problem Solving


4. I installed Sierra OS and then went straight to MultiBeast, I chose UEFI Boot Mode and since I didn't have any sound I tried to install the sound drivers I thought were appropriate, at this point I need to give you an advice: Don't do what I did, never try to guess what driver is best for you, go back to Windows if you have to and if you have both OS systems as I do, find out what is the exact audio component or whatever device you have troubles with and then install the appropriate driver in MultiBeast, it would have saved me a lot of time if I had done it instead of installing like half of them without success.

5. I forgot to mention that both my wireless keyboard and wireless mouse worked right after the installation, I didn't have to do anything for them to work. However, while playing with MultiBeast, for some weird reason I decided to install an Ethernet driver and my internet, that so far had been working, disappeared. My advice here is: If it ain't broken, don't fix it! Sometimes you don't have to manually install a driver for everything just because most of the tutorials give you that impression.

6. I couldn't get my internet to work, I removed the Ethernet driver I stupidly installed, well I actually didn't know how to uninstall it so I just deleted the related kext file. What I did was to insert again the pain driver and boot from there, choosing the option to repair/reinstall my Mac. While in the process it said on the screen that it needed to verify my system or something like that, I thought Apple was going to blow my cover and almost had a heart attack but again, surprise, it was successful, my Sierra was repaired, my internet was back and my Sierra version was updated, it was not the same one I originally installed!

7. Still no sound, I was in YouTube, trying to listen to The Doors, but Jim Morrison's voice was gone. I went online, checked what audio device my motherboard has and installed the necessary Audio Driver, which ended up being Related ALC898.

8. And guess what??? Still no sound. I went to System Preferences >> Audio >> Output and chose "Internal Speakers". It was then when Jim Morrison came back with Break on Through (to the Other Side). My speakers are connected to the computer through a Bluetooth transmitter, that's what caused the confusion for me but after all it was not about the audio driver or bluetooth issues, it was just that I had to use the right Output device on System Preferences. My Advice: don't underestimate the power of common sense solutions!.

What Does Not Work?

So far, everything works, except for iMessage, I know there is a tutorial to make it work but I'm too tired to try it, I just finished all the process yesterday!
There is though one thing that does not work and it is the boot loader that I though was going to let me choose between Windows or Sierra when I power my computer on, it does show me the option to boot Sierra from... and boot Windows from... but if I choose Windows nothing happens, so what I have to do is to press F11 at motherboard logo and choose the HDD where I have Windows installed, then it boots with no problem, I'll try to fix it and update this post if so.


Untested:


WiFi internal card


Thank You for Reading!

I'll try to see the moderators' tutorial later to see what else I can add to this post or what I missed but let's stop here for now, I'm just trying to share my mistakes in hopes of doing this process a bit easier for others.
 
Last edited:
Joined
Jul 27, 2018
Messages
2
Motherboard
MSI h81m e33
CPU
i7 4770
Graphics
GT 210
Mobile Phone
iOS
could you please upload the EFI folder ? i have the same motherboard
 
Top