Contribute
Register

EFI Agent v1.3.2 (menu bar utility)

Joined
Jun 20, 2014
Messages
1,017
Motherboard
Gigabyte Aero 15X v8-BK4K4P
CPU
i7-8750H
Graphics
UHD 630 / GTX 1070
Simple, low resource, efficient and no frills tool to mount EFI partitions.

Features:
  • Shows EFI disks to mount / unmount and open in Finder
  • Shows disk icons and color-coded partition scheme
  • Shows boot EFI partition (uses IODeviceTree:/chosen/boot-device-path if IODeviceTree:/options/efi-boot-device is unavailable)
  • Shows link for APFS containers to physical store and vice versa
  • Shows device name if media name is not available
  • Mount / unmount, eject and open context menu for partition scheme table
  • Tools to delete APFS container or converting HFS to APFS
  • Shows notifications on disk actions
  • Percentage bars show space used on mounted partitions
  • Drag the position of the splitter to adjust the table views
  • Launch at Login option
Download EFI Agent
MountEFI01.pngMountEFI02.png
 
Last edited:

UtterDisbelief

Moderator
Joined
Feb 13, 2012
Messages
6,583
Motherboard
Gigabyte Z490i Aorus Ultra - OC 0.6.8
CPU
i5-10600K
Graphics
GT710 - 1920x1080
Mac
  1. iMac
  2. Mac mini
Classic Mac
  1. eMac
  2. iBook
Mobile Phone
  1. iOS
Looks to be very handy :thumbup: Thanks for all your effort in producing it.

One of those hard-to-understand things we have to cope with using APFS is what containers are where and doing what :crazy: Is there a Getting Started Guide or User Guide anywhere?

:)
 

jaymonkey

Moderator
Joined
Aug 27, 2011
Messages
3,996
Motherboard
GB Z490 Vision G
CPU
i9 10850K OC @ 5.2 GHz
Graphics
Vega 64 LC + HD 630
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Mobile Phone
  1. iOS
@headkaze,

As noted by @hexart above, I too get an empty partition scheme with version 1.11 of MountEFI ...

392566

Let me know if there is anything you need in way of debugging the issue.

Cheers
Jay
 
Joined
Jun 20, 2014
Messages
1,017
Motherboard
Gigabyte Aero 15X v8-BK4K4P
CPU
i7-8750H
Graphics
UHD 630 / GTX 1070
@jaymonkey @hexart can you try the attached version. I'm thinking it might be related to reading the custom icon. In this version I've removed it.
 

jaymonkey

Moderator
Joined
Aug 27, 2011
Messages
3,996
Motherboard
GB Z490 Vision G
CPU
i9 10850K OC @ 5.2 GHz
Graphics
Vega 64 LC + HD 630
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Mobile Phone
  1. iOS
@jaymonkey @hexart can you try the attached version. I'm thinking it might be related to reading the custom icon. In this version I've removed it.


@headkaze,

Unfortunately its the same for me buddy, still have an empty partition scheme with MountEFI Version 1.1.2 :-

392708

Cheers
Jay
 
Joined
Jun 20, 2014
Messages
1,017
Motherboard
Gigabyte Aero 15X v8-BK4K4P
CPU
i7-8750H
Graphics
UHD 630 / GTX 1070
Can you download from the official link again and then run MountEFI.app/Contents/MacOS/MountEFI from Terminal and see if it spits out any errors.

It's weird I've tested it on my 3 Hackintoshes and it runs fine on all of them.
 
Joined
Oct 23, 2010
Messages
22
Motherboard
ASRock Z390 Phantom-Gaming ITX
CPU
i7-9700K
Graphics
RX 570
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
  4. Mac mini
  5. Mac Pro
Classic Mac
  1. iMac
  2. Performa
  3. Power Mac
  4. PowerBook
Mobile Phone
  1. iOS
Can you download from the official link again and then run MountEFI.app/Contents/MacOS/MountEFI from Terminal and see if it spits out any errors.

It's weird I've tested it on my 3 Hackintoshes and it runs fine on all of them.

Hi,

I also tried it and it is showing nothing. MountEFI startet from Terminal shows no errors.
High Sierra 10.13.6 (17G5019)
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
17,452
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Vega 56 (Bios flashed to 64)
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Version 1.1.2 working fine here. Thanks, headkaze!!

392773
 
Top