Contribute
Register

EBIOS read error: Error 0x31 Block 0x0 Sectors 0

Joined
Oct 22, 2012
Messages
84
Motherboard
ASUS Z170 A
CPU
i7 6700k
Graphics
ASUS MARS ROG dual GTX 760
Mac
MacBook Pro
Classic Mac
PowerBook
Mobile Phone
iOS
im have a same error on gigabyte ga-z77-d3h always wen boot the chimera bootloader write in screen 4 times the error message "EBIOS read error: Error 0x31. Block 0x0 Sectors 0"
this error its generated when the bootloader try to read the internal memory card (conected at internal usb port) as if it was a disc in here
4 errors for 4 port
im try to
a) disconect the card, boot and no error ---> work, but not valid workaround if im like to use memory card
b) disable on bios the "support legacy usb" ---> work, but not valid workaround if im like to use keyboard usb to intercept boot to select options or different partition to boot
c) in uefi bios of the z77 im found in advanced mode, in tab peripherals well down a option to configure how its treated the usb devices conected to the motherboard.
by default alll figure as auto
the card appear as "Generic Storage Device 0.00" and i set to FDD or CDROM type , save and reboot
voila no more error message "EBIOS read error: Error 0x31. Block 0x0 Sectors 0"
Great works for me in my mobo Z68 xp ud3 rev 1.3 with last uefi bios :headbang::headbang:
 
Joined
Mar 9, 2011
Messages
642
Motherboard
Gigabyte Z390 UD
CPU
i9-9900K
Graphics
RX 5700 XT
Mac
iMac, MacBook Pro, Mac Pro
Classic Mac
iMac
Mobile Phone
iOS
This method worked a treat. By disabling the card reader as a bootable device no more error message. The card reader is still enabled and everything works once I boot into the operating system but it's just not a bootable device as it was before this was after I updated my Z77–DS3H motherboard
 
Joined
Feb 2, 2014
Messages
1
Mac
Classic Mac
Mobile Phone
Setting USB Legacy to Off in the BIOS did the trick thanks.

GA-Z87-D3HP ML
 
Joined
Apr 21, 2011
Messages
11
Motherboard
NUC8i5BEH
CPU
i5-8259U
Graphics
Intel(R) Iris(TM) Plus Graphics 655
Mac
MacBook Air, Mac mini
Mobile Phone
iOS
When I try to boot into ML, I get the following message 4 times while Chimera is loading:

EBIOS read error: Error 0x31
Block 0x0 Sectors 0
I started having the same thing happen this afternoon. Turned out to be my cell phone. Forgot I had plugged it in to charge. :)
 
Joined
Mar 22, 2013
Messages
58
Motherboard
Gigabyte Z390 AORUS PRO
CPU
i7-9700K
Graphics
MSI RX 5700 XT
Mac
iMac
Mobile Phone
Android, iOS
Interesting. I found that there's an update for my UEFI/BIOS (version F18), updated it and now the problem is gone. Maybe you can try that too.

Regards
CK
Same here I installed the latest BIOS " mb_bios_ga-z87x-ud3h_f8 " on my GA-Z87X-UD3H and the problem is gone ;)

Cool...
 
Joined
Mar 22, 2013
Messages
58
Motherboard
Gigabyte Z390 AORUS PRO
CPU
i7-9700K
Graphics
MSI RX 5700 XT
Mac
iMac
Mobile Phone
Android, iOS
Interesting. I found that there's an update for my UEFI/BIOS (version F18), updated it and now the problem is gone. Maybe you can try that too.

Regards
CK
You are right CK, I installed the latest Bios mb_bios_ga-z87x-ud3h_f8 in a GA-Z87X-UDH3 and the problem is gone ....

Cool
 
Joined
Mar 9, 2014
Messages
13
Motherboard
Mavericks
CPU
2600k
Graphics
i7 GPU
Mac
Classic Mac
Mobile Phone
i have this same problem and I am using a SanDisk USB 2.0 card reader with a CF2 card to BOOT and INSTALL OSX on my PC.

I also get these errors approx 4 total, interesting as the USB drive comes up as 4 separate drives on boot select screen AND in windows operating systems
 
Joined
Sep 8, 2012
Messages
14
Motherboard
MSI H97 Gaming 3
CPU
Core I-7
Graphics
Geforce GTX1050ti
Mobile Phone
iOS
im have a same error on gigabyte ga-z77-d3h always wen boot the chimera bootloader write in screen 4 times the error message "EBIOS read error: Error 0x31. Block 0x0 Sectors 0"
this error its generated when the bootloader try to read the internal memory card (conected at internal usb port) as if it was a disc in here
4 errors for 4 port
im try to
a) disconect the card, boot and no error ---> work, but not valid workaround if im like to use memory card
b) disable on bios the "support legacy usb" ---> work, but not valid workaround if im like to use keyboard usb to intercept boot to select options or different partition to boot
c) in uefi bios of the z77 im found in advanced mode, in tab peripherals well down a option to configure how its treated the usb devices conected to the motherboard.
by default alll figure as auto
the card appear as "Generic Storage Device 0.00" and i set to FDD or CDROM type , save and reboot
voila no more error message "EBIOS read error: Error 0x31. Block 0x0 Sectors 0"
Heh, this did the trick for me, thank you all for your input. Thought my SSD was corrupt or something OH NOESSSS!!!, but no it was a card reader.
 
Top