Contribute
Register

EBIOS read error: Error 0x31 Block 0x0 Sectors 0

Joined
Mar 22, 2013
Messages
46
Motherboard
Gigabyte GA-Z97X-Gaming 3
CPU
i7-4470K
Graphics
GTX 1070 TI
Mobile Phone
Android, iOS
Well I think that I was too optimistic..... need to investigate further because I still have the issue....
I need to understand why it was working for some time.
 
Joined
Mar 9, 2014
Messages
14
Motherboard
Mavericks
CPU
2600k
Graphics
i7 GPU
Mac
Classic Mac
Mobile Phone
i have this same problem and I am using a SanDisk USB 2.0 card reader with a CF2 card to BOOT and INSTALL OSX on my PC.

I also get these errors approx 4 total, interesting as the USB drive comes up as 4 separate drives on boot select screen AND in windows operating systems
 
Joined
Sep 8, 2012
Messages
14
Motherboard
MSI H97 Gaming 3
CPU
Core I-7
Graphics
Geforce GTX1050ti
Mobile Phone
iOS
im have a same error on gigabyte ga-z77-d3h always wen boot the chimera bootloader write in screen 4 times the error message "EBIOS read error: Error 0x31. Block 0x0 Sectors 0"
this error its generated when the bootloader try to read the internal memory card (conected at internal usb port) as if it was a disc in here
4 errors for 4 port
im try to
a) disconect the card, boot and no error ---> work, but not valid workaround if im like to use memory card
b) disable on bios the "support legacy usb" ---> work, but not valid workaround if im like to use keyboard usb to intercept boot to select options or different partition to boot
c) in uefi bios of the z77 im found in advanced mode, in tab peripherals well down a option to configure how its treated the usb devices conected to the motherboard.
by default alll figure as auto
the card appear as "Generic Storage Device 0.00" and i set to FDD or CDROM type , save and reboot
voila no more error message "EBIOS read error: Error 0x31. Block 0x0 Sectors 0"
Heh, this did the trick for me, thank you all for your input. Thought my SSD was corrupt or something OH NOESSSS!!!, but no it was a card reader.
 
Joined
Mar 19, 2014
Messages
11
Motherboard
Mavericks 10.9.5 Gigabyte z87x-ud3h
CPU
Intel Core i5-4670
Graphics
Nvidia GTX660
Mac
Classic Mac
Mobile Phone
iOS
Thank you for your support. It's fine for me :D
 
Joined
Aug 27, 2013
Messages
9
CPU
i7 4771s
Graphics
HD4600
Mac
MacBook Pro
Classic Mac
Mobile Phone
iOS
I need some help with an issue following the EBIOS read error. I set USB support to only UEFI mod in the UEFI menu and now those 5 lines stating the boot error do not appear anymore. But now I unfortunately cannot boot into my system experiencing a boot loop. The chimera boot loader loads up and the loading bar gets almost full but then the system just reboots. Any ideas about what I can do in order to boot into system?

All devices are disconnected except keyboard.
 
Joined
Mar 19, 2014
Messages
11
Motherboard
Mavericks 10.9.5 Gigabyte z87x-ud3h
CPU
Intel Core i5-4670
Graphics
Nvidia GTX660
Mac
Classic Mac
Mobile Phone
iOS
I need some help with an issue following the EBIOS read error. I set USB support to only UEFI mod in the UEFI menu and now those 5 lines stating the boot error do not appear anymore. But now I unfortunately cannot boot into my system experiencing a boot loop. The chimera boot loader loads up and the loading bar gets almost full but then the system just reboots. Any ideas about what I can do in order to boot into system?

All devices are disconnected except keyboard.
You must select the hd mavericks in "NO UEFI" mode from boot menu. Cheers.
 
Joined
Oct 22, 2014
Messages
1
Motherboard
ASUS Maximus Hero VI Z87
CPU
i7-4770k
Graphics
ASUS R9 280x
Mac
Classic Mac
Mobile Phone
Android
do either of you have a USB card reader?

I started getting this error as soon as I hooked up my internal USB card reader with a new ML build I am working on. I would get 4 of these errors, and then I could choose an OS, and it would load no problem.

You could turn off USB booting in the BIOS ( it can be called "USB Legacy Support" sometimes).
Although, when I turned off my "USB Legacy" in my BIOS I could no longer use the keyboard to choose an operating system in the bootloader.

I also tried to reinstall the bootloader with the USB reader installed... I was hoping it would be like re-installing LiLo when you moved disks around in Linux... alas, it did not work.

In my case, I just ended up removing the card reader, as we didn't really use it anyway. :)

You sir are a hero. I thought I was going to have to reinstall Yosemite as I have been getting this exact error message four times on each boot since Mavericks. I thought I had disconnected my card reader but it was hidden behind my monstrous R9 280x. Some people said it was due to the partition mapping of your installation drive, but I followed the guide that was supposed to fix that issue when I did a fresh install of Yosemite. This has been driving me crazy thanks so much.
 
Joined
Oct 30, 2013
Messages
36
Motherboard
HP dc5800
CPU
e7400
Graphics
AMD Radeo 6000 series
Mac
Classic Mac
Mobile Phone
I'm going to add a new wrinkle to the thread. Everyone seems to have issues with card readers and scanners or printers with built ins. I get this error from a Seagate external HDD. I have 3 external drives connected, including the one I boot from. If I disconnect this specific drive no error. I think there's an issue in the MBR but no idea how to resolve it. I have formatted the drive in Windows, OSX and Fedora Linux, the error remains and none of the OS's will boot from the drive.
 
Joined
Aug 6, 2015
Messages
2
Motherboard
gigabyte z77 D3H
CPU
2500K
Graphics
730GT
Mac
Classic Mac
Mobile Phone
thank you very much r1De !!
 
Top