Contribute
Register

Solved > DW1560 bluetooth not work on 10.15.3

Joined
Mar 29, 2020
Messages
4
Motherboard
H310
CPU
i5-8500
Graphics
UHD630
Hi all,

I'm trying to get my Bluetooth work nowadays.
Base on the posts I read, I have tried:

* Place BrcmPatchRAM3, BrcmBluetoohInjector, BrcmFramwareData/Repo in /E/C/K/O or/L/E
* Other Bluetooth-worked EFIs

The Brcm*.kexts were downloaded from latest release in GitHub

This Guide mentioned some modification in the split files, but I can't find out the Device ID and VendorID , as no Bluetooth information can be found in System Report page.

The most wired thing is that the first time I finished installation, the Bluetooth work perfectly (Handoff, sidebar etc.) but the HDMI/DP audio is not work. Then I copied kexts from /E/C/k to /L/E , rebuild the kext cache and updated AppleALC, liu and whatevergreen, then the Bluetooth was broken and audio worked. From then, the Bluetooth is totally broken (No information found) even after re-install the system neither using old EFI.

Any ideas as to what I should do?

My hardware:

Deskmini 310
DW1560 (BCM94352Z) NGFF M.2
Catalina 10.15.3

Screen Shot 2020-03-29 at 6.57.29 PM.png


Solved Updated

hi guys, I solved the problem accidentally. My solution is

Place in BrcmBluetoohinjector, BrcmFirmwareData and BrcmPatchRAM3 in /E/C/K/O, (latest version from Github)

POWER OFF the computer(Unplug)for a while and then restart. The Bluetooths just come back magically.

My guess (stupid and unprofessional) is that there may be some hardware in the motherboard record some information about Bluetooth which block the BrcmBluettohInjector.kext working, power off would reset this.
 

Attachments

Last edited:
Joined
Mar 29, 2020
Messages
3
Motherboard
HP Spectre 13 x360
CPU
i7-7500U (KabyLake)
Graphics
HD 620
Have you tried working this with the newer version of Clover? I have the same WiFi card but cannot seem to turn it on for Catalina. Tried all these steps, but it just does not budge. Im on Clover r5106.
 
Joined
Mar 29, 2020
Messages
4
Motherboard
H310
CPU
i5-8500
Graphics
UHD630
Have you tried working this with the newer version of Clover? I have the same WiFi card but cannot seem to turn it on for Catalina. Tried all these steps, but it just does not budge. Im on Clover r5106.
Thanks for your advise. I have updated the Clover to version 5107 (5100 before) and Bluetooth still not work. Someone says that only keep BrcmBluetoohInjector.kext in the /E/C/K/O would make Bluetooth information available, but it is not work for me. I guess problem might be here
 
Top