Contribute
Register

Dell Precision 5820 - Xeon w2125

Joined
Dec 21, 2016
Messages
42
Motherboard
Precision 5820
CPU
W2125
Graphics
RX 560
Mac
  1. iMac
  2. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
At this time I have a problem. I boot to clover menu and when I select the BS install my WS won't boot every time. I get stuck on a black screen and only _ in the corner :(
 
Joined
Oct 4, 2018
Messages
243
Motherboard
Gigabyte C246-WU4
CPU
E-2278G
Graphics
WX7100
Mac
  1. MacBook Pro
  2. Mac mini
So the above EFI from yapan4's X11SRA-F let you install Big Sur on your Precision 5820 but cannot reboot reliably? It either works or gets stuck on a black screen.

Have you noticed any pattern? Cold boot vs. hot boot? Choice of USB port?

Is the RX560 in good condition? (Contrary to this other thread.) Known to be working in Windows or Linux, if you multiboot?
 
Joined
Dec 21, 2016
Messages
42
Motherboard
Precision 5820
CPU
W2125
Graphics
RX 560
Mac
  1. iMac
  2. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
It's rare my computer boot well. Most of cases I have a frozen underscore. USB or not, cold or hot boot this problem happen randomly. Even if I wait 1 or 20seconds

I haven't test my RX560 on Windows since 3 or 4 months. But she's in good condition I think.
 
Joined
Jul 29, 2018
Messages
62
Motherboard
ASUS WS C422 Pro/SE
CPU
W-2123
Graphics
W7100
I don't even know how to diagnose this problem. There was something similar on ASUS motherboards with USB 3.1 Asmedia controller. If your machine has Asmedia USB, try kext
 

Attachments

  • ASMedia.kext.zip
    1.8 KB · Views: 8
Joined
Oct 4, 2018
Messages
243
Motherboard
Gigabyte C246-WU4
CPU
E-2278G
Graphics
WX7100
Mac
  1. MacBook Pro
  2. Mac mini
So you have a random bug which gives no meaningful output… :banghead:
I'm clueless as well.

Dell provides little details as to what is on the motherboard (i219, ALC3234). There is no USB 3 Gen 2; the 10 Gen 1 ports could well come all from the C422 PCH. I tried looking at your USB map to confirm this, but did not find one in the EFI from post #31.
 
Joined
Dec 21, 2016
Messages
42
Motherboard
Precision 5820
CPU
W2125
Graphics
RX 560
Mac
  1. iMac
  2. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
Since I install Catalina I don't have USB on my workstation. It was not awkward at all.
 
Joined
Oct 4, 2018
Messages
243
Motherboard
Gigabyte C246-WU4
CPU
E-2278G
Graphics
WX7100
Mac
  1. MacBook Pro
  2. Mac mini
No USB map, or no working USB?

While browsing this folder I noticed you have both AppleALC and VoodooHDA (one too much; this could explain issues with sound), a kext against memory configuration issues on MacPro7,1 (any reason not to use iMacPro1,1 any longer? it's the real Mac SMBIOS for C422) but nothing to fix TSCSync (this seems to be a common or universal issue on C422 and C621, have you even seen error messages about TSC during verbose boot?).

Would you be willing to try OpenCore?
 
Joined
Dec 21, 2016
Messages
42
Motherboard
Precision 5820
CPU
W2125
Graphics
RX 560
Mac
  1. iMac
  2. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
No working USB.

I make some search about opencore. It's a bit difficult to understand for me.
 
Joined
Oct 4, 2018
Messages
243
Motherboard
Gigabyte C246-WU4
CPU
E-2278G
Graphics
WX7100
Mac
  1. MacBook Pro
  2. Mac mini
Take your time to read the documentation… Introduction of course, Adding base files + Gathering files for the basics of how the OpenCore EFI folder is setup, and then thoroughly proceed with the appropriate Config file — here that would be HEDT/Skylake-X
The screenshots date from older versions and do not match exactly the entries you'll see. Trust the text.

Here is an almost ready EFI folder with OpenCore 0.7.2 DEBUG (not the latest release, but the one that is still featured in the guide if you want to check). Edit Sample.plist in your favourite plist editor (ProperTree is well suited), scroll to the Platform Info section and fill in a set of motherboard number (MLB), serial number and UUID corresponding to the SMBIOS (SystemProductName). I have pre-filled iMacPro1,1 because it most closely matches C422 but you may change to MacPro7,1 if you prefer. Reusing a set of serials used with Clover is fine.
Then rename Sample.plist to config.plist (still in EFI/OC directory) and you have a valid OC EFI.

This is configured to defaults, excepts it uses EnableWriteUnprotector in Booter>Quirks and adds Kernel>Quirks>AppleXcpmExtraMsrs, mandatory with Xeon-W if you have not patched your BIOS.

But the most important settings are Misc>Debug>SysReport:true and Target:67. After a boot attempt (any OS X version), it will leave a log file and SysReport folder in the EFI folder. Please post back the log file and SysReport folder, along with any relevant shot of the verbose OS X boot.
I do not expect that the boot will succeed on this first attempt, but from the results it will be possible to adjust quirks and write custom SSDTs for this system.

Edit: Corrected "Sample.plist".
 

Attachments

  • EFI_DellP5820_OC072dbg.zip
    2.6 MB · Views: 16
Last edited:
Joined
Dec 21, 2016
Messages
42
Motherboard
Precision 5820
CPU
W2125
Graphics
RX 560
Mac
  1. iMac
  2. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
Thanks for your help @etorix I try tomorrow ;-)
 
Top