Contribute
Register

Dell 7559 - Bios 1.2.7 Update !

Joined
Apr 12, 2011
Messages
262
Motherboard
Probook 4540s
CPU
Intel(R) Core(TM) i7-3632QM CPU @ 2.20GHz, 2201 Mhz
Graphics
AMD Raden HD 7650m
Mobile Phone
iOS,
Have you figured it out? If the Bios version ≥1.2.5 it can only boot after the battery removed from motherboard!
Nope. I was thinking may be someone or RehabMan may want to help us debug this issue with our sample laptops that are having exact same issue?
 
Joined
Jan 16, 2017
Messages
17
Motherboard
Dell Inspiron 15 7559 / v1.2.2
CPU
Intel i7 6700HQ
Graphics
HD530
Nope. I was thinking may be someone or RehabMan may want to help us debug this issue with our sample laptops that are having exact same issue?
here is my step which help me get in mojave after the bios version upgrade to 1.2.9:

1: f2 get in bios setup

2: change the boot list option from uefi to legacy

3: Save and reset

4: f2 get in bios setup again,

5: Change the boot list option from legacy to refi

6: Save and reset

7: let the clover start the os,done!

But if I restart system ,I have to do it again to get in os!
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,974
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
here is my step which help me get in mojave after the bios version upgrade to 1.2.9:

1: f2 get in bios setup

2: change the boot list option from uefi to legacy

3: Save and reset

4: f2 get in bios setup again,

5: Change the boot list option from legacy to refi

6: Save and reset

7: let the clover start the os,done!

But if I restart system ,I have to do it again to get in os!
If you have patched ACPI files, make sure you re-extract/re-patch as per guide:
https://www.tonymacx86.com/threads/guide-patching-laptop-dsdt-ssdts.262184/
 
Joined
Apr 12, 2011
Messages
262
Motherboard
Probook 4540s
CPU
Intel(R) Core(TM) i7-3632QM CPU @ 2.20GHz, 2201 Mhz
Graphics
AMD Raden HD 7650m
Mobile Phone
iOS,
here is my step which help me get in mojave after the bios version upgrade to 1.2.9:

1: f2 get in bios setup

2: change the boot list option from uefi to legacy

3: Save and reset

4: f2 get in bios setup again,

5: Change the boot list option from legacy to refi

6: Save and reset

7: let the clover start the os,done!

But if I restart system ,I have to do it again to get in os!
Just brilliant man! I followed the steps after updating 1.2.9 and it worked on my High Sierra! We can live with this small problem than using older vulnerable bios.
 
Last edited:
Joined
Aug 13, 2017
Messages
167
Motherboard
Dell Inspiron 3670 DT
CPU
i7-9700K
Graphics
UHD 630 / RX570
Mobile Phone
iOS
Does anyone know what the latest "previous" BIOS version that can be used so as to not have the black screen issue? I'd almost rather go back to an earlier one to get rid of the black screen issue.

Oddly, up until today, I hadn't had the issue where as soon as Clover goes to boot the OS you just get stuck on a black screen, but this morning, I do. I did find that if I just do a CTRL-ALT-DEL and warm reboot, it boots fine the next time.
 
Top