Contribute
Register

Dell 7559 - Bios 1.2.7 Update !

Joined
Jul 21, 2014
Messages
3
Motherboard
ACER
CPU
i3
Graphics
HD 3000
Mac
Classic Mac
Mobile Phone
No such thing found as Preloader.efi as far as I could search, people are recommending OsxAptio2FixDrv and other variants such as OsxAptioFixDrv-2000 or something. None worked.
hey did you find a solution to this problem? i have the same problem when battery unplugged i can boot but when its plugged the famous 2 lines appear, i would really apreciate if you let me know if you found a solution to this problem, im not an expert but know the basics...
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
190,977
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Unfortunately I did not find any solution yet. 'Preloader.efi' did not work. As of moment I am out of any ideas. At least a couple of others are facing the same issue.

https://www.tonymacx86.com/threads/...q-can-only-boot-without-battery.230132/page-2
No "Problem Reporting" files attached.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
Use the gen_debug.sh tool mentioned in the FAQ, that way it is less likely you'll omit something.
 
Joined
Jul 21, 2014
Messages
3
Motherboard
ACER
CPU
i3
Graphics
HD 3000
Mac
Classic Mac
Mobile Phone
Unfortunately I did not find any solution yet. 'Preloader.efi' did not work. As of moment I am out of any ideas. At least a couple of others are facing the same issue.

https://www.tonymacx86.com/threads/...q-can-only-boot-without-battery.230132/page-2
yeah, i can boot without battery but as soon as i connect battery it hangs on those lines, it use to work perfectly fine before bios 1.2.7, again i tried downgrading bios and even then it still hangs... i dont get it how an older bios wont work like it use to
 
Joined
Apr 12, 2011
Messages
263
Motherboard
Probook 4540s
CPU
Intel(R) Core(TM) i7-3632QM CPU @ 2.20GHz, 2201 Mhz
Graphics
AMD Raden HD 7650m
Mobile Phone
iOS,
No "Problem Reporting" files attached.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
Use the gen_debug.sh tool mentioned in the FAQ, that way it is less likely you'll omit something.
Hey, I shall share my files once I remove my battery....I honestly think there is something that Dell has messed up, if you go to the bios detail link I shared in my first post, the date now say Released on 06 Feb 2018 without changing the version number. Clearly the same version was there prior to my post.

I also think you may merge the two threads since several users are facing the same issue with similar laptop.
 
Joined
Jul 25, 2015
Messages
14
Motherboard
DELL 7559-5012GRY, Clover
CPU
i7-6700HQ
Graphics
HD 530/NIVIDA 960M, 3840x2160
Hey, I shall share my files once I remove my battery....I honestly think there is something that Dell has messed up, if you go to the bios detail link I shared in my first post, the date now say Released on 06 Feb 2018 without changing the version number. Clearly the same version was there prior to my post.

I also think you may merge the two threads since several users are facing the same issue with similar laptop.
So from my understanding (which may be wrong) is that Intel threw out some garbage code to patch up meltdown and spectre which cause computer to shutdown and after making that statement dell took down bios 1.2.7 (the old one). Recently Intel updated their code so dell update bios 1.2.7 with the new code and that the one currently on the site.

And just wondering but has anyone fix the black screen issue? Cause I have it too, I am currently using the new bios 1.2.7 and my only work around to get machine to boot, currently, (which makes no sense to me) is that if you boot into another bootable drive, this can be either a bootable usb or another partition, and once it finish loading, shut off the computer and then restart the computer, then pick your hackintosh partition you can load into the hackintosh partition just fine.

** Note that the bootable usb is a Windows usb and the partition was also windows, I haven't test with other drives, so I don't if works for all bootable devices and partitions
 
Joined
Jan 21, 2016
Messages
40
Motherboard
Z390 Aorus Ultra
CPU
i9-9900K
Graphics
Vega 56
I am also facing this issue and system will not boot with battery after BOIS update to 1.2.7

System will boot only after removing battery, otherwise it will hangs on those lines. I have tried a lot of suggested solutions but not able to solve the issue.

Problem reporting file is attached.
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
190,977
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I am also facing this issue and system will not boot with battery after BOIS update to 1.2.7

System will boot only after removing battery, otherwise it will hangs on those lines. I have tried a lot of suggested solutions but not able to solve the issue.

Problem reporting file is attached.
Don't forget to re-extract/re-patch ACPI as per ACPI guide:
https://www.tonymacx86.com/threads/guide-patching-laptop-dsdt-ssdts.152573/

As per guide, re-extract/re-patch must be done after any hardware change, BIOS update, or BIOS option change.
 
Joined
Jan 21, 2016
Messages
40
Motherboard
Z390 Aorus Ultra
CPU
i9-9900K
Graphics
Vega 56
@RehabMan I have re-extract/re-patch ACPI multiple times. I have done it again just now, but issue remain and still not able to boot with battery connected, get AptioMemoryFix error.

I have attached problem reporting file.
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
190,977
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Top