Contribute
Register

Boot hangs on "DRMStatus iTunes/Apple Store Content Access Problem"

Status
Not open for further replies.
Joined
Jul 15, 2012
Messages
50
Motherboard
GA-Z77X-UP5 TH
CPU
i7-3770K
Graphics
HD 4000
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac mini
Classic Mac
Mobile Phone
  1. iOS
I'm attempting to get Mavericks installed on my GA-Z77X-UP5 TH. I Followed the guide from the front page, I'm able to install Mavericks but I can only successfully reboot using -v -x; if i try to reboot normally (actually using -v so I can see whats going on) it hangs on this message:

"DRMStatus iTunes/Apple Store Content Access Problem."

I'm attaching a screenshot hopefully that will help. Anyone else have this problem? I'm thinking of installing from scratch rather than upgrading from Mountain Lion if I can't get this working. I'm hoping if it comes to that I can still restore from my Time Machine backup.

:::UPDATE:::

I went ahead and did a clean install, then transferred my old account using Migration Assistant. Everything seems to be working except for iMessage. Had to run Trim Enabler and fixed iMessage using this post:

http://www.tonymacx86.com/general/1...nvram-1-1-2-still-no-imessage.html#post664704
 

Attachments

  • photo.JPG
    photo.JPG
    760.2 KB · Views: 782
Joined
Nov 18, 2013
Messages
69
Motherboard
Asrock x299 Designer+
CPU
i9-7900x
Graphics
zotac gtx1080 TI
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac mini
  5. Mac Pro
"DRMStatus iTunes/Apple Store Content Access Problem."
I got this also. The HD3000Controller.txt will print " SNB buffer did not show up, unload" every time before I see this, and the QI/CE does not works if these two line happens.

Interesting that, every thing works fine when I see "Transcript Offline - Buffer Pool Allocate [181000] .." .

So I did a disasm of AppleIntelSNBGraphicsFB.kext, I found that it happen in the AppleMEClientController::start
:

AppleMEClientController::start(IOService *)
{
//.....
if( AppleMEClientController::connect(MEIDriverData_t *) )
{
printx("DRMStatus iTunes/Apple Store Content Access Problem.");
return 0/1;
}

if(AppleMEClientController::createPool(0x0a, 0x181000, ...) != 0x0a)
{
printx( "Transcript Offline - Buffer Pool Allocate [181000] .." );
return 0/1;
}
//.....
}

codes like that, I have no idea what the MEI drivers for. but it seems the problem cause my Graphics QI/CE failed.

I really want to hack it to get my HD3000 works every time.

Any one can guide me on that?
Shoud I just add some jmp nop to skip the whole start precedure?
Or how can I get the AppleMEClientController::connect works fine every time? increase the retryCount?



Any suggestion will be appreciated.
 
Joined
Nov 18, 2013
Messages
69
Motherboard
Asrock x299 Designer+
CPU
i9-7900x
Graphics
zotac gtx1080 TI
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac mini
  5. Mac Pro
oh. Is that for iMessage? I have patched the snbBufferFrame to skip it all :
Code:
[COLOR=#444444][FONT=Microsoft Yahei]================ B E G I N   O F   P R O C E D U R E ================[/FONT][/COLOR]


[COLOR=#444444][FONT=Microsoft Yahei]                                       ; Basic Block Input Regs: rsi rdi -  Killed Regs: rax rbx rbp rsi rdi r12 r14[/FONT][/COLOR]
[COLOR=#444444][FONT=Microsoft Yahei]                                            __ZN23AppleMEClientController5startEP9IOService:        // AppleMEClientController::start(IOService*)[/FONT][/COLOR]
[COLOR=#444444][FONT=Microsoft Yahei]000000000001e922 55                              push       rbp[/FONT][/COLOR]
[COLOR=#444444][FONT=Microsoft Yahei]000000000001e923 4889E5                          mov        rbp, rsp[/FONT][/COLOR]
[COLOR=#444444][FONT=Microsoft Yahei]000000000001e926 4157                            push       r15[/FONT][/COLOR]
[COLOR=#444444][FONT=Microsoft Yahei]000000000001e928 4156                            push       r14[/FONT][/COLOR]
[COLOR=#444444][FONT=Microsoft Yahei]000000000001e92a 4154                            push       r12[/FONT][/COLOR]
[COLOR=#444444][FONT=Microsoft Yahei]000000000001e92c 53                              push       rbx[/FONT][/COLOR]
[COLOR=#444444][FONT=Microsoft Yahei]000000000001e92d 4883EC20                        sub        rsp, 0x20[/FONT][/COLOR]
[COLOR=#444444][FONT=Microsoft Yahei]000000000001e931 4989F6                          mov        r14, rsi[/FONT][/COLOR]
[COLOR=#444444][FONT=Microsoft Yahei]000000000001e934 4889FB                          mov        rbx, rdi[/FONT][/COLOR]
[COLOR=#444444][FONT=Microsoft Yahei]000000000001e937 4C8B254A770000                  mov        r12, qword [ds:0x26088][/FONT][/COLOR]
[COLOR=#444444][FONT=Microsoft Yahei]000000000001e93e 498B0424                        mov        rax, qword [ds:r12][/FONT][/COLOR]
[COLOR=#444444][FONT=Microsoft Yahei]000000000001e942 488945D8                        mov        qword [ss:rbp-0x40+var_24], rax[/FONT][/COLOR]
[COLOR=#444444][FONT=Microsoft Yahei]000000000001e946 488D0533920000                  lea        rax, qword [ds:__ZN23AppleIntelSNBGraphicsFB9metaClassE][/FONT][/COLOR]
[COLOR=#444444][FONT=Microsoft Yahei]000000000001e94d 488B30                          mov        rsi, qword [ds:rax][/FONT][/COLOR]
[COLOR=#444444][FONT=Microsoft Yahei]000000000001e950 4C89F7                          mov        rdi, r14[/FONT][/COLOR]
[COLOR=#444444][FONT=Microsoft Yahei]000000000001e953 E800000000                      call       0x1e958[/FONT][/COLOR]
[COLOR=#444444][FONT=Microsoft Yahei]000000000001e958 48898398000000                  mov        qword [ds:rbx+0x98], rax      ; XREF=0x1e953[/FONT][/COLOR]
[COLOR=#444444][FONT=Microsoft Yahei]                                       ; <---change 4885C0  (test rax, rax) to 4831c0 (xor rax,rax)  , so it  will jump always[/FONT][/COLOR]
[COLOR=#444444][FONT=Microsoft Yahei]000000000001e95f 4831C0                          xor        rax, rax[/FONT][/COLOR]
[COLOR=#444444][FONT=Microsoft Yahei]000000000001e962 0F8416030000                    je         0x1ec7e[/FONT][/COLOR]
[COLOR=#444444][FONT=Microsoft Yahei].....[/FONT][/COLOR]
[COLOR=#444444][FONT=Microsoft Yahei]                                       ; Basic Block Input Regs: rax r14 r15 -  Killed Regs: rax rbx rsi rdi r15[/FONT][/COLOR]
[COLOR=#444444][FONT=Microsoft Yahei]000000000001ec7e 488D3D40520000                  lea        rdi, qword [ds:0x23ec5]       ; "Transcript Offline\\n" XREF=0x1e962, 0x1e9b2, 0x1e9d1, 0x1ea03, 0x1ea22, 0x1ea41, ...[/FONT][/COLOR]
[COLOR=#444444][FONT=Microsoft Yahei]000000000001ec85 4530FF                          xor        r15L, r15L[/FONT][/COLOR]
[COLOR=#444444][FONT=Microsoft Yahei]000000000001ec88 30C0                            xor        al, al[/FONT][/COLOR]
[COLOR=#444444][FONT=Microsoft Yahei]000000000001ec8a E800000000                      call       0x1ec8f[/FONT][/COLOR]
[COLOR=#444444][FONT=Microsoft Yahei]000000000001ec8f C683D200000000                  mov        byte [ds:rbx+0xd2], 0x0       ; XREF=0x1ec8a[/FONT][/COLOR]
[COLOR=#444444][FONT=Microsoft Yahei]000000000001ec96 488B03                          mov        rax, qword [ds:rbx][/FONT][/COLOR]
[COLOR=#444444][FONT=Microsoft Yahei]000000000001ec99 4889DF                          mov        rdi, rbx[/FONT][/COLOR]
[COLOR=#444444][FONT=Microsoft Yahei]000000000001ec9c 4C89F6                          mov        rsi, r14[/FONT][/COLOR]
[COLOR=#444444][FONT=Microsoft Yahei]000000000001ec9f FF90C8050000                    call       qword [ds:rax+0x5c8][/FONT][/COLOR]
[COLOR=#444444][FONT=Microsoft Yahei]                                       ; Basic Block Input Regs: rbp r12 -  Killed Regs: rax[/FONT][/COLOR]
[COLOR=#444444][FONT=Microsoft Yahei]000000000001eca5 498B0424                        mov        rax, qword [ds:r12]           ;[/FONT][/COLOR]
 
Joined
Jan 9, 2015
Messages
12
Motherboard
z87 hd3
CPU
i7 4770k
Graphics
sapphire 580 8gb
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
[SOLVED] ->
I was banging my head on the walls but finally an idea comes to mind...
- boot with "-x" (safe boot)
go in Applications folder, locate iTunes, right click on it, select "Show Package Contents", and delete the "Contents" folder.

Now you can reboot, and will work. It worked for me.

Succes!
 
Joined
Jul 19, 2013
Messages
83
Motherboard
Gigabyte GA Z77X-UP4TH
CPU
i7 3770k
Graphics
GTX 750 Ti
Mobile Phone
  1. Android
  2. iOS
  3. Other
[SOLVED] ->
I was banging my head on the walls but finally an idea comes to mind...
- boot with "-x" (safe boot)
go in Applications folder, locate iTunes, right click on it, select "Show Package Contents", and delete the "Contents" folder.

Now you can reboot, and will work. It worked for me.

Succes!
That didn't work for me, boot into safe mode and deleted contents folder from itunes, and still stuck at that error message. Any other suggestions?
 
Joined
Jan 9, 2015
Messages
12
Motherboard
z87 hd3
CPU
i7 4770k
Graphics
sapphire 580 8gb
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
That didn't work for me, boot into safe mode and deleted contents folder from itunes, and still stuck at that error message. Any other suggestions?

Try this: enter safe mode, and install the graphics driver from the Multibeats. Sorry for the delayed reply.
 
Joined
Nov 30, 2020
Messages
7
Motherboard
Asus
CPU
Asus
Graphics
Intel
[SOLVED] ->
I was banging my head on the walls but finally an idea comes to mind...
- boot with "-x" (safe boot)
go in Applications folder, locate iTunes, right click on it, select "Show Package Contents", and delete the "Contents" folder.

Now you can reboot, and will work. It worked for me.

Succes!
I am trying to delete this content but when i am entered into boot mode and in applications there is no such folder of locate iTunes. Plzz help me plzz
 
Joined
Jan 9, 2015
Messages
12
Motherboard
z87 hd3
CPU
i7 4770k
Graphics
sapphire 580 8gb
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
How to do this ??
Hi! Download the Multibeast (for your os system you are trying to install) from the download section.

Copy Multibeast on the USB stick

Enter in safe mode ( boot with -x )

Open Multibeast from the USB stick

Click on Customize tab

Click on Graphics Configuration (left)

Select the Intel HD version (click the checkbox)

Then go to the Build tab (up)

Make sure that on Select Install Drive (right) you select your harddisk and NOT your USB stick

Click Install (down right)

Good luck!
 
Joined
Nov 30, 2020
Messages
7
Motherboard
Asus
CPU
Asus
Graphics
Intel
Hi! Download the Multibeast (for your os system you are trying to install) from the download section.

Copy Multibeast on the USB stick

Enter in safe mode ( boot with -x )

Open Multibeast from the USB stick

Click on Customize tab

Click on Graphics Configuration (left)

Select the Intel HD version (click the checkbox)

Then go to the Build tab (up)

Make sure that on Select Install Drive (right) you select your harddisk and NOT your USB stick

Click Install (down right)

Good luck!
Hi ! But in which folder do i copy multibeast. In EFI folder or In clover ??
 
Status
Not open for further replies.
Top