Contribute
Register

Bluetooth BCM20702A0 Problem (USB?)

Joined
Jun 13, 2012
Messages
154
Motherboard
Lenovo Ideapad Y510P
CPU
Core i7 4700MQ
Graphics
Intel Mobile HD4600
Mac
Classic Mac
Mobile Phone
Android
Hello,

I have a Lenovo Y510p and specs are in my signature. I’m currently running 10.11.3 using Clover and have a problem with Bluetooth/USB. My WiFi card is Broadcom 4352 which have BCM20702A0 BT chip and I’m using BrcmFirmwareRepo.kext and BrcmPatchRAM2.kext to inject BT (and both kexts are installed to /S/L/E).

The problem is after sleep/wake the BT is unavailable anymore which is presumably a USB problem. I’ve had a talk with Rehabman about this before and the fix was to keep XHCI away from XHC1 name and it worked back then. However, I have the same problem at the moment and XHCI is named correctly to XHC in my DSDT.

Some notes about my setup:
  • I have EHCI renamed to EH01 and EH02
  • I have XHCI renamed to XHC
  • I don’t have any USB injector at the moment
  • I have FakePCIID_XHCIMux.kext (with it my BT is routed to EHCI so the kext is doing its job)
  • My DSDT simulates Windows 2012 for Darwin
  • After wake, I found BCM20702A0 available twice in System Information. Similar to this is found in IOREG where BCM20702A0@14600000 was listed twice under HS07@14600000. This was fixed by disabling XWAK in DSDT.

I've been reading in (http://www.tonymacx86.com/el-capitan-laptop-support/173616-guide-10-11-usb-changes-solutions.html) but I'm not convinced to go the injectors route because BT actually work fine on fresh boot (so as all my USB devices) so the USB port my BT is connected to is initially defined. Something change on wake but I'm not sure how to find it or where to look or what could possibly trigger it.

I’m attaching two copies of my IOREG (fresh_boot and after_wake). Any help is appreciated.

Thanks.

EDIT: wrong attachment, I will update them immediately
EDIT: attachement fixed
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,259
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hello,

I have a Lenovo Y510p and specs are in my signature. I’m currently running 10.11.3 using Clover and have a problem with Bluetooth/USB. My WiFi card is Broadcom 4352 which have BCM20702A0 BT chip and I’m using BrcmFirmwareRepo.kext and BrcmPatchRAM2.kext to inject BT (and both kexts are installed to /S/L/E).

The problem is after sleep/wake the BT is unavailable anymore which is presumably a USB problem. I’ve had a talk with Rehabman about this before and the fix was to keep XHCI away from XHC1 name and it worked back then. However, I have the same problem at the moment and XHCI is named correctly to XHC in my DSDT.

Some notes about my setup:
  • I have EHCI renamed to EH01 and EH02
  • I have XHCI renamed to XHC
  • I don’t have any USB injector at the moment
  • I have FakePCIID_XHCIMux.kext (with it my BT is routed to EHCI so the kext is doing its job)
  • My DSDT simulates Windows 2012 for Darwin
  • After wake, I found BCM20702A0 available twice in System Information. Similar to this is found in IOREG where BCM20702A0@14600000 was listed twice under HS07@14600000. This was fixed by disabling XWAK in DSDT.

I've been reading in (http://www.tonymacx86.com/el-capitan-laptop-support/173616-guide-10-11-usb-changes-solutions.html) but I'm not convinced to go the injectors route because BT actually work fine on fresh boot (so as all my USB devices) so the USB port my BT is connected to is initially defined. Something change on wake but I'm not sure how to find it or where to look or what could possibly trigger it.

I’m attaching two copies of my IOREG (fresh_boot and after_wake). Any help is appreciated.

Thanks.

EDIT: wrong attachment, I will update them immediately
EDIT: attachement fixed
Remove the Android File Transfer software.
 
Joined
Jun 13, 2012
Messages
154
Motherboard
Lenovo Ideapad Y510P
CPU
Core i7 4700MQ
Graphics
Intel Mobile HD4600
Mac
Classic Mac
Mobile Phone
Android
Remove the Android File Transfer software.
Oh MY ... just like magic !!

It works brilliantly now .. I can't believe it!

Thanks, many thanks for this.

However, I spent over 2 days researching and trying different things so I would appreciate to learn and understand why does this software conflict with Bluetooth/USB on wake? I can't make sense of it. Are there any alternatives that I can use which does not have the problem?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,259
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Oh MY ... just like magic !!

It works brilliantly now .. I can't believe it!

Thanks, many thanks for this.

However, I spent over 2 days researching and trying different things so I would appreciate to learn and understand why does this software conflict with Bluetooth/USB on wake? I can't make sense of it. Are there any alternatives that I can use which does not have the problem?
I've just noticed that people with that software installed seem to have issues.

I think it is very invasive/sloppy that the software hooks every USB port. I can't see why that is necessary to be able to transfer data from a phone to the PC... assuming that is what it does. I don't have an Android phone, so I don't really know the software's purpose (I have an iPhone 5s).
 
Joined
Jun 13, 2012
Messages
154
Motherboard
Lenovo Ideapad Y510P
CPU
Core i7 4700MQ
Graphics
Intel Mobile HD4600
Mac
Classic Mac
Mobile Phone
Android
I've just noticed that people with that software installed seem to have issues.

I think it is very invasive/sloppy that the software hooks every USB port. I can't see why that is necessary to be able to transfer data from a phone to the PC... assuming that is what it does. I don't have an Android phone, so I don't really know the software's purpose (I have an iPhone 5s).
Yes that's the purpose of it. The strange thing is that the problem existed even when the software was not running and the phone is not connected to my laptop at all. Could it be a service running in background and messing with USB ports? I don't know for sure. I will look for other alternatives.

Thanks again for your help.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,259
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Yes that's the purpose of it. The strange thing is that the problem existed even when the software was not running and the phone is not connected to my laptop at all. Could it be a service running in background and messing with USB ports? I don't know for sure. I will look for other alternatives.

Thanks again for your help.
The software installs some kernel extensions that are always running. That's why I can see the software is installed just by looking at ioreg.
 
Joined
Jun 13, 2012
Messages
154
Motherboard
Lenovo Ideapad Y510P
CPU
Core i7 4700MQ
Graphics
Intel Mobile HD4600
Mac
Classic Mac
Mobile Phone
Android
The software installs some kernel extensions that are always running. That's why I can see the software is installed just by looking at ioreg.
Oh I see. I just toke a look into my previous ioreg and found it there. Like an octopus hooking to all as you said before, trying to find any connection whenever/wherever.

I reinstalled the software to trace that kernel extension and found some dynamic libraries and frameworks inside the .app and used ioreg again to find the process that use them in background. I used Activity Monitor and terminated that process then attempted sleep to check bluetooth. It worked!

Code:
pkill -9 "Android File Transfer Agent"
After some more deep investigation, I found that this process "Android File Transfer Agent" is an app ships with "Android File Transfer" at /Applications/Android File Transfer.app/Contents/Android File Transfer Agent.app. This agent is copied every time the main software is run into /Users/<username>/Library/Application Support/Google/Android File Transfer/Android File Transfer Agent.app (unless it's already there) and there is a LaunchAgent to fire it.

What I did is that I installed the software normally but before running it I deleted the agent form its resources. Now the software is not able to install/copy the agent but it does not complain fortunately. The software now can't detect when I connect the android so it does not run automatically until I open the software manually (expected). However, the Bluetooth/USB problem is now fixed.

That was it .. sneaky software but we don't have to remove it completely.

Thanks!
 
Joined
Apr 20, 2015
Messages
1
Motherboard
Yosemite 10.10.3 10.9.4
CPU
i5 2450M
Graphics
AMD ATI 6760
Mac
Classic Mac
Mobile Phone
That's funny things~ There is a Application called Vysor on Chrome Marcket,we can use it to connect with our android phone,so we can see and operate our phone's screen on our pc. it maybe the reason that chrome also hook the usb ports....I guess :)
 
Joined
Feb 15, 2018
Messages
57
Motherboard
HP 836B
CPU
i7-7700HQ
Graphics
HD 630 & GTX 1050
Mobile Phone
Android, iOS
  • After wake, I found BCM20702A0 available twice in System Information. Similar to this is found in IOREG where BCM20702A0@14600000 was listed twice under HS07@14600000. This was fixed by disabling XWAK in DSDT.
Hello, could you please describe this in detail? I'm having the same issue. Many thanks!
 
Top