Contribute
Register

Big List of Solutions for El Capitan Install Problems

Joined
May 19, 2015
Messages
409
Motherboard
Asus ROG STRIX Z270G GAMING
CPU
i7-7700
Graphics
RX 560
Joined
Jul 14, 2014
Messages
68
Motherboard
Gigabyte Z87X-UD5H
CPU
i7 Haswell 4790
Graphics
GeForce 640
Mac
iMac
Mobile Phone
iOS
I just found out that I can only boot my HDD OS from USB Unibeast stick. When booting directly from HDD I get "No bootable device Insert boot disk and press any key" error.
I have a legacy BIOS and use Legacy mode.

Before installing El Capitan I had no problem booting Yosemite with the same version of Clover.

I've noticed that the HDD is GPT and USB is MBR. Can this be the issue?
SOLVED: After a week of struggling I have found the solution.
I had to manually format EFI partition as to FAT32 first, flag it as active, and then install Clover on it.
Everything works fine now on my Aspire 7720G.

I also have to mention that installing Clover from the scratch gave me incredibly higher performance than switching from Chimera.
 
Joined
Sep 30, 2015
Messages
23
Motherboard
MSI ATX DDR3 2600 LGA 1150 Motherboards Z97 GAMING 7
CPU
Intel Core i7-4790K Processor
Graphics
EVGA GeForce GTX 970 Super Clocked ACX 2.0 4GB GDDR5
Mac
Classic Mac
Mobile Phone
I have successfully installed. But Bluetooth is not working, It was working fine in Yosemite OS. Also, blue tooth icon also missing from the setting menu. I tried almost everything but still no luck.
 
Joined
Oct 13, 2013
Messages
24
Motherboard
H97N-WIFI
CPU
i7 4770
Graphics
HD4600
Mac
iMac, MacBook Air, Mac Pro
Classic Mac
iBook, LC, Performa, Power Mac, PowerBook, Quadra
Mobile Phone
iOS
It's only me still using Firewire or nobody is having problems with that?

I have a audio interface (Edirol FA101) not showing neither in Sound Preferences nor in Audio MIDI Setup app.

The System Information panel shows Firewire bus, but nothing found connected.

Any advice?
 
Joined
Sep 28, 2012
Messages
29
Motherboard
GA-H270N-WIFI
CPU
i5-7600
Graphics
RX 560
Not sure if you want to add this to the list.. but it caused me a LARGE headache..

You can't install El Captain on a Gigabyte H61N-USB3 unless you disable USB 3.0. Apple removed support for the Fresco FL1009 CHIP (used only for the two back USB3.0 ports on the H61N-USB3) in 10.11.

You can either turn USB3.0 off in the BIOS or add this to your config.plist to dissable AppleUSBXHCIPCI.kext in clover.

Code:
<key>KextsToPatch</key>
<array>
       <dict>
                <key>Comment</key>
                <string>Remove XHCI</string>
                <key>Find</key>
                <data>
                MGMwMzMwMDA=
                </data>
                <key>InfoPlistPatch</key>
                <true/>
                <key>Name</key>
                <string>AppleUSBXHCIPCI</string>
                <key>Replace</key>
                <data>
                MDAwMDAwMDA=
                </data>
        </dict>
</array>
Once USB3.0 is turned off all of the standard El Capitan install guides work great.
 
Joined
Aug 21, 2011
Messages
11
Motherboard
EP45-DS3
CPU
Q6600 @ 3.0 GHz
Graphics
Geforce GTX 660
Mac
MacBook
Classic Mac
Mobile Phone
iOS
After successful installation with a GPT formatted Unibeast USB, I get boot0af error when I try to boot from the SSD I installed El Capitan on.

I have read about boot0af error when trying to boot from the Unibeast USB, but that is not my problem. I get the boot0af error when I try to boot from the SSD with the finished installation on it.

Now I am able to boot into my SSD install by booting from the Unibeast USB, but maybe somebody has found a fix for this particular boot0af problem.

I have a legacy BIOS board by the way, so of course I installed with 'legacy clover'.
Somebody named gnappoman over at insanelymac came up with a solution for my boot0af problem:

download this file
extract Clover_v2.3k_r3270_Legacy.pkg using unpkg ( https://github.com/downloads/timdoug/unpkg/unpkg-4.5.zip )
search and copy boot1h2 to your usb drive
then reboot the target hackintosh booting from your usb drive (mac os installation)
then open utilities -> terminal
then -> diskutil list
then -> cd /Volumes/NAME OF YOUR USB DRIVE (to discover, just cd /Volumes/ and then ls
then -> dd if=boot1h2 of=/dev/diskXsY bs=4096 (diskXsY: partition Mac OS X, usually disk0s2 if you have only one HD and only MAC OS installed)

I had to unmount the El Capitan SSD using diskutil in the USB installer before I was able to transfer the boot1h2 file, but hey...

Thanks gnappoman!
 
Last edited:
Joined
May 4, 2013
Messages
1
Mac
Classic Mac
Mobile Phone
  • If it's a panic in a AppleUSBUHCIPCI.kext or AppleUSBXHCIPCI.kext:
I performed the update from 10.10 after solving "panic problems" with the method for X58 and P35 chipset. The installation seems to be right but, when I have tried to boot after the update, El capitan can't start. When I select Boot Mac OS X from Macintosh HD from clover, it appears the apple and the empty charging bar, then the pc immediately restart.
Someone can help me? Thanks!
 
Top