Contribute
Register

Big List of Solutions for El Capitan Install Problems

Joined
May 18, 2011
Messages
24
Motherboard
Asus N53SV - Clover Legacy
CPU
i7- 2630QM/HM65
Graphics
GT 540M 1920x1080
Mac
MacBook Air
Mobile Phone
iOS
Hello, I'm having an issue trying to boot into the installer, I have a fully working Yosemite install with clover as a boot loader.

So far i've tried a lot of stuff with no success, first I wanted to do an direct upgrade from the El capital app, so I updated clover, installed the app and on reboot when I choose boot into el capital installer it won't boot, after removing kexts, adding kexts, with or without fakesmc, different flags, etc I gave up and prepared a usb installer.
The installer can boot into yosemite just fine and finds both the install partition on the usb itself and the one in the ssd, but it won't boot into any of them, whichever I choose all usb power goes down and it freezes, I tried different ports and xhci modes, uefi and non uefi boot, different osxaptio and can not find which setting works, they ALL work for the already installed Yosemite but none can get into any of the el capital installers...

My mobo is a Sabertooth Z77, i7 3770k, gtx 650ti

this is what i get on verbose mode: (sorry for the file size)
View attachment 154268


hai i had he same on my SZ77R5 shuttle with 3770 I7

did you put nullcpupowermanagement kext in Clover/kext/10.11 ? also Fakesmc must be in there

good luck
 
Joined
Sep 9, 2011
Messages
26
Motherboard
GA-z68x-UD3h-B3
CPU
i7
Graphics
AMD Radeon HD6850
Mac
Classic Mac
Mobile Phone
For people who are stuck with spinning beachball instead of Installation:

If you had copied updated FakeSMC.kext to /S/L/E or L/E , run cache rebuild before starting upgrade

kextcache -system-prelinked-kernel
kextcache -system-caches


or add this to config.plist

<key>SystemParameters</key>
<dict>
<key>InjectKexts</key>
<string>Yes</string>
<key>NoCaches</key>
<true/>
</dict>


Do not forget to remove NoCache after upgrade is done otherwise startups will be slooooow.


-SimDim
 

ammulder

Moderator
Joined
Sep 1, 2014
Messages
3,466
Motherboard
GA-H87N-WIFI
CPU
i7-4790S
Graphics
GT 740
Mac
MacBook Pro, Mac mini
Mobile Phone
iOS
Please don't quote that entire giant thing.

And please put your specific motherboard model into the system information area on the left. It's really hard to give you good advice otherwise.

And please start a new thread for troubleshooting. :)
 
Joined
Apr 6, 2014
Messages
6
Motherboard
Gigabyte GA-Z97-D3H
CPU
Intel Corei3
Graphics
Nvidia
Mac
Classic Mac
Mobile Phone
Hello, guys!

I am having big problem with sleep mode. My hack goes to sleep and wake up immediately all the time when I press the sleep button. Power management kext from Yosemite and boot flags do not work. Any ideas how to fix it? I attached my config.
View attachment config-generate.plist Thank you!
 

XQC

Joined
Mar 4, 2013
Messages
132
Motherboard
GA Z170 UD3
CPU
i7 6770K
Graphics
AMD RX580
Mac
MacBook Pro
Mobile Phone
Android
Here are my 3 problems I had upgrading from Yosemite to El Capitan and how I solved them.
Hardware: i7 4770K, Gigabyte GA-Z87X-UD3H, Nvidia GTX 970

Problem 1
A "no entry" icon when booting from USB installer and "Still waiting for root device" message

Solution:
The USB3 stick was the problem. Using an USB2 stick solved the problem (and I figured that out after 3 hours of trying other things...)

Problem 2:
Boot loop after installation went through and did the first reboot

Solution:
I had to disconnect power from the Nvidia GPU, switch to internal graphics in BIOS. OSX boots up, then install updated Nvidia drivers for El Capitan. Switch back to Nvidia and it boots fine.

Problem 3:
USB3 not working

Solution:
I installed FakePCIID.kext and FakePCIID_XHCIMux.kext - search for "RehabMan-FakePCIID" on Google


That was the hardest upgrade I ever experienced!
 

ammulder

Moderator
Joined
Sep 1, 2014
Messages
3,466
Motherboard
GA-H87N-WIFI
CPU
i7-4790S
Graphics
GT 740
Mac
MacBook Pro, Mac mini
Mobile Phone
iOS
Thanks QXC, I've added the first two to the list. As for the third, I'm reluctant to start providing USB solutions here because it seems so specific to the motherboard and there are other threads for that. But it's great to hear your formula for success in any case!
 
Joined
Oct 28, 2010
Messages
37
Motherboard
ASUS Z-97-A Mother Board
CPU
i7-4790K
Graphics
NVIDIA 760 GTX 2GB
Mac
Mac Pro
Mobile Phone
Android, iOS
i managed to get mac book.

so will be downloading and creating unibeast from it and will post results.
Earlier i was getting error of extracting essentials.pkg error in both EL CAPITAN and YOSEMITE.
Lets hope for the best.

My Config is

Mobo - ASUS Z-97A
CPU - i7 4790k
Ram - Corsair vengeance 8GB(4GBx2)
PSU - Corsair RM850
Gpu - 760GTX

I am using UEFI in Clover Setting while creating unibeast.

MOBO Bois Setting
Restored To Default
And Set os to Other OS.

Without and problem i boot into USB and get to installer.
But when it is installing i get error
(unable to extract essentials.pkg)

Please guide is anything i am doing wrong.
Thanks Team

got error of essentials.pkg fixed.

borrowed mac book from my friend and made uni beast from it
viola it work and i followed the post installation guide.

m happy

thanks a million

who all made it possible and thanks for the help.
 
Joined
May 19, 2015
Messages
409
Motherboard
Asus ROG STRIX Z270G GAMING
CPU
i7-7700
Graphics
RX 560
Top