Contribute
Register

Audio - HDMI Audio AppleHDA [Guide]

Status
Not open for further replies.
Joined
Aug 9, 2015
Messages
5
Motherboard
Asus
CPU
Intel
Graphics
Intel
Mac
Classic Mac
Mobile Phone
I ran the cloverALC-110, rebooted... Sound is working again :clap: Thank you!

--
Agreement
The audio_cloverALC-110 script is for personal use only. Do not distribute
the patch, any or all of the files or the resulting patched AppleHDA.kext
for any reason without permission. The audio_cloverALC-110 script is
provided as is and without any kind of warranty.

File: audio_cloverALC-110.command_v1.0j
EFI partition is mounted
System Integrity Protection status: enabled (Custom Configuration).


Configuration:
Apple Internal: disabled
Kext Signing: disabled
Filesystem Protections: disabled
Debugging Restrictions: enabled
DTrace Restrictions: enabled
NVRAM Protections: enabled


This is an unsupported configuration, likely to break in the future and leave your machine in an unknown state.


OK to patch
Confirm Realtek ALC892 (y/n): y
Enable HD4600 HDMI audio (y/n): y
Clover Audio ID Injection (y/n): y
Use Audio ID: 1 (y/n): y


Download ALC892 files ...
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 25585 100 25585 0 0 9232 0 0:00:02 0:00:02 --:--:-- 9236
Edit config.plist/Devices/Audio/Inject/1
Edit config.plist/SystemParameters/InjectKexts/YES
Download kext patches
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 1404 100 1404 0 0 3914 0 --:--:-- --:--:-- --:--:-- 3921
Install /Volumes/EFI/EFI/CLOVER/kexts/10.11/realtekALC.kext
Download config kext and install ...
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 3586 100 3586 0 0 11938 0 --:--:-- --:--:-- --:--:-- 11913
Install System/Library/Extensions/AppleHDA.kext/ALC892 zml files
Fix permissions ...
Kernel cache...
rebuilding //System/Library/PrelinkedKernels/prelinkedkernel
kext-dev-mode allowing invalid signature -67054 0xFFFFFFFFFFFEFA12 for kext AppleHDA.kext
AppleDataSetManagement.kext - dependency for com.apple.iokit.IOAHCIBlockStorage lacks valid OSBundleCompatibleVersion.
AppleDataSetManagement.kext is missing dependencies (including anyway; dependencies may be available from elsewhere)
AppleDataSetManagement.kext - dependency for com.apple.iokit.IOAHCIBlockStorage lacks valid OSBundleCompatibleVersion.
kextcache updated critical boot files, requesting launchd reboot


Install finished, restart required.
To save a Copy of this Terminal session: Terminal/Shell/Export Text As ...
logout
Saving session...
...copying shared history...
...saving history...truncating history files...
...completed.
 
Joined
May 23, 2012
Messages
90
Motherboard
ASUS Sabertooth Z77
CPU
I7-3770K
Graphics
GTX 680
Mac
MacBook Pro
Mobile Phone
iOS
No idea what methods you installed.
I ran an installer from a HDMIAudio-1.1.dmg which I kept from older Yosemite installations. It installs HDMIAudio.kext in S/L/E. This is the install.sh:

Code:
#!/bin/sh
INSTALL_NAME="HDMIAudio"
INSTALL_EXTENSION="HDMIAudio.kext"

OLD_INSTALL_NAME="NVAudio"
OLD_INSTALL_EXTENSION="NVAudio.kext"

if [ "$(expr "$(sw_vers -productVersion | cut -f 2 -d .)" \>= 8)" = 0 ]; then
	echo "$INSTALL_NAME requires Mac OS 10.8 or later."
	exit 1
fi

if [ -x /usr/bin/sudo -a $UID -ne 0 ]; then
	echo "Need administrative privileges. You may need to enter your password."
	exec /usr/bin/sudo $0 $*
fi

if [ -d /System/Library/Extensions/$OLD_INSTALL_EXTENSION ]; then
	echo "Removing $OLD_INSTALL_NAME."
	kextunload /System/Library/Extensions/$OLD_INSTALL_EXTENSION > /dev/null 2>&1
	rm -R /System/Library/Extensions/$OLD_INSTALL_EXTENSION
fi

if [ -d /System/Library/Extensions/$INSTALL_EXTENSION ]; then
	echo "Removing previous version of $INSTALL_NAME."
	kextunload /System/Library/Extensions/$INSTALL_EXTENSION > /dev/null 2>&1
	rm -R /System/Library/Extensions/$INSTALL_EXTENSION
fi

echo "Installing $INSTALL_NAME."
cp -R $INSTALL_EXTENSION /System/Library/Extensions/

if [ ! -d /System/Library/Extensions/$INSTALL_EXTENSION ]; then
	echo "Installation failed."
	exit 1
fi

chmod -R 0755 /System/Library/Extensions/$INSTALL_EXTENSION
chown -R root:wheel /System/Library/Extensions/$INSTALL_EXTENSION

echo "Rebuilding extension caches. This may take a while."
kextcache -system-prelinked-kernel > /dev/null 2>&1
kextcache -system-caches > /dev/null 2>&1

echo "Installation complete. Please reboot now."
This worked for Yosemite, but not El Capitan apparently. I removed HDMIAudio.kext from S/L/E. NVAudio.kext is also not present.
Attach dsdt.
DSDT attached here.
 

nobodynose

Moderator
Joined
Sep 30, 2012
Messages
4,210
Motherboard
ASRock Z370M Pro4
CPU
i7-8700
Graphics
RX 560
Mac
iMac, MacBook, MacBook Pro, Mac mini
Classic Mac
iBook, iMac, Quadra
Mobile Phone
Android, iOS
I'm trying to get HDMI audio working under El Capitan on my Ivy Bridge NUC DC3217BY. It has HD 4000 graphics (working), one DisplayPort and one HDMI port, which is what I'm trying to use. I followed the guide (OSX-hdmi_audio-hdef_audio-ssdt_v3.pdf), completed these steps:

Injected Audio ID=3 via Devices/Audio/Inject/3 in Clover's config.plist
Installed the supplied SSDT-1.aml (from ssdt_hdmi-hd4000-7series-3.zip in the repo) as SSDT.aml in /EFI/EFI/CLOVER/ACPI/Patched
Rebooted and checked for audio.

System Info reports the audio device (with Audio ID: 3):
System Info.png
DCPIManager shows the audio device:
DCPIMgr.png
But the Sound Preferences Panel gives me only an AirPlay device (my AppleTV) as a choice for sound output.

I feel like I'm close to getting it working, but something is missing. Attached are the requested files (in .zip format).
 

Attachments

toleda

Moderator
Joined
May 20, 2010
Messages
24,453
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
512K, LC, Power Mac
Mobile Phone
iOS
trying to get HDMI audio working
Capri framebuffer edit required.
See HD4600+/HD4000/HD3000 Framebuffer Edits/Find HD4600+/HD4000 HDMI port-number
Note HDMI/port-number
See Requirements/4. Framebuffer Injection/4. Clover (link to Repo)
Select config-hdmi_hd4000-100.plist/View Raw (to Download)

Clover Capri framebuffer patch:
Xcode/config-hdmi_hd4000-100.plist/KernelAndKextPatches/KextsToPatch/Item /
Copy port-number patch (Item)
Paste port-number patch to Xcode/config.plist/KernelAndKextPatches/KextsToPatch
Save. Install. Restart.
 
Joined
Oct 23, 2015
Messages
1
Motherboard
ASUS P6TSE
CPU
intel core i7 920 @2.67
Graphics
Gigabyte nVidia GTX 770(4GB)
Mac
Classic Mac
Mobile Phone
Hello!
Can I use this script if I have
ASUS P6TSE
GTX 770
ALC 1200?
I have now working headphones sound(back panel)
OSX 10.10
 

ALL

Joined
Apr 25, 2010
Messages
22
Motherboard
Asus Gene VII
CPU
i7 4790K
Graphics
Gigabyte GTX 970 mini
Mac
Classic Mac
Mobile Phone
iOS
I follow the guide and was able to make the DP audio via GTX 970 working on 10.11 El Capitan.
Update to 10.11.1 and the DP Audio stop working, I try follow the guide again and no luck. Happen to anyone here?

Don't show up in the System Audio / ASUS Gene VII (Z97) / BIOS 2801 / 4790K / GTX 970



EFI/CLOVER/config.plist

EFI/CLOVER/ACPI/Patched/ssdt.aml
 

toleda

Moderator
Joined
May 20, 2010
Messages
24,453
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
512K, LC, Power Mac
Mobile Phone
iOS
Update to 10.11.1 and the DP Audio stop working, I try follow the guide again and no luck. Happen to anyone here?
No. A screenshot of IOReg is useless. Attach all requested files.
 
Joined
Jun 7, 2015
Messages
13
Motherboard
Gigabyte GA-H81-MDS2
CPU
i5-9400
Graphics
Vega 64
Mac
MacBook Air, MacBook Pro
Mobile Phone
iOS
Hi guys!

Please help, installing it does not work on my H81MDS2.
It installs successfully but no sound output can be chosen on the Sounds preference pane.

Here's the installation logs.

Code:
Agreement
The audio_cloverALC-110 script is for personal use only. Do not distribute
the patch, any or all of the files or the resulting patched AppleHDA.kext
for any reason without permission. The audio_cloverALC-110 script is
provided as is and without any kind of warranty.
 
File: audio_cloverALC-110.command_v1.0j
Password:
EFI partition is mounted
System Integrity Protection status: enabled (Custom Configuration).


Configuration:
	Apple Internal: disabled
	Kext Signing: disabled
	Filesystem Protections: disabled
	Debugging Restrictions: enabled
	DTrace Restrictions: enabled
	NVRAM Protections: enabled


This is an unsupported configuration, likely to break in the future and leave your machine in an unknown state.


OK to patch
Confirm Realtek ALC887 (y/n): y
ALC887 v_0x100302 (Current)
Enable HD4600 HDMI audio (y/n): n
Audio ID: 0 is not supported, continue (y/n): y
Clover Audio ID Injection (y/n): y
Use Audio ID: 0 (y/n): n
Audio IDs:
1 - 3/5/6 port Realtek ALCxxx audio
2 - 3 port (5.1) Realtek ALCxxx audio (n/a 885)
3 - HD3000/HD4000 HDMI and Realtek ALCxxx audio (n/a 885/1150 & 887/888 Legacy)
Select Audio ID: 1


Download ALC887 files ...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 24502  100 24502    0     0   6597      0  0:00:03  0:00:03 --:--:--  6597
Edit config.plist/Devices/Audio/Inject/1
Set: Entry, ":Devices:Audio:Inject", Does Not Exist
Edit config.plist/SystemParameters/InjectKexts/YES
Download kext patches
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  1404  100  1404    0     0    942      0  0:00:01  0:00:01 --:--:--   942
Install /Volumes/EFI/EFI/CLOVER/kexts/10.11/realtekALC.kext
Download config kext and install ...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  3586  100  3586    0     0   2213      0  0:00:01  0:00:01 --:--:--  2213
Install System/Library/Extensions/AppleHDA.kext/ALC887 zml files
Fix permissions ...
Kernel cache...
rebuilding //System/Library/PrelinkedKernels/prelinkedkernel
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext Soundflower.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext RealtekRTL8111.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext HDMIAudio.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext FakeSMC.kext
kext-dev-mode allowing invalid signature -67054 0xFFFFFFFFFFFEFA12 for kext AppleHDA.kext
AppleDataSetManagement.kext - dependency for com.apple.iokit.IOAHCIBlockStorage lacks valid OSBundleCompatibleVersion.
AppleDataSetManagement.kext is missing dependencies (including anyway; dependencies may be available from elsewhere)
AppleDataSetManagement.kext - dependency for com.apple.iokit.IOAHCIBlockStorage lacks valid OSBundleCompatibleVersion.
kextcache updated critical boot files, requesting launchd reboot


Install finished, restart required.
To save a Copy of this Terminal session: Terminal/Shell/Export Text As ...
logout
Saving session...
...copying shared history...
...saving history...truncating history files...
...completed.
Deleting expired sessions...2 completed.
Any help would be appreciated. Thanks!
 
Status
Not open for further replies.
Top