Contribute
Register

ATI/AMD 5xxx 6xxx 7xxx 2xx 3xx Graphics Cards Framebuffer Personalities

tonymacx86

Administrator
Staff member
Joined
Nov 18, 2009
Messages
8,568
Motherboard
PRIME Z490-A
CPU
i5 10600K
Graphics
Vega 56
Mac
  1. MacBook Air
Classic Mac
  1. Apple
  2. PowerBook
Mobile Phone
  1. iOS
Re: ATI/AMD 5xxx & 6xxx Graphics Cards Framebuffer Personalities

steve19137 said:
Hey, thanks for this. I was able to get my Gigabyte 6850 working with dual monitors HDMI/DVI by experimenting with all the personalities. I finally found that Bulrushes works, but then found the wiki where that very same piece of info is available. Tons of wasted time, but that's OK.

A suggestion, it would be extremely helpful if you were to explain how to see what framebuffer is working at the moment with the "ioreg | grep ATY" command. It would make someone else's work much easier.

Current default framebuffers for GraphicsEnabler=Yes can be found in the Chimera source here:

http://forge.voodooprojects.org/p/chame ... saio/ati.c

;)
 
Joined
Dec 20, 2011
Messages
4
Mac
Classic Mac
Mobile Phone
Re: ATI/AMD 5xxx & 6xxx Graphics Cards Framebuffer Personalities

I need your help enabling my graphical card, ATI Raedon HD 5650. I have tried several tutorials without success. Please help me out.
 
Joined
Sep 24, 2010
Messages
6
Motherboard
asus p6x58d premium
CPU
i930
Graphics
ati radeon hd 5850
Mac
Classic Mac
Mobile Phone
Re: ATI/AMD 5xxx & 6xxx Graphics Cards Framebuffer Personalities

Hi,

Thank you for the great discussion. I have built my machine without installing chimera (I just boot off the iboot 3.2 cd) and then choose which drive I want to boot off of (a win7 install or a different one with 10.6.8). Is there a way I can change the framebuffer settings for my machine? Do I have to install chimera? If so, any pointers on which instructions would be best? (I primarily use the win 7 side of the machine but do use the snow leopard version a few times per week(.

Thanks,

GH
 
Joined
Jan 10, 2012
Messages
8
Motherboard
OS X 10.7.5
CPU
core i5 (2500k @ 3.3 GHz)
Graphics
Powercolor Radeon 6850 SCS3 1 GB (passively cooled)
Mac
  1. MacBook Air
Classic Mac
Mobile Phone
  1. Android
Re: ATI/AMD 5xxx & 6xxx Graphics Cards Framebuffer Personalities

Hello All,
This is my first post, as I have been able to resolve most of my issues by searching the forum. However, getting my Powercolor Radeon HD 6850 SCS3 (fanless) working with Lion 10.7.2 hasn't gone so well. Here is where my system stands currently:

- New build with clean install of 10.7.2
- Added updated IO80211Family.kext, DeviceMergeNub.kext and AtherosFix.kext in order to get wifi working
- Multibest 4.2.1 userDSDT + Chimera v1.7.0 r1394
-Audio - ALC8xxHDA + AppleHDA Rollback

For my DSDT file I flashed my bios to F10 and used DSDT-GA-Z68X-UD3H-B3-F10 from tonymacx86's DSDT database.

Here's what I'm seeing with the graphics card:
If I set GE=No, everything in the OS works nicely, but the card shows up in About This Mac>More Info as ATI Radeon HD 6xxx 1024 MB and ioreg | grep ATY returns:

| | | | +-o ATY,ATY,RadeonFramebuffer@0 <class AtiFbStub, id 0x1000002ba, registered, matched, active, busy 0 (9 ms), retain 7>
| | | | +-o ATY,ATY,RadeonFramebuffer@1 <class AtiFbStub, id 0x1000002bb, registered, matched, active, busy 0 (4 ms), retain 7>
| | | | +-o ATY,ATY,RadeonFramebuffer@2 <class AtiFbStub, id 0x1000002bc, registered, matched, active, busy 0 (3 ms), retain 7>
| | | | +-o ATY,ATY,RadeonFramebuffer@3 <class AtiFbStub, id 0x1000002bd, registered, matched, active, busy 0 (3 ms), retain 7>

Based on what I have read elsewhere, that indicates that the frame buffer is not loading correctly (also can't start Steam games). QE/CI work fine per the dashboard ripple test.

That led me switch to GE=YES and to cycle through the list of Personalities at the beginning of this thread by setting AtiConfig={PersonalityName} during boot. After going through all of them, some produced white screens, others killed the display entirely, but Gibba, Hydrilla, Elodea and Duckweed booted successfully (card showed as 6850 instead of 6xxx, and ioreg | grep ATY showed the correct frame buffer name).

HOWEVER: Using all four personalities that would boot, the mouse intermittently freezes for a split second. I thought maybe it was related to my specific mouse (logitech Mx510), so I downloaded the drivers for my mouse, but no change. I noticed on the GPU wiki that my card worked successfully in SL using Gibba, but no luck in Lion.

Any help would be greatly appreciated (this is my first post and my first hackintosh, so if I am confused, be patient with me…)

Thanks in advance.
 
Joined
Jan 10, 2012
Messages
8
Motherboard
OS X 10.7.5
CPU
core i5 (2500k @ 3.3 GHz)
Graphics
Powercolor Radeon 6850 SCS3 1 GB (passively cooled)
Mac
  1. MacBook Air
Classic Mac
Mobile Phone
  1. Android
Re: ATI/AMD 5xxx & 6xxx Graphics Cards Framebuffer Personalities

Fixed my problem (so far...) by reverting to previous versions of the Radeon 6000 kexts http://www.osx86.net/view/1366-radeon6000_kexts.html

Did NOT use ATY_Init.kext (framebuffer would not load), but seeing GraphicsEnabler=Yes and AtiConfig=Gibba, this worked.

The only reason I tried this was because somebody else had the same problem with 10.7.2 and fixed be reverting to radeon 6000 kexts from their previous 10.7.1.

Now I have full QE/CI and can launch Steam (correct card definition in system info and correct framebuffer shown in ioreg | grep ATY). Portal 2 feels a little laggy. Smooth, but just delayed. Like driving a big boat.
 
Joined
Dec 7, 2011
Messages
66
Motherboard
Mountain Lion
CPU
I7 2600
Graphics
Radeon 6870
Mac
  1. MacBook Pro
  2. Mac Pro
Classic Mac
Mobile Phone
  1. iOS
Re: ATI/AMD 5xxx & 6xxx Graphics Cards Framebuffer Personalities

Im having a weird problem.
Can you fix it so I don't need to put this line of code everytime ?
(Also in my apple info -->in the graphic / Displays my card is named ATI RADEON HD NI40 and not RADEON HD 6870???)

Read this post: viewtopic.php?f=7&t=46986

Thanks
 
Joined
Jan 10, 2012
Messages
8
Motherboard
OS X 10.7.5
CPU
core i5 (2500k @ 3.3 GHz)
Graphics
Powercolor Radeon 6850 SCS3 1 GB (passively cooled)
Mac
  1. MacBook Air
Classic Mac
Mobile Phone
  1. Android
Re: ATI/AMD 5xxx & 6xxx Graphics Cards Framebuffer Personalities

Update on power color 6850 scs3:

AtiConfig=Gibba -> OS works nicely, portal 2 tops out at 20 fps with min graphics settings
AtiConfig=Duckweed -> Mouse hiccups, portal 2 60 fps with all graphics maxed out

Any suggestions?

I will continue down the personality list and report if anything new arises.
 
Joined
Jan 10, 2012
Messages
8
Motherboard
OS X 10.7.5
CPU
core i5 (2500k @ 3.3 GHz)
Graphics
Powercolor Radeon 6850 SCS3 1 GB (passively cooled)
Mac
  1. MacBook Air
Classic Mac
Mobile Phone
  1. Android
Re: ATI/AMD 5xxx & 6xxx Graphics Cards Framebuffer Personalities

Sorry, didn't update my post after further tesing. I went through all the personalities and either got laggy mouse + good portal 2 performance, or the system wouldn't boot. I have AtiPorts=4 and GraphicsEnabler=yes in my org.chameleon.Boot.plist. If I am not mistaken, I need GraphicsEnabler=Yes in order to load any of these personalities.

The only personality that works for mac OS is Gibba, which steam doesn't like.
When I was testing, I noticed that in Portal 2 the FPS was staying very very close to 20 fps no matter what I did to the setting, or how much detail was on screen.

Interestingly, the issue with Lion seems to be related to the mouse only. If I am typing and not using the mouse, everything works very smoothly; even animated transitions like dashboard/launch pad.

Edit: After further testing, it appears that the Gibba personality leads to generally poor performance in graphics intensive use outside of just games. 1080p video on Youtube through Chrome was unwatchable, and the iTunes visualizer runs very slowly. If set GraphicsEnabler=No, iTunes and HD video work perfectly, but no steam games. :(
 
Top