Contribute
Register

Asus Zenbook 13 UX 333 F (Whiskey Lake) Compatibility!

Joined
Aug 24, 2020
Messages
2
Motherboard
ux333
CPU
i5-8265u
Graphics
uhd620
Hi guys, has anyone got sound working on OpenCore? I've been struggling with it for days...
I've tried every (theoretically) working id on AppleALC for ALC294... With some layouts the mic is working, but about speakers... No luck.
I didn't really understand the ssdt-ALC294 thing, does it need any kext? Without any it doesn't work.
Running Big Sur on UX333FN btw
May I try EFI for Big Sur?
 
Joined
Jul 15, 2020
Messages
5
Motherboard
Zenbook UX333
CPU
i7 8565U
Graphics
UHD620 + MX150
On Big Sur I don't know, on Catalina use EFI from this topic
Which one are you referring to? I tried yours (updating OC files) but still no audio
May I try EFI for Big Sur?
Sure, if you succeed making sound work tell me. HDMI works (with audio), webcam doesn't, AppleAlc layout-id is in DeviceProperties
Any suggestions are highly appreciated!
 

Attachments

  • EFI.zip
    93 MB · Views: 11

Feartech

Moderator
Joined
Aug 3, 2013
Messages
20,692
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Which one are you referring to? I tried yours (updating OC files) but still no audio

Sure, if you succeed making sound work tell me. HDMI works (with audio), webcam doesn't, AppleAlc layout-id is in DeviceProperties
Any suggestions are highly appreciated!
try without: SSDT-ALC294.aml

and test all possible layout id's as per:
 
Joined
Jul 15, 2020
Messages
5
Motherboard
Zenbook UX333
CPU
i7 8565U
Graphics
UHD620 + MX150
try without: SSDT-ALC294.aml

and test all possible layout id's as per:
Thanks, but I've already tried all of those(even layout 22-28-66, with and without SSDT-ALC294) None of them seem to fix speakers, some make only microphone work...
Tried VoodooHDA but it didn't work either.
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
20,692
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Thanks, but I've already tried all of those(even layout 22-28-66, with and without SSDT-ALC294) None of them seem to fix speakers, some make only microphone work...
Tried VoodooHDA but it didn't work either.
have you tried just adding the layout-id and removing everything else?:

Code:
<key>PciRoot(0x0)/Pci(0x1f,0x3)</key>
            <dict>
                <key>layout-id</key>
                <integer>28</integer>
            </dict>
 
Joined
Jul 15, 2020
Messages
5
Motherboard
Zenbook UX333
CPU
i7 8565U
Graphics
UHD620 + MX150
have you tried just adding the layout-id and removing everything else?:

Code:
<key>PciRoot(0x0)/Pci(0x1f,0x3)</key>
            <dict>
                <key>layout-id</key>
                <integer>28</integer>
            </dict>
Tried now, doesn't work.
Previously I was using the boot argument alcid to set the layout, so the other parameters in DeviceProperties probably are not the issue
I switched to DeviceProperties just because I saw it from other EFIs and thought it would help
 
Joined
Jul 15, 2020
Messages
5
Motherboard
Zenbook UX333
CPU
i7 8565U
Graphics
UHD620 + MX150
FIXED AUDIO
Here's how i did it:
-I booted into a random linux distribution
-Discovered the Slot id of the Audio Controller (lspci -vmmnD)
-Used the slot id to discover the ACPI path (cat /sys/bus/pci/devices/SLOTID/firmware_node/path)
-Reboot into MacOS
- Decompiled the SSDT-ALC294.aml found in some other EFIs with MaciASL and changed the acpi path used with the new one
-Saved and added to the EFI

Now everything is working with layout 21 with AppleALC
Here's my updated EFI.
 

Attachments

  • EFI.zip
    93 MB · Views: 32

Feartech

Moderator
Joined
Aug 3, 2013
Messages
20,692
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
FIXED AUDIO
Here's how i did it:
-I booted into a random linux distribution
-Discovered the Slot id of the Audio Controller (lspci -vmmnD)
-Used the slot id to discover the ACPI path (cat /sys/bus/pci/devices/SLOTID/firmware_node/path)
-Reboot into MacOS
- Decompiled the SSDT-ALC294.aml found in some other EFIs with MaciASL and changed the acpi path used with the new one
-Saved and added to the EFI

Now everything is working with layout 21 with AppleALC
Here's my updated EFI.
yay! well done! :)
 
Joined
Jun 23, 2011
Messages
2
Motherboard
Asus Zenbook UX333F
CPU
i5-8265U
Graphics
HD620
Mobile Phone
  1. Android
For those like me, who own a UX333F (without MX150), I created a SSDT-ALC294.aml. The internal soundcard there has a different ACPI-Path.
Allthough i fixed this, it's only working (just like the keyboard-backlight) when rebooting from Linux.
 

Attachments

  • SSDT-ALC294.aml
    294 bytes · Views: 11
Top