Contribute
Register

Asus Zenbook 13 UX 333 F (Whiskey Lake) Compatibility!

Joined
Sep 17, 2010
Messages
21
Motherboard
NUC D54250WYKH
CPU
i5
Graphics
Intel IGP
For those like me, who own a UX333F (without MX150), I created a SSDT-ALC294.aml. The internal soundcard there has a different ACPI-Path.
Allthough i fixed this, it's only working (just like the keyboard-backlight) when rebooting from Linux.
Hello MrMoe, can you share your EFI folder?
Like pizzleberry, I’ve managed to get Big Sur installed but I’m facing issues with keyboard touch mapping and backlight. It will be much appreciated if you share. Thks.
 
Joined
Sep 17, 2010
Messages
21
Motherboard
NUC D54250WYKH
CPU
i5
Graphics
Intel IGP
Hi guys,
For the sake of this very thread name, here are my achievements for this very laptop "UX333FA" :
- opencore 6.8 > done
- MacOS Big Sur > installed
- Trackpad > done > get to find to make it work in polling mode > laggy on CPU high usage
- screen backlight > done
- keyboard backlight > done
- keyboard mapping > done with Karabiner > get to find how to remap in a SSDT for full vanilla > need some help
- hibernation > done or sort of > installed MacOS on USB SSD drive > have to try on internal SSD for fully testing
- intel WiFi & BT > done with known limitations of the AirportItlwm.kext
- audio > almost done but such a PIA !!! > have to use AppleALC.kext (21) with SSDT-ALC294.aml & CodecCommander.kext > without this last audio appears in sound preferences but no sound output > get to handle how to get my headset mic to work > maybe built an pinout xml but I haven't found how to do > any help would be appreciate
- HDMI > done > video and audio output
- webcam > almost done > peripheral is recognized but black screen on FaceTime or Photo Booth or whatever > if someone has an idea
- smart card reader > almost done > peripheral is recognized but no sd card are mouting in the Finder > if someone has an idea

I hope I didn't forget anything else, ask me ;)
 

Attachments

  • EFI.zip
    25.1 MB · Views: 21

Feartech

Moderator
Joined
Aug 3, 2013
Messages
21,530
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Hi guys,
For the sake of this very thread name, here are my achievements for this very laptop "UX333FA" :
- opencore 6.8 > done
- MacOS Big Sur > installed
- Trackpad > done > get to find to make it work in polling mode > laggy on CPU high usage
- screen backlight > done
- keyboard backlight > done
- keyboard mapping > done with Karabiner > get to find how to remap in a SSDT for full vanilla > need some help
- hibernation > done or sort of > installed MacOS on USB SSD drive > have to try on internal SSD for fully testing
- intel WiFi & BT > done with known limitations of the AirportItlwm.kext
- audio > almost done but such a PIA !!! > have to use AppleALC.kext (21) with SSDT-ALC294.aml & CodecCommander.kext > without this last audio appears in sound preferences but no sound output > get to handle how to get my headset mic to work > maybe built an pinout xml but I haven't found how to do > any help would be appreciate
- HDMI > done > video and audio output
- webcam > almost done > peripheral is recognized but black screen on FaceTime or Photo Booth or whatever > if someone has an idea
- smart card reader > almost done > peripheral is recognized but no sd card are mouting in the Finder > if someone has an idea

I hope I didn't forget anything else, ask me ;)
for your Asus keys, you need to do the renames in your config.plist that you have listed in the ssdt

ie _Q0D -> ZQ0D and do this for the rest of them

to find the values for renaming, in terminal:
Code:
echo -n _Q0D|xxd
that will be the find

and the replace:
Code:
echo -n ZQ0D|xxd

 
Joined
Apr 7, 2021
Messages
4
Motherboard
UX333FA
CPU
i7-8565u
Graphics
UHD 620
Hi guys,
For the sake of this very thread name, here are my achievements for this very laptop "UX333FA" :
- opencore 6.8 > done
- MacOS Big Sur > installed
- Trackpad > done > get to find to make it work in polling mode > laggy on CPU high usage
- screen backlight > done
- keyboard backlight > done
- keyboard mapping > done with Karabiner > get to find how to remap in a SSDT for full vanilla > need some help
- hibernation > done or sort of > installed MacOS on USB SSD drive > have to try on internal SSD for fully testing
- intel WiFi & BT > done with known limitations of the AirportItlwm.kext
- audio > almost done but such a PIA !!! > have to use AppleALC.kext (21) with SSDT-ALC294.aml & CodecCommander.kext > without this last audio appears in sound preferences but no sound output > get to handle how to get my headset mic to work > maybe built an pinout xml but I haven't found how to do > any help would be appreciate
- HDMI > done > video and audio output
- webcam > almost done > peripheral is recognized but black screen on FaceTime or Photo Booth or whatever > if someone has an idea
- smart card reader > almost done > peripheral is recognized but no sd card are mouting in the Finder > if someone has an idea

I hope I didn't forget anything else, ask me ;)
If I download this efi file onto my USB, is that all I'll need to install mac os? I'm trying to do a clean wipe and go with big sur and your efi file.
 
Joined
Apr 7, 2021
Messages
4
Motherboard
UX333FA
CPU
i7-8565u
Graphics
UHD 620
Hi guys,
For the sake of this very thread name, here are my achievements for this very laptop "UX333FA" :
- opencore 6.8 > done
- MacOS Big Sur > installed
- Trackpad > done > get to find to make it work in polling mode > laggy on CPU high usage
- screen backlight > done
- keyboard backlight > done
- keyboard mapping > done with Karabiner > get to find how to remap in a SSDT for full vanilla > need some help
- hibernation > done or sort of > installed MacOS on USB SSD drive > have to try on internal SSD for fully testing
- intel WiFi & BT > done with known limitations of the AirportItlwm.kext
- audio > almost done but such a PIA !!! > have to use AppleALC.kext (21) with SSDT-ALC294.aml & CodecCommander.kext > without this last audio appears in sound preferences but no sound output > get to handle how to get my headset mic to work > maybe built an pinout xml but I haven't found how to do > any help would be appreciate
- HDMI > done > video and audio output
- webcam > almost done > peripheral is recognized but black screen on FaceTime or Photo Booth or whatever > if someone has an idea
- smart card reader > almost done > peripheral is recognized but no sd card are mouting in the Finder > if someone has an idea

I hope I didn't forget anything else, ask me ;)
Could you reply to my question please?
 

UtterDisbelief

Moderator
Joined
Feb 13, 2012
Messages
5,921
Motherboard
ASRock B560M itx/ac - OC 0.6.8
CPU
i3-10320
Graphics
GT710 - 1920x1080
Mac
  1. iMac
  2. Mac mini
Classic Mac
  1. eMac
  2. iBook
Mobile Phone
  1. iOS
Could you reply to my question please?

Hi there.

Bear in mind the OP has not been back since the 26th April.

The OP also had problems which the other Moderstor was trying to assist with. He/She never came back to say if it worked or not.

So ... Why not just try it?

Creating a Hackintosh needs you to understand some basic concepts and a little learning-curve is a good thing. We have guides for laptops - see @Feartech 's Signature for a FAQ and Install Guide. :thumbup:
 
Joined
Apr 7, 2021
Messages
4
Motherboard
UX333FA
CPU
i7-8565u
Graphics
UHD 620
Hi there.

Bear in mind the OP has not been back since the 26th April.

The OP also had problems which the other Moderstor was trying to assist with. He/She never came back to say if it worked or not.

So ... Why not just try it?

Creating a Hackintosh needs you to understand some basic concepts and a little learning-curve is a good thing. We have guides for laptops - see @Feartech 's Signature for a FAQ and Install Guide. :thumbup:
I would say I definitely do have an understanding of those basic concepts. I've made several hackintoshes throughout the past 5 years.

I've been working a long time to get mac os working on my zenbook ux333fa. I have Catalina installed finally, but have been unable to get my trackpack or sound working for the past month, and op seems to have it working.

I was just confused that the EFI they provided wasn't able to boot me into an installer for Big Sur like they mentioned they were running their hackintosh on, and was hoping that they could clarify that for me.
 

UtterDisbelief

Moderator
Joined
Feb 13, 2012
Messages
5,921
Motherboard
ASRock B560M itx/ac - OC 0.6.8
CPU
i3-10320
Graphics
GT710 - 1920x1080
Mac
  1. iMac
  2. Mac mini
Classic Mac
  1. eMac
  2. iBook
Mobile Phone
  1. iOS
I would say I definitely do have an understanding of those basic concepts. I've made several hackintoshes throughout the past 5 years.

Fair enough. My apologies.
 
Top