Contribute
Register

Asus p8H77-I itx with 10.8 HD4000 100%(SUCCESS)

Joined
Nov 19, 2011
Messages
68
Motherboard
ASUS STRIX Z370-g mATX (Clover)
CPU
I5-8400
Graphics
ASUS GTX 1060 3G
Classic Mac
iMac
Mobile Phone
iOS
UPDATE 10.9.2 Asus p8H77-I itx with 10.8 HD4000 90%(SUCCESS)

10.9.2
Patch your ROM or use easybeast.
Use HDMI only for your install DVI will work after.
boot with Unibeat-Wait for at least 3 minutes.
Run your install with -X

Quickstart-no dsdt/ (with ROM patch)
Drivers-Realtek-Realtek/
Customize-GraphicsEnabler=Yes/
Build-Install

Run Kext Utility

A couple of notes.
Mavericks is finicky.
don't even try 1080p under customize, it will make your install unusable.
MacPro 3.1 works good the graphics are better than MountainLion (less twitch)
I tried VooDoo Audio and it was not working at all and created a need for -x on boot.
I also tried importing my ML voodoo kext and that didn't work.
apple TV is an option or an external USB unit.

Feel free to try some VooDoo and Ill update this if you get it to work.



10.8.3
I have upgraded my asus rom BIOS to avoid using null power management.
http://www.tonymacx86.com/116-modified-roms-flashable-asus-z77-h77.html
If you don't have a modified rom check easybeast installation instead of User DSDT installation at the top of multibeast.

set bios to:
f5 to load optimized defaults
system agent,graphics configuration, set primary display to iGPU and 64m
back,usb configuration,set XHCI to auto and set EHCI handoff to enable.

restart
Press f8 and boot from USB into your new install (I had to use -x)
load multibeast
/dsdt installation
drivers,audio,universal,/voodoo 2.7.3
network,/Realtek-Lnx2Mac
Customization,boot options, /1080p display, it forces 1920 x 1080
Customization,system definition,/macmini 6.1 (I believe this adds hd4000 and ivy bridge support )

Download kext utility from the community software category below multibeast.

Run kext utility

Restart


my only issue so far is a 50 second delay after macxswappon success.
I think it is caused by 10.8.3 and Lnx2Mac but am uncertain at this time.
Feel free to contribute a fix and i will update post #1.





OLD INSTALL:

Here are my notes to get it working. I have redone the process once to make sure it is correct.

Asus P8H77-I
intel 3570k
corsair gt 120 gb ssd

get m lion on computer
create unibeast usb
set bios advanced,sata,to AHCI
set bios advanced,USB,Intel xHCL mode to "Auto" for usb 3.0
reboot with Unibeast then select new GUID partitioned ml drive
get multi beast 5.1.3
/ the following
/ easybeast
drivers,disk, / trim enabler 10.8.1+ for ssd (wow 5 second startups) :)
drivers,kext,audio,universal, /voodoohda 2.72
drivers,kext,network, / lnx2macs and follow install
customization,boot options, /1080p display, it forces 1920 x 1080
restart.

optional
add ig-platform-id: 01660003 to enable hd 4000 in About This Mac, just add in:Extra/org.chameleon.Boot.plist

<key>device-properties</key>
<string>7f0000000100000001000000730000000200000002010c00d041030a000000000101060000027fff04002c0000004100410050004c002c00690067002d0070006c006100740066006f0072006d002d006900640000000800000003006601140000006800640061002d0067006600780000000d0000006f6e626f6172642d31</string>

Be aware that there are some limitations with the voodoohda. Consider it a 9/10 for audio.I still have to test hdmi audio.
Good luck, It was a fun endeavor.

Update: both the dvi (used for install) and hdmi work. Hdmi has no audio at this time. I think Hdmi audio is probable but have not attempted it yet.

Yes, M. Lion recognizes USB 3.0 in my combination: Asus P8H77-I, i5-3570k and HD4000 graphics.
You must set Intel xHCL mode in "Auto" to make it work.
thanks Isaac I just added it to the guide.

(oct31)
Please Note I have just recently had to boot and change to (GraphicsEnabler=No) after a new install 10.8.2
 
Joined
Mar 2, 2012
Messages
54
Motherboard
GA-Z77-D3H
CPU
Core i5-3570K
Graphics
HD4000
Mac
MacBook Pro, Mac mini
Classic Mac
Power Mac, PowerBook
Mobile Phone
Android,
Here are my notes to get it working. I have redone the process once to make sure it is correct.

Asus P8H77-I
intel 3570k

get m lion on computer
create unibeast usb
set bios sata to AHCI
run unibeast
reboot with USB then select new GUID partitioned ml drive
get multi beast: / the following
/ easybeast
drivers,kext,network, / lnx2macs
drivers,kext,audio,universal, /voodoohda 2.72
boot loaders, / chimera

edit /extra/org.chameleon.boot.plist, with the #5 entry and change your resolution as needed.
add:
<key>graphics mode</key>
<string>1920x1080x32</string>
<key>device-properties</key>
<string>7f0000000100000001000000730000000200000002010c00d041030a000000000101060000027fff04002c0000004100410050004c002c00690067002d0070006c006100740066006f0072006d002d006900640000000800000005006201140000006800640061002d0067006600780000000d0000006f6e626f6172642d31</string>

restart.
Be aware that there are some limitations with the voodoohda. Consider it a 9/10 for audio.I still have to test hdmi audio.
Good luck, It was a fun endeavor.
Why do we have to hard code the resolution? Doesn't M. Lion native support HD4000 on the combination P8H77-I + i5-3570K?
 
Joined
Jun 14, 2012
Messages
7
Motherboard
Asus P8H77-I
CPU
3570K
Graphics
HD4000
Mac
Classic Mac
Mobile Phone
I have the same build, it works almost fine except a few things.
I try to adjust settings in the voodoo pref pane and sound & midi settings, but it won't save when i reset,
also edit the voodoohda info.plist seems do make no effect. These things worked in my lion setup, make the sound better
Any idea why it won't save? annoying to adjust it every time

I was going to try Diablo3, but when i run it the screen mess up, probably its running in wrong resolution?
I have set the Graphics Mode to 1680x1050

It cannot find my Epson stylus px730wd over wifi. I tried to put in the ip address but it says it cant find the software and cant add the printer
it works on usb tho.

Everything else seem to work good so far
 
Joined
Mar 2, 2012
Messages
54
Motherboard
GA-Z77-D3H
CPU
Core i5-3570K
Graphics
HD4000
Mac
MacBook Pro, Mac mini
Classic Mac
Power Mac, PowerBook
Mobile Phone
Android,
I have a same build and follow your instructions. If I connect one monitor to the DVI port, the result looks like the attached image (screen.jpg). However, if I connect 2 monitors to both DVI and VGA ports, HD4000 driver is loaded and it works fine on the DVI monitor, but have flickering screen on VGA monitor.

How can I make the DVI monitor works fine without connect another monitor to the VGA port? Do you know what the problem is?

Moreover, why does system profiler shows VRAM is 512Mb (hd4000.jpg) but I set the iGPU memory in BIOS is 64Mb?

My hardware:
ASUS P8H77-I mother board
i5 3570K CPU with HD4000 graphics
2 x 4Gb 1600 Ram

Install method:
In BIOS > set iGPU memory to 64Mb
UniBeast 1.5.3 USB with Mountain Lion 10.8.0
MultiBeast Mountain Lion 5.0.2
/ easybeast
boot loaders, / chimera

edit /extra/org.chameleon.boot.plist
add:
<key>graphics mode</key>
<string>1680x1050x32</string>
<key>device-properties</key>
<string>7f0000000100000001000000730000000200000002 010c00d041030a000000000101060000027fff04002c000000 4100410050004c002c00690067002d0070006c006100740066 006f0072006d002d0069006400000008000000050062011400 00006800640061002d0067006600780000000d0000006f6e62 6f6172642d31</string>

Thanks.

Best
Isaac
 

Attachments

Joined
Mar 2, 2012
Messages
54
Motherboard
GA-Z77-D3H
CPU
Core i5-3570K
Graphics
HD4000
Mac
MacBook Pro, Mac mini
Classic Mac
Power Mac, PowerBook
Mobile Phone
Android,
Here are my notes to get it working. I have redone the process once to make sure it is correct.

Asus P8H77-I
intel 3570k ...
Hi damuffin,

Which video port are you using?
 
Joined
Apr 20, 2012
Messages
4
Motherboard
Asrock Z77E-ITX
CPU
i7-3770k OC 4.4GHz
Graphics
GTX 460 + HD4000
Mac
Classic Mac
Mobile Phone
Does USB 3.0 work on this motherboard with MultiBeast 5.02?
 
Joined
Mar 2, 2012
Messages
54
Motherboard
GA-Z77-D3H
CPU
Core i5-3570K
Graphics
HD4000
Mac
MacBook Pro, Mac mini
Classic Mac
Power Mac, PowerBook
Mobile Phone
Android,
Yes, M. Lion recognizes USB 3.0 in my combination: Asus P8H77-I, i5-3570k and HD4000 graphics.
You must set Intel xHCL mode in "Auto" to make it work.
 
Joined
Aug 23, 2012
Messages
2
Motherboard
imac
CPU
i2120
Graphics
hd6450
Mac
Classic Mac
Mobile Phone
I built a NAS based on this motherboard. If I switch the bios sata in RAID mode - will it work? Thanks in advance!
 
Joined
Nov 19, 2011
Messages
68
Motherboard
ASUS STRIX Z370-g mATX (Clover)
CPU
I5-8400
Graphics
ASUS GTX 1060 3G
Classic Mac
iMac
Mobile Phone
iOS
I just did a fresh install with all the latest software and the newest bios. Its all updated on post 1. Enjoy.
 
Joined
May 8, 2011
Messages
4
Motherboard
Gigabyte Z77-DS3H
CPU
I5 3570k
Graphics
Nvidia 8800 GT
Mac
Classic Mac
Mobile Phone
SLEEP / WAKE works too?
 
Top