Contribute
Register

Solved > ASUS N580VD - Display problems (Kernel panic on USB-C plug-in)

Joined
Apr 27, 2019
Messages
70
Motherboard
ASUS X580VD
CPU
i7-7700HQ
Graphics
HD630 / GTX1050
Mobile Phone
Android
The problem:

Plugging in a USB-C to HDMI made the system reboot, this is solved by choosing another Platform-ID. The built-in display still won't work unless the external screens are hot-plugged after booting.

My ASUS Vivobook N580VD has an Intel HD630 so Platform-ID "0x591B0000" would be recommended. However this setting doesn't have the Bus-ID "0x05" as shown below so I started testing other Platform-ID's I tried all HD620, HD630 and HD650 Platform-ID's. From all of them "0x59160009" seems to work best. All 3 screens are recognised and no reboots!

410418


Other problems:
  • Built-in screen only working if no other screens are plugged in at boot: See topic
  • Laptop not waking from sleep (reported by ItsJustinSpier).
  • Trackpad sometimes stops working as (reported by Overnightmare).

Laptop specs:

Model:
ASUS VivoBook 15 N580VD
Motherboard: X580VD
CPU: i7-7700HQ (Kaby Lake FCBGA-1440)
GPU: Intel HD630 / GTX1050 (2GB)
RAM: 16GB (Samsung M47A1K43CB1-CRC DDR4 2x8GB PC4 2400T SA1-11)
SSD: 256GB Micron 1100 M.2 (MTFDDAV256TBM)
SSHD: 2TB FireCuda (ST2000LX001)
Ethernet: Realtek RTL8168
WIFI: Intel 8265NGW M.2 (Replacing with BCM94352Z DW1560)
Audio: Conexant Audio CX8150
Built-in Display: B156HAN06.1 (1080p non touch)
Touchpad: ELAN1200

BIOS SETTINGS:
BIOS VER:
315
Secureboot: Disabled
Fastboot: Disabled
CSM Support: Disabled
Legacy USB Support: Disabled
Sata mode: AHCI
DVMT Pre-Allocated: 64M


Thanks to Overnightmare and Itsjustinspier for the help!
 

Attachments

Last edited:
Joined
Apr 27, 2019
Messages
70
Motherboard
ASUS X580VD
CPU
i7-7700HQ
Graphics
HD630 / GTX1050
Mobile Phone
Android
I updated Clover and all the used kext's to the latest version.

Updated from 10.14.4 to 10.14.5 and removed 'AppleIntelLpssI2C.kext' and 'AppleIntelLpssI2CController.kext' from /S/L/E because 'VoodooI2C.kext' wasn't working unless I booted with Clover kext injection. I'm not sure if this is the proper way but now my touchpad works perfectly.

I also dumped my original DSDT/SSDT's and re-uploaded a new debug file in the first post. I did some more reading and I guess it would be best to patch these myself from scratch instead of using the ones provided to me by /u/overnightmare.

I hope the patching will solve my issue or this this likely to be caused by something else? Some advice would be highly appreciated!
 
Joined
May 16, 2019
Messages
3
Motherboard
Asus X580VD
CPU
i5-7300HQ
Graphics
HD 630
Mobile Phone
Android, iOS
Updated from 10.14.4 to 10.14.5 and removed 'AppleIntelLpssI2C.kext' and 'AppleIntelLpssI2CController.kext' from /S/L/E because 'VoodooI2C.kext' wasn't working unless I booted with Clover kext injection. I'm not sure if this is the proper way but now my touchpad works perfectly.
Hi again :wave:
You can also add these patches to your clover config.plist to avoid loading of these two kexts, So you don't need remove them on each updates.
(Must add under KernelAndKextPatches)

XML:
<key>KextsToPatch</key>
<array>
  <dict>
    <key>Comment</key>
    <string>Prevent Apple I2C kexts from attaching to I2C controllers, credit CoolStar</string>
    <key>Name</key>
    <string>com.apple.driver.AppleIntelLpssI2C</string>
    <key>Find</key>
    <data>SU9LaXQ=</data>
    <key>Replace</key>
    <data>SU9LaXM=</data>
    <key>InfoPlistPatch</key>
    <true/>
  </dict>
  <dict>
    <key>Comment</key>
    <string>Prevent Apple I2C kexts from attaching to I2C controllers, credit CoolStar</string>
    <key>Name</key>
    <string>com.apple.driver.AppleIntelLpssI2CController</string>
    <key>Find</key>
    <data>SU9LaXQ=</data>
    <key>Replace</key>
    <data>SU9LaXM=</data>
    <key>InfoPlistPatch</key>
    <true/>
  </dict>
</array>
 
Joined
Apr 27, 2019
Messages
70
Motherboard
ASUS X580VD
CPU
i7-7700HQ
Graphics
HD630 / GTX1050
Mobile Phone
Android
Hi again :wave:
You can also add these patches to your clover config.plist to avoid loading of these two kexts, So you don't need remove them on each updates.
(Must add under KernelAndKextPatches)
Hello! :wave:

A response jeej! I was tired of talking to myself haha.

There were already patches in the Config.plist I got from /u/overnightmare but the hex values are different I'll adjust them thanks!

406373


As for your sleep problem I just have my settings set like this and haven't had a problem.

406374


You don't have the display problems or you haven't tried? If you don't have those problems maybe it's the 7700HQ or my DSDT isn't properly patched?... (I'll redo that anyway)
 
Joined
May 16, 2019
Messages
3
Motherboard
Asus X580VD
CPU
i5-7300HQ
Graphics
HD 630
Mobile Phone
Android, iOS
My issue with sleep is kinda weird, It goes to sleep and wakes well, But it takes about 1 minute to completely go to sleep. :(
---
I also created a repository for what I'm doing for this laptop on GitHub, It's not completed yet but I try to do it in coming week.
https://github.com/itsjustinspier/setup-hackintosh
 
Joined
Apr 27, 2019
Messages
70
Motherboard
ASUS X580VD
CPU
i7-7700HQ
Graphics
HD630 / GTX1050
Mobile Phone
Android
My issue with sleep is kinda weird, It goes to sleep and wakes well, But it takes about 1 minute to completely go to sleep. :(
---
I also created a repository for what I'm doing for this laptop on GitHub, It's not completed yet but I try to do it in coming week.
https://github.com/itsjustinspier/setup-hackintosh
Looking forward to it! I'd like to try your EFI and see if the display problems persist.

---

This laptop seems to have the same problem:
 
Joined
May 16, 2019
Messages
3
Motherboard
Asus X580VD
CPU
i5-7300HQ
Graphics
HD 630
Mobile Phone
Android, iOS
Hey ...
I checked out your current clover configs, It has a lot of issues and have some unnecessary things in it. Maybe some of those causing your issue.
I'm working on my setup and I'll complete it in next day.
I forgot to ask one thing, Is your touch-pad/track-pad working during installation or in recovery?
 
Joined
Apr 27, 2019
Messages
70
Motherboard
ASUS X580VD
CPU
i7-7700HQ
Graphics
HD630 / GTX1050
Mobile Phone
Android
Yea I know!

I was thinking about starting with a clean config.plist (from Rehabman). But then I started reading the DSDT patching guide. Now I'm just confused haha this might be a bit above my head.

I just tried and: No trackpad doesn't work in the installer

Edit 1: I asked /u/Overnightmware (Where I got the EFI folder from) to join this topic.
He was experiencing some track pad issue's too.
 
Last edited:
Joined
Apr 27, 2019
Messages
70
Motherboard
ASUS X580VD
CPU
i7-7700HQ
Graphics
HD630 / GTX1050
Mobile Phone
Android
I tried extracting my Display info with Hackintool and put "DisplayVendorID-6af" and "Icons.plist" under "/System/Library/Displays/Contents/Resources/Overrides" Installed DisplayEDID-6af-61ed.kext to /L/E/ and changed CsrActiveConfig to "0x03E7"

Still not working... :( I'm running out of imagination.

@itsjustinspier: Could you share your EFI folder to have a look?
 
Last edited:
Joined
Jan 22, 2019
Messages
1
denisuu
hi, You would be kind enough to explain to me how you installed on the laptop.
I have the same yours
 
Top