Contribute
Register

ASRock Deskmini 110 issues

Status
Not open for further replies.
Joined
Jan 18, 2013
Messages
71
Motherboard
Gigabyte (GA-H77N-WIFI)
CPU
Intel I7-3770
Graphics
NVIDIA GTX-970
Mac
  1. Mac mini
Classic Mac
  1. iMac
Hey, I have fixed the audio problem.
I extracted the codec_dump from Ubuntu, got the platform/layout infos of Deskmini ALC283 and built a special AppleALC.kext.
Now the audio(both output and input) can work well with the AppleALC.kext and CodecCommander.kext.
View attachment 232970
For Sleep Problem,I choose to never use Sleep function.
View attachment 232963
For M.2 Wifi card, I use the BCM94352Z(DW1560).

Now everything works well except the Sleep.But I don't need Sleep as it is a desktop build.
So you can refer to my files.

Does this fix allow for HDMI Audio as well?
 
Joined
Jan 18, 2013
Messages
71
Motherboard
Gigabyte (GA-H77N-WIFI)
CPU
Intel I7-3770
Graphics
NVIDIA GTX-970
Mac
  1. Mac mini
Classic Mac
  1. iMac
I was ordering a WiFi card and instead of ordering a DW1560, I mistakenly ordered a BCM94352Z that was a Lenovo 20200480 card. Has anyone used the Lenovo 20200480 WiFi card for the ASRock H110M-STX for OS X?
 
Last edited:
Joined
Feb 11, 2017
Messages
13
Motherboard
H110M-STX (Deskmini 110)
CPU
Kaby Lake 7600
Graphics
Intel 630
Hey guys, I'm new to this forum and building my first Hackintosh. I have the Deskmini with a Samsung Evo 500gb m2, 8gb ram, and the Intel i57600 installed. It has the newest Bios version (1.5) and I fixed all the suggested BIOS settings. Upon bootup with Clover I get stucked at the first Apple Logo. I tried combinations of of different boot flags (verbose and safe), but keep running into the same problem. Verbose install gets stuck at the following screen. I searched through the forum, but couldn't find an answer that helped me getting past this issue. Any suggestions are very much appreciated. Thanks for the help.
 

BreBo

Moderator
Joined
Oct 17, 2011
Messages
9,426
Motherboard
Gigabyte GA-Z87X-OC
CPU
i7-4770K
Graphics
HD 4600 / RX 580
@sebastiaanpoppen, please update your profile (personal details) with your build (Motherboard, CPU and Graphics Card).
The Rules said:
Profiles need to contain at least your primary system to assist others with helping you.

Please note that your Kaby Lake CPU (i5-7600) is not (yet) natively supported in macOS.
The CPU requires a FakeCPUID to boot.
 
Joined
Jan 18, 2013
Messages
71
Motherboard
Gigabyte (GA-H77N-WIFI)
CPU
Intel I7-3770
Graphics
NVIDIA GTX-970
Mac
  1. Mac mini
Classic Mac
  1. iMac
A BIOS fix has been released by Asrock for the H110M-STX:
http://www.asrock.com/mb/Intel/H110M-STX/?cat=Beta

Each of bios settings below is necessary, or the installation process will suffer unexpected error and fail.

1. If your CPU supports VT-d, disable it

2. IOAPIC 24-119 Entries, disable it

3. If your system has Secure Boot Mode, disable it

4. If your system has IO Serial Port, disable it

5. Set XHCI Handoff to Enabled

Hope this helps!

I am going to attempt an installation of a Kaby Lake CPU on the DeskMini 110, and am wondering about the version of the BIOS to use.

The BIOS fix that allowed the Mac OS X installation is 1.4.1 as you can see below:
upload_2017-2-12_11-20-42.png


However the version 1.50 of the BIOS is the one that supports Kaby Lake Series 7 processors
upload_2017-2-12_11-29-57.png


Also, the support of 2400 speed memory versus 2133 is only for 7th Generation processors.
upload_2017-2-12_11-28-6.png


There is a further complication that they have released a version 7.00 of the BIOS after the version 1.50
upload_2017-2-12_11-23-5.png


My question: If I am going to install a Kaby Lake 7th Generation processor and 32GB of 2400 speed memory and run Mac OS X, what version should I use?

1.41 does not support the Kaby Lake processors or fully utilize the 2400 speed memory
1.50 may not have the fix to allow Mac OS X installation
7.00 has no additional description about anything

Tony,
Since you appear to have ASRock's ear can you find out anything about the version 7.00 of the BIOS? Specifically does it support Mac OS X installation.

Thanks
 
Last edited:
Joined
Feb 11, 2017
Messages
13
Motherboard
H110M-STX (Deskmini 110)
CPU
Kaby Lake 7600
Graphics
Intel 630
@sebastiaanpoppen, please update your profile (personal details) with your build (Motherboard, CPU and Graphics Card).


Please note that your Kaby Lake CPU (i5-7600) is not (yet) natively supported in macOS.
The CPU requires a FakeCPUID to boot.

@BreBo, thankyou for your help, I changed my profile settings. I followed different suggestions today and got my installation of OSX Sierra working!

After installing the suggested drivers with Multibeast my system however no longer boots up. It gets stuck at the prohibited sign with the scrambled text and with the message:

--AppleUSBHostResources:allocateDownStreamBudCurrentGated: assuming succesfull WakeUnits 100 sleepUnits 0-- (see photo)

I browsed the website for a couple of hours and tried a number of suggestions, such as BIOS settings, different USB ports etc. Not of them worked however. See also the attached photo. Any users in this thread who encountered the same problem with the Deskmini and found a solution?
 

Attachments

  • IMG_20170212_183522455.jpg
    IMG_20170212_183522455.jpg
    5.6 MB · Views: 365
Last edited:
Joined
Jan 18, 2013
Messages
71
Motherboard
Gigabyte (GA-H77N-WIFI)
CPU
Intel I7-3770
Graphics
NVIDIA GTX-970
Mac
  1. Mac mini
Classic Mac
  1. iMac
@BreBo, thankyou for your help, I changed my profile settings. I followed different suggestions today and got my installation of OSX Sierra working!

After installing the suggested drivers with Multibeast my system however no longer boots up. It gets stuck at the prohibited sign with the scrambled text and with the message:

--AppleUSBHostResources:allocateDownStreamBudCurrentGated: assuming succesfull WakeUnits 100 sleepUnits 0-- (see photo)

I browsed the website for a couple of hours and tried a number of suggestions, such as BIOS settings, different USB ports etc. Not of them worked however. See also the attached photo. Any users in this thread who encountered the same problem with the Deskmini and found a solution?

I think you should search for:

AppleUSBHostResources:allocateDownstreamBusCurrentGated: assuming successful wakeUnits 100 sleepUnits 0

There are several threads on that search string.
 
Joined
Feb 6, 2017
Messages
162
Motherboard
Dell Latitude 7390
CPU
i5-8350U
Graphics
UHD 620, 1920x1080
Mac
  1. MacBook Air
Mobile Phone
  1. Android
I am going to attempt an installation of a Kaby Lake CPU on the DeskMini 110, and am wondering about the version of the BIOS to use.

The BIOS fix that allowed the Mac OS X installation is 1.4.1 as you can see below:
View attachment 235909

However the version 1.50 of the BIOS is the one that supports Kaby Lake Series 7 processors
View attachment 235913

Also, the support of 2400 speed memory versus 2133 is only for 7th Generation processors.
View attachment 235912

There is a further complication that they have released a version 7.00 of the BIOS after the version 1.50
View attachment 235910

My question: If I am going to install a Kaby Lake 7th Generation processor and 32GB of 2400 speed memory and run Mac OS X, what version should I use?

1.41 does not support the Kaby Lake processors or fully utilize the 2400 speed memory
1.50 may not have the fix to allow Mac OS X installation
7.00 has no additional description about anything

Tony,
Since you appear to have ASRock's ear can you find out anything about the version 7.00 of the BIOS? Specifically does it support Mac OS X installation.

Thanks

I have just installed Sierra with a i5-7500 after upgrading to the 7.00 BIOS. Memory speed is 2400 according to the BIOS and Sierra. Of course, you must upgrade the BIOS using a supported sky lake CPU first.
 
Status
Not open for further replies.
Top