Contribute
Register

ASRock Deskmini 110 issues

Joined
May 11, 2013
Messages
34
Motherboard
Desktop Mini 110
CPU
I3-6100
Graphics
Intel HD530
Mac
Mac mini
I just got this ASRock Deskmini Kit with the H110 motherboard, I3-6100 and a single sodimm of 4gb-2133 ram and added a WD 3200BEV laptop drive. I followed the latest Skylake uefi unibeast guide but the HD530 is giving me fits...i.e. kernel crashes during boot up with Clover. I got ELCap to install by booting the usb with -x -v (safe mode).

I've tried setting clover options to no intel and 0x19120000 but can't get to the setup screen after install. The bios has no options to set dvmd/apature size. I have echi handoff on. Not sure what else to try. I have looked at the 2 other threads on this kit here to no avail. I read the Asus H110S1 has a better bios and works.
 
Joined
May 11, 2013
Messages
34
Motherboard
Desktop Mini 110
CPU
I3-6100
Graphics
Intel HD530
Mac
Mac mini
OK I have the all messages log and I get to bluetooth loading and I get a kernel panic for it. I suspect that this board has a serial port somewhere on it but the only thing I see in the bios is some ioapic type field that is disabled. Its not labeled clearly as a serial port field. I believe it's upsetting the bluetooth kexts and crashing. It's that or the intel 530 kext won't load which I've tried 0x19120000 and 0x19120006. The hd 540 iris I know works on a NUC 6i5 with this HDD-OS moved over to it. I have successfully booted it on the asrock h110 to safe mode only and it runs fine..programs open, network connects and browses. Some little thing but I cant find the problem.
 
Joined
Aug 21, 2016
Messages
6
Motherboard
Asrock H110M-STX
CPU
I5-6500
Graphics
Intel HD530
Mac
iMac
OK I have the all messages log and I get to bluetooth loading and I get a kernel panic for it. I suspect that this board has a serial port somewhere on it but the only thing I see in the bios is some ioapic type field that is disabled. Its not labeled clearly as a serial port field. I believe it's upsetting the bluetooth kexts and crashing. It's that or the intel 530 kext won't load which I've tried 0x19120000 and 0x19120006. The hd 540 iris I know works on a NUC 6i5 with this HDD-OS moved over to it. I have successfully booted it on the asrock h110 to safe mode only and it runs fine..programs open, network connects and browses. Some little thing but I cant find the problem.
I think the issue is that that the serial port still exists in the BIOS but there is no way to turn it off. Most other motherboards have a switch in the BIOS to disable serial port but the ASRock does not. There is a brand new BIOS (ver. 1.40) that has been released but I do not see an option in it to turn off the serial port.

I found out about the serial port from installing Win 10 on the machine and having a com port appear in the PC's device manager. It's listed as ACPI\PNP0501\0.

I've found this thread http://www.tonymacx86.com/threads/solution-com-serial-port-on-gigabyte-z170x-running-10-11-4.191172/ that might help in pointing us in the right direction if Asrock doesn't fix the BIOS. I'm still opening a ticket with ASrock to see if they'll do anything about it.
 
Joined
May 11, 2013
Messages
34
Motherboard
Desktop Mini 110
CPU
I3-6100
Graphics
Intel HD530
Mac
Mac mini
Hey Roll...for only 2 messages here you dun good son. Thanks to you and Joevt ! That thread worked the treat as they say in England. It was also very easy to do and gave an excellent explanation of the problem. Hoping we get that bios change. Thanks for posting there too.

How do you like your D-Mini? I find it was cheaper and much nicer technically than the Skylake NUC I'm returning soon.
It will serve as my new main triple boot Linux Kaos, Win 8.1, OS X ElCap PC. I've been waiting about 3 years for this form factor to get past the rumor-dev stages. Yeah! Finally.
 
Joined
Aug 21, 2016
Messages
6
Motherboard
Asrock H110M-STX
CPU
I5-6500
Graphics
Intel HD530
Mac
iMac
Hey Roll...for only 2 messages here you dun good son. Thanks to you and Joevt ! That thread worked the treat as they say in England. It was also very easy to do and gave an excellent explanation of the problem. Hoping we get that bios change. Thanks for posting there too.

How do you like your D-Mini? I find it was cheaper and much nicer technically than the Skylake NUC I'm returning soon.
It will serve as my new main triple boot Linux Kaos, Win 8.1, OS X ElCap PC. I've been waiting about 3 years for this form factor to get past the rumor-dev stages. Yeah! Finally.
Thanks! Actually I didn't get the patches working so how did you manage to get the install up and running?

I love the concept, it's really quite clever. Being able to put in 65W CPU is awesome You can cram a lot of storage into it and with space for two hard drives you will be able to upgrade as the price/performance curve changes in storage. The nvme m.2 is really fast, I was able to boot up Win 10 in seconds and I hope to do the same in MacOS. Being able to swap in a Broadcom BT/Wifi module instead of being stuck with the Intel is a bonus. I'm planning on using it as Plex server. The size, silence, and storage capacity make it ideal for that.

Good thing you're getting rid of the NUC, our IT consulting company at work is having reliability issues with them. The failure rate has been unusually high.
 
Joined
May 11, 2013
Messages
34
Motherboard
Desktop Mini 110
CPU
I3-6100
Graphics
Intel HD530
Mac
Mac mini
Joevt has the kexts in that thread. I did what that post said ..copied the 2 hack16550 kexts to the EFI location. I did have to use the efimounter tool from here. I did this by mounting the drive from an external usb hdd dock on my current OS X box. Moved the drive back and poof ...it booted right up. Finished it with the multibeast drivers like 530 HD, ALC 2xx and mauserintel for nic. Hope this helps ya.

Yes the DW1520 seems to be the card but I dont have any need for WL-BT atm. I agree it has room for great storage options/cpu's. I'm satisfied with using a WD 320 GB 2.5" drive for my OS atm. The Sammy 950 nvme is tempting though.

Cheers
 
Last edited:
Joined
Aug 18, 2016
Messages
33
Great, let me try the kext too!

tmtrw05 - does ASRock respond to your ticket regarding serial port option in BIOS?

SSD - I am using a generic SATA SSD and couldn't be more happy about it

Wifi - I am using DW1560 and tapping pin is required...
 
Joined
Aug 21, 2016
Messages
6
Motherboard
Asrock H110M-STX
CPU
I5-6500
Graphics
Intel HD530
Mac
iMac
Joevt has the kexts in that thread. I did what that post said ..copied the 2 hack16550 kexts to the EFI location. I did have to use the efimounter tool from here. I did this by mounting the drive from an external usb hdd dock on my current OS X box. Moved the drive back and poof ...it booted right up. Finished it with the multibeast drivers like 530 HD, ALC 2xx and mauserintel for nic. Hope this helps ya.

Yes the DW1520 seems to be the card but I dont have any need for WL-BT atm. I agree it has room for great storage options/cpu's. I'm satisfied with using a WD 320 GB 2.5" drive for my OS atm. The Sammy 950 nvme is tempting though.

Cheers
I hate to sound like a total idiot but can you give step-by-step on how you did it? I keep getting stuck and I know I'm missing something.

Thanks!
 
Joined
May 11, 2013
Messages
34
Motherboard
Desktop Mini 110
CPU
I3-6100
Graphics
Intel HD530
Mac
Mac mini
I had to reinstall this and I think I know what I forgot to mention. I installed ELCap using my older working hackintosh, added the kexts using the method I wrote above. So I can see why my posts here are misleading. I reinstalled using a new OCZ 240GB SSD and I still could not get the Dmini to boot without using safe mode which does not allow for a correct install. Sorry I forgot but this method works albeit it requires another box to get the HDD install right.

1) Take an unformatted HDD/SSD and install it in data port 1 (or 2 if you have a dvd on 1) and plug your uefi usb el cap stick created with unibeast into your working hack/mac. Boot and choose a matching board type in options for that box in Clover. I used MBPro 3,1 for my GA-P67A-UD-B3/I5-2400. After it boots install like normal...add a user, etc finishing setup then power off that install box. Move the new OS X you just installed to sata port 3 and hook up the original OS X drive to sata 2 and boot it into the original OS X drive. You will see the new OS X drive as a second hard drive now.

2) Use the instructions for mounting the second drives EFI with the eft-mounter v3 tool. Copy the kexts. Unmount the EFI partition and shutdown. Move the second drive to the Dmini and boot it by itself. You will notice it does not hang with the new serial kexts in EFI partition. Once that boots up run multi beast and add the kexts drivers above. Again muti beast wants the EFI partition mounted then unmounted. Power off and remove the usb installer and boot to the new drive. Should all work now.

If you don't have another mac/hack box then I am at a loss for how to get past using this method until someone more knowledgeable buys a Dmini and sets all this complication to nought.
 
Last edited:
Joined
Aug 21, 2016
Messages
6
Motherboard
Asrock H110M-STX
CPU
I5-6500
Graphics
Intel HD530
Mac
iMac
tmtrw05 - does ASRock respond to your ticket regarding serial port option in BIOS?
The support person said they would talk to the HQ about it. But there might be some hope in another way. Read below...

If you don't have another mac/hack box then I am at a loss for how to get past using this method until someone more knowledgeable buys a Dmini and sets all this complication to nought.
I'm not done testing and blowing things up but I think I've might have found a solution for getting past the serial port problem. I've created a DSDT that disables the serial port and so far things are looking promising. It will install OSX and boot up. I got LAN drivers installed as well. I even managed to get my Samsung Pro 950 NVMe working. However I'm having some display issues with flickering and it only recognized half my memory. I also need to get the Broadcom BT/WiFi working but one step at a time.

I'll give a full write-up once I get things going reliably.
 
Top