Contribute
Register

AMD Radeon Navi GPU

Gigamaxx

Moderator
Joined
May 15, 2016
Messages
6,137
Motherboard
GIGABYTE X470 Arous Gaming 7 WiFi
CPU
Ryzen R9 3900X
Graphics
RX 480
Mac
  1. iMac
Where i get radeonmonitor.kext?
I no see temp and clock
Thats right, all reference are from AMD only, if you watch "Actually Hardcore Overclocking" YouTube channel, the guy is an expert on GPU electronics and stuff, he does the most detailed analyses on GPU boards components and he said exactly the same about reference branding.

And even more interesting, he said that "the reference 5700 XT has the most high quality components and any other AIB board is like a downgrade from it", so I see that a very big deal tbh, therefore I got my Sapphire 5700XT reference.

Edit: The video is uploaded to "Gamers Nexus" channel but from the same guy.


Buildzoid, he also looks into motherboards. Some of the manufacturers are using him for power delivery analysis, consulting etc...
 
Joined
Mar 28, 2011
Messages
253
Motherboard
Asus Tuf X299 Mark 1
CPU
i9-7900X
Graphics
RX 5700 XT
Mobile Phone
  1. iOS
Thanks, @RandomTech and @Loloflatsix. I tried kexts but my 5700 XT does not appear, it will be for the version of my FakeSMC.

I have tried a version of FakeSMC that I found, and the 5700 XT appears but the CPU does not.
Is there any version that all sensors are seen?
 
Joined
Mar 18, 2017
Messages
986
Motherboard
ASUS ROG Rampage VI Extreme
CPU
i9-7940X
Graphics
2 X VEGA 56
Mac
  1. iMac
  2. Mac mini
Mobile Phone
  1. iOS
Thanks, @RandomTech and @Loloflatsix. I tried kexts but my 5700 XT does not appear, it will be for the version of my FakeSMC.

I have tried a version of FakeSMC that I found, and the 5700 XT appears but the CPU does not.
Is there any version that all sensors are seen?

Take a look here on the X299 Mojave thread :
iMac Pro X299 - Live the Future now with macOS 10.14 Mojave
"The actual HWSensor and FakeSMC kext distribution of @interferenc can be assessed at https://github.com/interferenc/HWSensors"
 
Last edited:
Joined
May 28, 2019
Messages
17
Motherboard
Gigabyte Z390 Aorus Pro
CPU
i9-9900K
Graphics
RX 5700 XT
Mac
  1. Mac mini
Mobile Phone
  1. iOS
Updated from Mojave to 10.15.1 today using iGPU only. Catalina works only via UHD630 but can’t boot with Sapphire 5700 XT Nitro+ :(

Can anybody tell me please, what do i need to do step by step?

Smbios: iMac 19.1
 
Last edited:

Gigamaxx

Moderator
Joined
May 15, 2016
Messages
6,137
Motherboard
GIGABYTE X470 Arous Gaming 7 WiFi
CPU
Ryzen R9 3900X
Graphics
RX 480
Mac
  1. iMac
Updated from Mojave to 10.15.1 today using iGPU only. Catalina works only via UHD630 but can’t boot with Sapphire 5700 XT Nitro+ :(

Can anybody tell me please, what do i need to do step by step?

Smbios: iMac 19.1


Lilu & Whatevergreen, disable IGPU and use boot arg. agdpmod=pikera
 
Joined
May 28, 2019
Messages
17
Motherboard
Gigabyte Z390 Aorus Pro
CPU
i9-9900K
Graphics
RX 5700 XT
Mac
  1. Mac mini
Mobile Phone
  1. iOS
Lilu & Whatevergreen, disable IGPU and use boot arg. agdpmod=pikera

Did what you say, now i have reboot in the end instead logo.
 

Attachments

  • EF32CA79-F786-499C-91E8-DAC568E41BB9.jpeg
    EF32CA79-F786-499C-91E8-DAC568E41BB9.jpeg
    381.9 KB · Views: 71
Joined
Oct 23, 2011
Messages
237
Motherboard
Asus ROG Strix Z390-I
CPU
i9-9900K OC 5GHz
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Yesterday I installed macOS Catalina 10.15.2 Public Beta 1.
Now it seems to work OOB even without WhatEvergreen and the agdpmode boot flag. VideoProc says no HEVC acceleration.

Using also WhatEvergreen it seems to work fine, including HEVC acceleration and DRM contents. I didn't tried without the boot flag.
I think I have solved my "blockFenceInterrupt" freezes but I need more testing. I also disabled my DW1820A.
 
Joined
Mar 28, 2011
Messages
253
Motherboard
Asus Tuf X299 Mark 1
CPU
i9-7900X
Graphics
RX 5700 XT
Mobile Phone
  1. iOS
Take a look here on the X299 Mojave thread :
iMac Pro X299 - Live the Future now with macOS 10.14 Mojave
"The actual HWSensor and FakeSMC kext distribution of @interferenc can be assessed at https://github.com/interferenc/HWSensors"

Thank you very much, I tried it.
If I use that version, Catalina doesn't start me.
I am using the version that I install in high sierra and it works for me and I see cpu temperature, hard drives, voltages but not gpu.

let's see if there is any user of x299 who can tell me which version of fakesmc and sensors works well.
 

Attachments

  • Captura de pantalla 2019-11-18 a las 15.57.29.png
    Captura de pantalla 2019-11-18 a las 15.57.29.png
    724.7 KB · Views: 128
Joined
Mar 18, 2017
Messages
986
Motherboard
ASUS ROG Rampage VI Extreme
CPU
i9-7940X
Graphics
2 X VEGA 56
Mac
  1. iMac
  2. Mac mini
Mobile Phone
  1. iOS
Thank you very much, I tried it.
If I use that version, Catalina doesn't start me.
I am using the version that I install in high sierra and it works for me and I see cpu temperature, hard drives, voltages but not gpu.

let's see if there is any user of x299 who can tell me which version of fakesmc and sensors works well.

I agree with you. I was still yesterday on my main system on Mojave and High Sierra, so may be the sensors don't work on Catalina. I use Virtualsmc.kext to boot on it...Then the problem appears more complex, I am very busy this afternoon but I will take a look tonight.
 
Last edited:
Top