Contribute
Register

AMD Radeon Navi GPU

Joined
Sep 30, 2018
Messages
21
Motherboard
ASUS PRIME Z390-A
CPU
i5-9600k
Graphics
Sapphire RX 5700XT Nitro+
I'm having some artifacts problem with the Sapphire RX5700XT Nitro+ in the installation program. It seems like that doesn't recognize the resolution of the display. I'm using this setup in config: Lilu & Whatevergreen, disabled IGPU and boot arg. agdpmod=pikera, SMBIOS iMac 19,1
 
Joined
May 28, 2019
Messages
17
Motherboard
Gigabyte Z390 Aorus Pro
CPU
i9-9900K
Graphics
RX 5700 XT
Mac
  1. Mac mini
Mobile Phone
  1. iOS
I try to use clean installation now and get some interesting setup screen (see screenshot) :lol: using six sense I find invisible buttons.

I'm using this setup in config:
- NO Lilu & Whatevergreen,
- Enabled IGPU,
- NO boot arg. agdpmod=pikera,
- SMBIOS Mac Pro 6,1
 

Attachments

  • IMG_0300.jpeg
    IMG_0300.jpeg
    2.3 MB · Views: 101
Joined
Oct 23, 2011
Messages
237
Motherboard
Asus ROG Strix Z390-I
CPU
i9-9900K OC 5GHz
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hi, someone encountered problem with audio using the GPU also for audio output?
Mine is jerky and has a very low quality.. tried also with another cable
 
Joined
Dec 26, 2018
Messages
6
Motherboard
X570m Pro4
CPU
Ryzen 5 3600
Graphics
5700 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I try to use clean installation now and get some interesting setup screen (see screenshot) :lol: using six sense I find invisible buttons.

You have to proceed somehow with the installation. When it installs, it should boot fine without all these screen glitches. I think this is bad Navi drivers, Apple probably will fix this in later macOS updates.

Update: I've used MacBook to install Mac on SSD, and then I've booted my hackintosh from it.
 
Joined
Jul 20, 2014
Messages
722
Motherboard
Asrock X299 Creator
CPU
i9 10900X
Graphics
RX 5700XT
Some Information.
I plugged both a Radeon VII and an RX 5700 XT on the motherboard: System info show both use x16 PCIe
I made several quick tests with DAVINCI and the "candle project"
Display is 3440x1440 via DP
View attachment 434216
What I learn :
1 - RX 5700 XT in a little less powerful than Radeon VII ➧ RX 5700 XT has better price/performance ratio
2 - OpenCl is dead .... slow
3 - Pluging the display on computing GPU has a minor impact on performances (It's not true with RED RAW GPU debayering for example)
4 - I can't figure how Final Cut Pro 10.4.7 select the GPU despite the new preference menu
5 - RX 5700 XT (Gigabyte Gaming OC) is less noisy than the Radeon VII when fully loaded
6 - RX 5700 XT (Gigabyte Gaming OC) is a little wider than 2 PCI slot ➧ multiple GPU difficulties

After I Superscale (very GPU intensive) the media to 8K and make the project to 8K, to find a if the RADEON VII's 16G is an advantage. 2 TNR Test give the same result with each computing GPU

Hope this helps
Another Round :

Hardware and Software
All the tests use DaVinci Resolve Studio 16.1.1
The Project is a Simple Timeline with 3 BRAW (4.6K) heavily graded
The results are in “fps” (frame per second)

  • Imac 2019 – Core i9 8 cores 3.6 Ghz – RAM 64 GB – Pro Vega 48 8GB
  • Hack X299 – Core i9 12 cores 2.9 Ghz – RAM 32 GB – RX 5700XT 8GB
  • Hack X299 – Core i9 12 cores 2.9 Ghz – RAM 32 GB – RX 5700XT 8GB & GT 710 2GB
  • Hack X299 – Core i9 12 cores 2.9 Ghz – RAM 32 GB – GTX 1080 Ti 11GB
  • Hack X299 – Core i9 12 cores 2.9 Ghz – RAM 32 GB – GTX 1080 Ti 11GB & GT 710 2GB
With the Dual GPUs, only one is used for compute with Resolve and the other is only for GUI

The Test Results
1080Ti_vs_RX5700XT_vs_VegaPro48.png
What I learned
  • The Old and Expensive (more than 800€ a year and half ago) GTX 1080 Ti is the best with FHD timeline
  • The Very expensive (RX 580X + 540€) Vega Pro 48 is almost as powerful as the RX 5700 XT
  • The RX 5700 XT (450€) is the best for UHD timeline
  • For AMD GPU, the GUI has a small impact on performances
  • There is something definitely wrong the NVIDIA web driver ➧ You need a dedicated GPU for the GUI
Hope this helps
 
Last edited:
Joined
May 28, 2019
Messages
17
Motherboard
Gigabyte Z390 Aorus Pro
CPU
i9-9900K
Graphics
RX 5700 XT
Mac
  1. Mac mini
Mobile Phone
  1. iOS
You have to proceed somehow with the installation. When it installs, it should boot fine without all these screen glitches. I think this is bad Navi drivers, Apple probably will fix this in later macOS updates.

UPD: I've used Macbook to install Mac on SSD and then I've booted my hackintosh from it.

Yep! All works fine after installation. And I use this EFI https://www.tonymacx86.com/threads/update-directly-to-macos-catalina.284463/post-2023498 instead of my old EFI from Mojave.
 
Joined
Dec 28, 2018
Messages
24
Motherboard
Gigabyte Z390 Aorus Pro
CPU
i9-9900K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
ok, I will add my benchmarks of Sapphire Radeon PULSE RX 5700 XT 8G, 8GB GDDR6, I am unable to make SMBIOS iMac19,1 to work so I have to use MacPro6,1, here is openCl and Metal score:
Screenshot 2019-11-21 at 21.55.55.png
Screenshot 2019-11-21 at 21.55.50.png
Screenshot 2019-11-21 at 21.51.58.png


here is my clover efi setup, if you find anything I can make better, don't hesitate to write me

Just find out that my system don't have HW acceleration in Encoder and Hackintool - Decoder Failed
 
Last edited:
Joined
Sep 5, 2012
Messages
26
Motherboard
Asus TUF Gaming Z390M-Pro
CPU
I5-9600K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
After recently updating BIOS on my motherboard (Asus TUF Gaming Z390M-Pro) from an outdated one to the latest one I had issues with macOS stuttering extremely on any HDD and non-trivial GPU activity (like hovering over menus with the mouse) when 5700 XT was used. I *think* what fixed this was to disable the whole PCIE power management section in BIOS. Since then it's been flawless. I'll try to do some checks today to verify that.

Just my 0.02€.

By the way - my 5700XT is at least two times slower on macOS than in Windows, at least in Geekbench.
 
Joined
Nov 13, 2012
Messages
78
Motherboard
Asrock Z390 Phantom Gaming 6
CPU
i9-9900K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
By the way - my 5700XT is at least two times slower on macOS than in Windows, at least in Geekbench.

Yea for compute workloads that is expected because macOS uses aggressive powersaving. Disabling automatic undervolting and clock gating by injecting these properties for your card might boost your compute performance considerably at the expense of some power saving:
PP_DisableDIDT=1 (clockgating)
PP_DisableULV=1 (undervolting)
 
Joined
Nov 21, 2019
Messages
15
Motherboard
Asrock X99M Extreme4
CPU
Xeon E5-2690v4
Graphics
RX 5700 XT
You have to proceed somehow with the installation. When it installs, it should boot fine without all these screen glitches. I think this is bad Navi drivers, Apple probably will fix this in later macOS updates.

Update: I've used MacBook to install Mac on SSD, and then I've booted my hackintosh from it.

I have the same problem, how can I proceed with the installation? In my case mouse is working, but I cant click see this thread: klick me

Nevermind, found a way to do it (with voiceover):
https://discussions.apple.com/thread/7024975
 
Last edited:
Top