Contribute
Register

After Installation, Lost Audio

toleda

Moderator
Joined
May 20, 2010
Messages
24,420
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
512K, LC, Power Mac
Mobile Phone
iOS
Mojave does not support Audio ID/layout-id = 1 or 3.
Temporary workarounds:
a. set Audio ID/layout-id = 2 (Desktop: 887, 888, 889, 892, 898, 1150, 1220 only)
b. AppleALC.kext only, see Workaround incompatible layouts · vit9696

Permanent fix:
a. New Audio IDs added to current solutions, TBD.
 
Last edited:
Joined
Nov 11, 2010
Messages
367
Motherboard
Gigabyte GA-H97-D3H
CPU
i7-4790
Graphics
HD 4600 & R9 270X
Mac
iMac, Mac Pro
Mobile Phone
Android, iOS, Other
Mojave does not support Audio ID/layout-id = 1 or 3.
Temporary workarounds:
a. set Audio ID/layout-id = 2 (Desktop: 887, 888, 889, 892, 898, 1150, 1220 only)
b. AppleALC.kext only, see Workaround incompatible layouts · vit9696

Permanent fix:
a. New Audio IDs added to current solutions, TBD.
toleda my audio is ALC 888b .. layout id is in 2 in clover but no audio
 
Joined
Jan 26, 2014
Messages
1,381
Motherboard
Asus P5LP-LE
CPU
Core 2 Duo
Graphics
Nvidia GeForce GT 640
Mac
Mac Pro
Mobile Phone
iOS
toleda my audio is ALC 888b .. layout id is in 2 in clover but no audio
As Toleda said you must set to layoutID 2 and use AppleALC.kext. You must also use Lilu.kext with bootlargs -lilubeta -alcbeta.
Lilu.kext and AppleALC.kext must be in the same folder.
 

toleda

Moderator
Joined
May 20, 2010
Messages
24,420
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
512K, LC, Power Mac
Mobile Phone
iOS
Joined
Jul 13, 2016
Messages
871
Motherboard
ASUS ROG STRIX Z370-F
CPU
I5-8600K
Graphics
RX580
Mac
Mac mini, Mac Pro
Mobile Phone
iOS
Audio ID: 5 is not supported on this site
Good thing I was not looking for support on audio. I was asking what the id was for in general no specific number. Because for the most part mine just worked.
 
Joined
Sep 18, 2017
Messages
113
Motherboard
H170N-wifi
CPU
I3-7100
Graphics
HD630
Mobile Phone
iOS
use applealc 1.2.8. it works for me
 
Joined
Apr 6, 2011
Messages
60
Motherboard
Asus Strix Z270F Gaming
CPU
i5 7500
Graphics
RX 580
Mobile Phone
Android, iOS
I am using applealc 1.2.8 . and also booting with -alcbeta , alcid= ,alcaaplid and -lilubetaall

But what ever layoutid i use i have still no audio..

My audio is ALC1220a anyone got this to work??

Here is my config.plist is there anything wrong with this..
 

Attachments

Joined
Jul 13, 2016
Messages
871
Motherboard
ASUS ROG STRIX Z370-F
CPU
I5-8600K
Graphics
RX580
Mac
Mac mini, Mac Pro
Mobile Phone
iOS
I am using applealc 1.2.8 . and also booting with -alcbeta , alcid= ,alcaaplid and -lilubetaall

But what ever layoutid i use i have still no audio..

My audio is ALC1220a anyone got this to work??

Here is my config.plist is there anything wrong with this..

I just use Lilubetaall, I do not know what all that other stuff is for.

Layout 2 I think is out the window and that's what your config says you are using.

Someone also said that removing whatevergreen if you have that fixed their sound issue though it might have just been coincidence.
 
Top