Contribute
Register

10.11.2 Audio don't working - MSI Z97 PC Mate ALC 887

Status
Not open for further replies.
Joined
Jun 17, 2015
Messages
13
Motherboard
MSI Z97 PC Mate
CPU
Intel Core i5 4690K
Graphics
Palit GTX 1050 Ti
Mobile Phone
  1. Android
Hi guys I need some help. I have Installed El Capitan 10.11.2 on my PC and audio now don't working. I have tried ALC 887 / 888B and all of the VoodooHDA kexts, bot no one works.:banghead: Pls help me!

My build is:
MSI Z97 PC Mate
Pentium G3460
GTX 750 Ti
8 GB DDR3 Ram
Thx!
 
Joined
Nov 26, 2015
Messages
3
Motherboard
MSI Z97 PC Mate
CPU
Intel i5-4690k
Graphics
GTX 660
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
  1. iOS
Thx the reply I tried reinstalling the soundkexts and now it works with an older version of Voodoo

Could you please tell me how you managed to make it work? I tried a lot of methods without success.

Thanks



EDIT
Managed to get it to work!
Audio is not very high (much lower than my MBP) but it's better than no audio at all... when I use headphones I have to turn it to max to obtain a decent output. But I guess volume is subjective, and I tend to listen to music at very high volume (max on iPod and iPhone).

Here is what I've done, so other people could follow the steps.

First of all, if you previously tried other ways to enable audio, the best thing to do is start with a clean slate. So follow Toleda's exceptionally good guide (Toleda, if you're reading this, thank you very much!) and restore AppleHDA. I found out that the only way this worked for me was by launching the vanilla El Capitan Installer, after having moved the necessary kexts for my system in EFI>Clover>Extensions>10.11.

Doing this will restore all the kexts to stock. I was able to keep all other files and settings.

Then open HDD>System>Library>Extensions and delete AppleHDA.kext (back it up before).

Open MultiBeast and install VooDooHDA v2.8.6 (newer versions are not working).

Then reboot, and that's pretty much all. I had some background noise and realised that in the Voodoo panel in system preferences the Input gain was set, so i turned it off.

The strange thing was that before using Voodoo i didn't have a codec_id for audio. Looking around the web everyone pretty much said it was a hardware issue. After using Voodoo i have a proper codec, DPCI Manager recognises my audio as Realtek 888b and everything works. :crazy:

I just hope that it stays like this. I also hope that what I've written is understandable (I'm not a native English speaker).

Thanks to all the people in this community for the work you put into this stuff, maybe someone will benefit from this really small contribution.
 
Joined
Jan 20, 2016
Messages
68
Motherboard
ASRock Z97 Anniversary
CPU
i5-4690K
Graphics
GTX 970
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. Android
Could you please tell me how you managed to make it work? I tried a lot of methods without success.

Thanks



EDIT
Managed to get it to work!
Audio is not very high (much lower than my MBP) but it's better than no audio at all... when I use headphones I have to turn it to max to obtain a decent output. But I guess volume is subjective, and I tend to listen to music at very high volume (max on iPod and iPhone).

Here is what I've done, so other people could follow the steps.

First of all, if you previously tried other ways to enable audio, the best thing to do is start with a clean slate. So follow Toleda's exceptionally good guide (Toleda, if you're reading this, thank you very much!) and restore AppleHDA. I found out that the only way this worked for me was by launching the vanilla El Capitan Installer, after having moved the necessary kexts for my system in EFI>Clover>Extensions>10.11.

Doing this will restore all the kexts to stock. I was able to keep all other files and settings.


Then open HDD>System>Library>Extensions and delete AppleHDA.kext (back it up before).

Open MultiBeast and install VooDooHDA v2.8.6 (newer versions are not working).

Then reboot, and that's pretty much all. I had some background noise and realised that in the Voodoo panel in system preferences the Input gain was set, so i turned it off.

The strange thing was that before using Voodoo i didn't have a codec_id for audio. Looking around the web everyone pretty much said it was a hardware issue. After using Voodoo i have a proper codec, DPCI Manager recognises my audio as Realtek 888b and everything works. :crazy:

I just hope that it stays like this. I also hope that what I've written is understandable (I'm not a native English speaker).

Thanks to all the people in this community for the work you put into this stuff, maybe someone will benefit from this really small contribution.


What do you mean by this? Launch the installer via Unibeast USB? I have a different motherboard but ALC 887 audio and I cannot get it to work. Wondering exactly what steps you took to get your audio working


EDIT

Never mind! Using Multibeast I installed VoodooHDA v2.8.6 and it works!!!! Thank you
 
Last edited:
Status
Not open for further replies.
Top