Contribute
Register

ZBook 15 G3 success (i7-6700hq)

Joined
Dec 24, 2012
Messages
39
Motherboard
HP folio 1040 g2 (Clover V4813)
CPU
i5-5300u
Graphics
HD5500, FHD
Mobile Phone
Android
Hello fellow ZBook owners,
good news: your laptop is a near perfect machine for macos high sierra.

Open issues:
  • HDMI output (but i'm sure it'll work!)
  • strange reboot on shut down if the PSU is plugged (i could use some help with this :confused:)
This small guide aim to help you with the trouble you may (and probably will) encounter at the moment while following this https://www.tonymacx86.com/threads/guide-hp-probook-elitebook-zbook-using-clover-uefi-hotpatch.232948/ .

installation integration to the original guide:
Add the "SSDT-DiscreteSpoof.aml" file in EFI/CLOVER/ACPI/patched, look here for additional information information: https://www.tonymacx86.com/threads/fix-window-server-service-only-ran-for-0-seconds-with-dual-gpu.233092/.

post installation integration to the original guide:
after the ./install_downloads.sh command, you'll probably experience a kp after reboot: don't worry, drop the "SSDT-ZBook-G3-Skylake" and now you should be able to reach the desktop. Remove "SSDT-ZBook-G3-Skylake" from the EFI/CLOVER/ACPI/patched folder.
Due to the fact that don't know how to write a clover patch for hotpatching, i just old style patched my DSDT. Here https://www.tonymacx86.com/threads/guide-patching-laptop-dsdt-ssdts.152573/ the instruction i followed.
NOTE: use the refs.txt attached for disassembling.
Now, if i recall correctly, you'll get a "Invalid type (Target is [Package], Source must be a package also)”. Delete the problematic line: trust me, i have read't somewhere.
Apply the batteryPatch in attachment, they are for the greatest part from RehabMan.
Inject, from clover, the audio layout 7.
From clover, inject the intel with ig-platform-id=0x19160000.

Now, disable some ACPI patch: i'm actually using only:

  1. change _DSM to XDSM
  2. change _OSI to XOSI
  3. change GFX0 to IGPU
  4. change HDAS to HDEF
  5. change BOD3 to HDAU
  6. RTC fix

anddddd, that's it, for now at least.
i've included my clover folder as reference.

EDIT: i removed the clover folder, it's outdated
EDIT 2: The whole guide is now senseless: follow the thread and make the small adjustment needed to make the rehabMan's method work.
Frank
 
Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,088
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hello fellow ZBook owners,
good news: your laptop is a near perfect machine for macos high sierra.

Open issues:
  • HDMI output (but i'm sure it'll work!)
  • strange reboot on shut down if the PSU is plugged (i could use some help with this :confused:)
This small guide aim to help you with the trouble you may (and probably will) encounter at the moment while following this https://www.tonymacx86.com/threads/guide-hp-probook-elitebook-zbook-using-clover-uefi-hotpatch.232948/ .

installation integration to the original guide:
Add the "SSDT-DiscreteSpoof.aml" file in EFI/CLOVER/ACPI/patched, look here for additional information information: https://www.tonymacx86.com/threads/fix-window-server-service-only-ran-for-0-seconds-with-dual-gpu.233092/.

post installation integration to the original guide:
after the ./install_downloads.sh command, you'll probably experience a kp after reboot: don't worry, drop the "SSDT-ZBook-G3-Skylake" and now you should be able to reach the desktop. Remove "SSDT-ZBook-G3-Skylake" from the EFI/CLOVER/ACPI/patched folder.
Due to the fact that don't know how to write a clover patch for hotpatching, i just old style patched my DSDT. Here https://www.tonymacx86.com/threads/guide-patching-laptop-dsdt-ssdts.152573/ the instruction i followed.
NOTE: use the refs.txt attached for disassembling.
Now, if i recall correctly, you'll get a "Invalid type (Target is [Package], Source must be a package also)”. Delete the problematic line: trust me, i have read't somewhere.
Apply the batteryPatch in attachment, they are for the greatest part from RehabMan.
Inject, from clover, the audio layout 7.
From clover, inject the intel with ig-platform-id=0x19160000.

Now, disable some ACPI patch: i'm actually using only:

  1. change _DSM to XDSM
  2. change _OSI to XOSI
  3. change GFX0 to IGPU
  4. change HDAS to HDEF
  5. change BOD3 to HDAU
  6. RTC fix

anddddd, that's it, for now at least.
i've included my clover folder as reference.
Frank
See guide:
https://www.tonymacx86.com/threads/guide-hp-probook-elitebook-zbook-using-clover-uefi-hotpatch.232948/
 
Joined
Dec 24, 2012
Messages
39
Motherboard
HP folio 1040 g2 (Clover V4813)
CPU
i5-5300u
Graphics
HD5500, FHD
Mobile Phone
Android
i saw it, again thanks for that guide.
As i said, i've been forced to move away from the guide due to a KP if i use the suggested set of ACPI hotpatch + SSDT-ZBook-G3-Skylake. May i provide some information to help you fix it?

I read also that probably the hdmi output is connected to the discrete gpu, which is disabled, so i will just ignore it for now.

The other issue, the "reboot on shutdown if AC ", is the only open issue (as far as i know).
I tried the shutdown fix patch, v1 and v2, with no luck. I tried also the common clover fixes for the shutdown problem, still no luck =(
Could you give me some hints or take a look at the attached efi folder?
regards,
Frank
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,088
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
i saw it, again thanks for that guide.
As i said, i've been forced to move away from the guide due to a KP if i use the suggested set of ACPI hotpatch + SSDT-ZBook-G3-Skylake. May i provide some information to help you fix it?

I read also that probably the hdmi output is connected to the discrete gpu, which is disabled, so i will just ignore it for now.

The other issue, the "reboot on shutdown if AC ", is the only open issue (as far as i know).
I tried the shutdown fix patch, v1 and v2, with no luck. I tried also the common clover fixes for the shutdown problem, still no luck =(
Could you give me some hints or take a look at the attached efi folder?
regards,
Frank
Follow guide as written. If you have an issue, attach problem reporting files.
Read FAQ, "Problem Reporting". Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
 
Joined
Dec 24, 2012
Messages
39
Motherboard
HP folio 1040 g2 (Clover V4813)
CPU
i5-5300u
Graphics
HD5500, FHD
Mobile Phone
Android
Ciao,
as attachment1, the KP i get after the ./install_download.sh command.
I'm able to get through that error by disabling the patch "EC0 to EC" in clover.
As attachment2, another issue, i just added the"SSDT-DiscreteSpoof" file to EFI/CLOVER/ACPI/patched to get ride of it.
The archive.zip archive is the common problem reporting files collection
note: i've added the boot arg -v and changed the GUI->ScreenResolution to 1920*1080 in config_ZBook_G3_Skylake.plist (xcode as been used for the file editing)

regards,
Frank
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,088
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Ciao,
as attachment1, the KP i get after the ./install_download.sh command.
I'm able to get through that error by disabling the patch "EC0 to EC" in clover.
As attachment2, another issue, i just added the"SSDT-DiscreteSpoof" file to EFI/CLOVER/ACPI/patched to get ride of it.
The archive.zip archive is the common problem reporting files collection
note: i've added the boot arg -v and changed the GUI->ScreenResolution to 1920*1080 in config_ZBook_G3_Skylake.plist (xcode as been used for the file editing)

regards,
Frank
I see no issue with the EC0->EC patch.
Your native ACPI uses EC0, no references to EC, so EC0->EC does not pose a problem.
SSDT-ZBook-G3-Skylake.aml assumes EC0->EC rename.
 
Joined
Dec 24, 2012
Messages
39
Motherboard
HP folio 1040 g2 (Clover V4813)
CPU
i5-5300u
Graphics
HD5500, FHD
Mobile Phone
Android
technically the patch is fine, the problem is in the SSDT-ZBook-G3-Skylake.aml, something related with the EC.
I can avoid the KP either by removing the patch EC0->EC or by dropping the SSDT-ZBook-G3-Skylake.aml file
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,088
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
technically the patch is fine, the problem is in the SSDT-ZBook-G3-Skylake.aml, something related with the EC.
I can avoid the KP either by removing the patch EC0->EC or by dropping the SSDT-ZBook-G3-Skylake.aml file
No idea without "Problem Reporting" files that represent the problem scenario.
You could also start eliminating code from SSDT-ZBook-G3-Skylake.aml until you find the problem (it is pretty easy to eliminate chunks of it as it is built with #include, look at the .dsl source).

Maybe BIOS is not up-to-date...
The ZBook discrete video card may not be able to be disabled with _OFF, which might be part of the problem.

And of course, TRIM+APFS is problematic and TRIM is always enabled with NVMe. You should have installed on HFS+J instead of APFS.
 
Joined
Dec 24, 2012
Messages
39
Motherboard
HP folio 1040 g2 (Clover V4813)
CPU
i5-5300u
Graphics
HD5500, FHD
Mobile Phone
Android
the problem reporting i attached on post 5# isn't about that scenario?

edit: Ok, working on the SSDT-ZBook-G3-Skylake.aml.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,088
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
the problem reporting i attached on post 5# isn't about that scenario?
I would need to see KP details that scrolled off the screen.
And you should do some work on eliminating portions of the model specific SSDT in order to isolate the problem.
Also, please read my comments regarding NMVe/TRIM/APFS.

One thing is if your discrete card is not able to be disabled, you should set RMCF.DGPU=0 ...
 
Last edited:
Top