Contribute
Register

Z490 & Z590

Joined
May 11, 2011
Messages
1,198
Motherboard
Gigabyte B550 Vision D
CPU
Ryzen 5900X
Graphics
RX 6800
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
Ryzen is a beast. So is m1. Competition is good, and is a strong incentive for Intel to innovate, otherwise it will eventually die as customers move away from the platform. We saw the effects of competition in the GPU space. Nvidia was dominant for years, while Radeon floundered. Now with the 6000 series, AMD has delivered a superior product, and has nearly caught up with nVidia in the high end. Yes AMD still doesn't have a DLSS competitor or on-par ray tracing, but it is innovating! And there are rumblings of Intel throwing its hat in the ring.

I believe in 2-3 years, the effects of competition in the CPU space will force all the players involved to deliver superior end products to consumers. Let's see how Zen4/Zen5, Raptor/Meteor/Lunar Lake, M2/M3 perform!
Umm...actually they do. It’s called FSR (FidelityFX Super Resolution) :) > https://www.pcgamer.com/amd-fsr-fidelity-fx-super-resolution-announcement/
 
Joined
May 11, 2011
Messages
1,198
Motherboard
Gigabyte B550 Vision D
CPU
Ryzen 5900X
Graphics
RX 6800
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
Initially I used the same SSD, but later added a SATA drive which is where Windows resides now. I have unplugged it from the system though. So there is no Windows Boot manager in the BIOS. I formatted the NVMe drive from terminal as well just to make sure there are no remnants of Windows partitioning left. I even updated to the latest F5c BIOS but it made no difference.
Sash11,

Aside from the above, have you tried adding the CPU spoofing into the Kernel section under the Emulate section? For my i5-10500 to boot on my board I had to use this:
Cpuid1Data
Code:
EA060900 00000000 00000000 00000000

Cpuid1Mask
Code:
FFFFFFFF 00000000 00000000 00000000

and also use SMBIOS of iMac 18,3
 
Joined
Sep 25, 2019
Messages
73
Motherboard
Gigabyte z590i vision d
CPU
i9-10900K
Graphics
MSI RX5500XT Gaming X 8GB
Sash11,

Aside from the above, have you tried adding the CPU spoofing into the Kernel section under the Emulate section? For my i5-10500 to boot on my board I had to use this:
Cpuid1Data
Code:
EA060900 00000000 00000000 00000000

Cpuid1Mask
Code:
FFFFFFFF 00000000 00000000 00000000

and also use SMBIOS of iMac 18,3
Thank you for suggestion. i9-10900k has the same device ID as native Appple i9-10910 so no CPU masking is required. The successful install worked without any CPU spoofing. Also SMBIOS is supposed to be iMac20,2 according the Dortania's guide. I can play around with CPU and SMBIOS of course...
 

UtterDisbelief

Moderator
Joined
Feb 13, 2012
Messages
5,946
Motherboard
ASRock B560M itx/ac - OC 0.6.8
CPU
i3-10320
Graphics
GT710 - 1920x1080
Mac
  1. iMac
  2. Mac mini
Classic Mac
  1. eMac
  2. iBook
Mobile Phone
  1. iOS
Thank you for suggestion. i9-10900k has the same device ID as native Appple i9-10910 so no CPU masking is required. The successful install worked without any CPU spoofing. Also SMBIOS is supposed to be iMac20,2 according the Dortania's guide. I can play around with CPU and SMBIOS of course...

So have you now managed to re-install Big Sur? (Your original problem.)
 
Joined
Jul 1, 2018
Messages
117
Motherboard
ASUS ROG STRIX Z590-A
CPU
i7-11700K
Graphics
GTX 760
Mac
  1. MacBook
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. iBook
  2. iMac
  3. Power Mac
Mobile Phone
  1. Android
  2. iOS
  3. Other
I have an ASUS Strix Z590-A motherboard with an 11700K. I followed the Dortania OpenCore guide. I may have messed something up because I have absolutely no USB devices. I cant even use USBInjectAll to make a custom SSDT. No mouse, bluetooth, anything over USB. Did I miss something in my EFI?
Thank you!
 
Joined
Sep 25, 2019
Messages
73
Motherboard
Gigabyte z590i vision d
CPU
i9-10900K
Graphics
MSI RX5500XT Gaming X 8GB
I have an ASUS Strix Z590-A motherboard with an 11700K. I followed the Dortania OpenCore guide. I may have messed something up because I have absolutely no USB devices. I cant even use USBInjectAll to make a custom SSDT. No mouse, bluetooth, anything over USB. Did I miss something in my EFI?
Thank you!
I would turn off SIP in NVRAM. Under csr-active-config put FF0F0000 instead of 00000000. Other than that, your EFI looks clean.
 
Joined
Feb 16, 2012
Messages
164
Motherboard
Z590i Vision D
CPU
i7-11700
Graphics
RX560
Mac
  1. MacBook Air
I have an ASUS Strix Z590-A motherboard with an 11700K. I followed the Dortania OpenCore guide. I may have messed something up because I have absolutely no USB devices. I cant even use USBInjectAll to make a custom SSDT. No mouse, bluetooth, anything over USB. Did I miss something in my EFI?
Thank you!
USBInjectAll.kext is too low. Z590 must be 0.7.7
 

Attachments

  • USBInjectAll.kext.zip
    20.6 KB · Views: 19

UtterDisbelief

Moderator
Joined
Feb 13, 2012
Messages
5,946
Motherboard
ASRock B560M itx/ac - OC 0.6.8
CPU
i3-10320
Graphics
GT710 - 1920x1080
Mac
  1. iMac
  2. Mac mini
Classic Mac
  1. eMac
  2. iBook
Mobile Phone
  1. iOS
I have an ASUS Strix Z590-A motherboard with an 11700K. I followed the Dortania OpenCore guide. I may have messed something up because I have absolutely no USB devices. I cant even use USBInjectAll to make a custom SSDT. No mouse, bluetooth, anything over USB. Did I miss something in my EFI?
Thank you!

Hi there.

Check which version of OpenCore you are using.

I'm running 0.6.8 and the files sizes seem different to yours.

Currently I have a test-build of a 500-series motherboard going on and 0.6.8 cured the inactive USB problem after boot.

USBInjectAll 0.7.7 has been updated for 500-series.
 
Joined
Apr 17, 2021
Messages
1
Motherboard
I didn't Read
CPU
the Rules!
Graphics
So, ignore me!
I could fix the audio, and right now, my Hackintosh 11gen Intel is totally complete!!!! I fix it with PCIIDDFake and PCIIDIntelHDMI, with spoofing device id and keeping the layout_id. Right now my final config will be.
* Core i7 11700KF
* Asrock Z590M-Pro4
* DDR4 3000Mhz Kingston HyperX
* NVME MP600 2TB Gen 4
* Radeon RX 5500 XT 8GB
* FENVI FV-HB1200 (Wireless and Bluetooth)

What it Works:
=========

* Processor with all Turbo States (4,7Ghz with all cores)
* LAN (i219-V)
* Wifi and Bluetooth
* Video (VDA Full Asceleration, iMacPro1,1 Smbios)
* All USB Ports
* Audio (ALC897)

So happy right now my Hackintosh with that specs is 100% working and with full performance. I am writing a guide to share how I did it, today or tomorrow I will post it.
Is the guide already online? Where can I find it? Thank you.
 
Top