Contribute
Register

WindowServer memory leak on High Sierra?

Joined
Aug 10, 2016
Messages
11
Motherboard
Gigabyte Z170XP-SLI
CPU
Intel Core i7 7700K
Graphics
EVGA GTX 1080 FTW HYBRID
Mobile Phone
iOS
I updated a few days ago from 10.12.6 and got everything running smoothly. I noticed that after a few hours, WindowServer would be consuming 3GB+ of memory, with a few GB compressed. This caused noticeable slow downs. I am using a 1080 with the latest nvidia drivers for 10.13. Is this happening to anyone else? Is there a way to debug it, preferably without having to use a clean user account for hours?

Logging out and back in is the only way to free up the memory.
 
Joined
Oct 2, 2017
Messages
4
I updated a few days ago from 10.12.6 and got everything running smoothly. I noticed that after a few hours, WindowServer would be consuming 3GB+ of memory, with a few GB compressed. This caused noticeable slow downs. I am using a 1080 with the latest nvidia drivers for 10.13. Is this happening to anyone else? Is there a way to debug it, preferably without having to use a clean user account for hours?

Logging out and back in is the only way to free up the memory.
Having exactly the same issue, and it started to happen after upgrading to 10.13. This is the first post I found related to this issue; tried resetting the SMC, NVRAM, no success; thinking of installing 10.13 from scratch if no one is coming with a solution to this; also, maybe worth mentioning that my laptop is a macbook pro late 2013.
 
Joined
Jul 9, 2014
Messages
1
Mac
Classic Mac
Mobile Phone
I've been running the beta for a couple of months and this has been a continual problem. Restart is the only (temporary) fix I've found. My guess is the bug was created during the re-write to use Metal 2 and will take a software update.
 
Joined
Oct 2, 2017
Messages
4
Is it by any chance something specific to a macbook model? As one of my friends have upgraded but didn't get this issue, and he has a newer model than mine.
 
Joined
Aug 10, 2016
Messages
11
Motherboard
Gigabyte Z170XP-SLI
CPU
Intel Core i7 7700K
Graphics
EVGA GTX 1080 FTW HYBRID
Mobile Phone
iOS
I saw someone mention somewhere else that it happens when you are running in a scaled resolution on a Retina display. This also applies to people with 4K monitors like me using a scaled resolution.
 
Joined
Oct 2, 2017
Messages
4
Oh, I think you're right, and we're close to something here; I've changed the resolution to Default, and now the windowserver process memory consumption looks pretty steady (I hate this resolution, but I believe it's bearable till Apple will issue a proper fix).
So, just to be clear, changing the resolution to default, seems to be a fix for me; will come back later with an update if something changes.
 
Joined
Sep 30, 2015
Messages
3
Motherboard
GA-Z77M-D3H
CPU
i5 3350p
Graphics
gtx650ti
Mac
MacBook Air
Classic Mac
Mobile Phone
iOS
Same here. 4K monitor + GTX 970. WindowServer high memory consumption observed. Changing scale mode to default and everything looks good now. Not sure if this bug is introduced by Apple or Nvidia.
 
Joined
Aug 2, 2015
Messages
7
Mac
Classic Mac
Mobile Phone
Discussion on other forums like macrumor all pointed this window server memory hog to bug related with HIPDI, even with the non-hackintosh MacBook or iMac, and some people resolved it by updated to newest 10.13.1 Beta. I also tried it and succeeded.
 
Joined
Oct 4, 2017
Messages
3
Same issue here, Pro Retina late 2013.. Thank you for the workaround (default resolution), let's wait for Apple fix this bug. My WindowServer was showing 18gb of memory on Activity monitor lol
 
Top